]> git.pld-linux.org Git - packages/libmpcdec.git/blob - libmpcdec.spec
fc574cdc100f441a7e2ea4fca59a57ac80883f8c
[packages/libmpcdec.git] / libmpcdec.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Musepack decoding library
6 Summary(pl):    Biblioteka do dekodowania formatu musepack
7 Name:           libmpcdec
8 Version:        1.2.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://files2.musepack.net/source/%{name}-%{version}.tar.bz2
13 # Source0-md5:  f14e07285b9b102a806649074c1d779b
14 URL:            http://www.musepack.net/
15 BuildRequires:  automake
16 BuildRequires:  autoconf
17 BuildRequires:  libtool
18 BuildRequires:  sed >= 4.0
19 Obsoletes:      libmusepack
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This library handles decoding of the MPC format, which is an audio
24 compression format with a strong emphasis on high quality. It's not
25 lossless, but it is designed for transparency, so that you won't be
26 able to hear differences between the original wave file and the much
27 smaller MPC file. It is based on the MPEG-1 Layer-2 / MP2 algorithms,
28 but since 1997 it has rapidly developed and vastly improved and is now
29 at an advanced stage in which it contains heavily optimized and
30 patentless code.
31
32 %description -l pl
33 Ta biblioteka obs³uguje dekodowanie formatu MPC, który jest formatem
34 kompresji d¼wiêku z naciskiem na wysok± jako¶æ. Nie jest bezstratny,
35 ale jest zaprojektowany dla przezroczysto¶ci tak, ¿e nie mo¿na
36 us³yszeæ ró¿nicy miêdzy oryginalnym plikiem wave a du¿o mniejszym
37 plikiem MPC. Jest oparty na algorytmach MPEG-1 Layer-2 / MP2, ale od
38 1997 roku zosta³ znacznie rozwiniêty i ulepszony, a teraz jest w
39 zaawansowanym stadium, w którym zawiera silnie zoptymalizowany i nie
40 objêty patentami kod.
41
42 %package devel
43 Summary:        Header files for libmpcdec
44 Summary(pl):    Pliki nag³ówkowe do biblioteki libmpcdec
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Obsoletes:      libmusepack-devel
48
49 %description devel
50 Header files for libmpcdec.
51
52 %description devel -l pl
53 Pliki nag³ówkowe do biblioteki libmpcdec.
54
55 %package static
56 Summary:        Static version of the libmpcdec library
57 Summary(pl):    Statyczna wersja biblioteki libmpcdec
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60 Obsoletes:      libmusepack-static
61
62 %description static
63 Static version of the libmpcdec library.
64
65 %description static -l pl
66 Statyczna wersja biblioteki libmpcdec.
67
68 %package examples
69 Summary:        Example of using libmpcdec with documentation
70 Summary(pl):    Przyk³ad u¿ycia libmpcdec z dokumentacj±
71 Group:          Documentation
72
73 %description examples
74 Example of using libmpcdec with documentation.
75
76 %description examples -l pl
77 Przyk³ad u¿ycia libmpcdec z dokumentacj±.
78
79 %prep
80 %setup -q
81
82 %build
83 %{?debug:%{__sed} -i -e "s,-O3 -fomit-frame-pointer,,g" configure.ac}
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install src/sample.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS ChangeLog
110 %attr(755,root,root) %{_libdir}/libmpcdec.so.*.*.*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libmpcdec.so
115 %{_libdir}/libmpcdec.la
116 %{_includedir}/mpcdec
117
118 %if %{with static_libs}
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libmpcdec.a
122 %endif
123
124 %files examples
125 %doc docs/html
126 %defattr(644,root,root,755)
127 %{_examplesdir}/%{name}-%{version}
This page took 0.072704 seconds and 2 git commands to generate.