]> git.pld-linux.org Git - packages/libmp3splt.git/blob - libmp3splt.spec
- up to 0.9.0
[packages/libmp3splt.git] / libmp3splt.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Libraries for the mp3splt project
7 Summary(pl.UTF-8):      Biblioteki do projektu mp3splt
8 Name:           libmp3splt
9 Version:        0.9.0
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/mp3splt/%{name}-%{version}.tar.gz
14 # Source0-md5:  b9b9677ababf823e0739e5caff68aa86
15 Patch0:         ltdl.patch
16 Patch1:         %{name}-format_security.patch
17 URL:            http://mp3splt.sourceforge.net/
18 BuildRequires:  autoconf >= 2.62
19 BuildRequires:  automake
20 BuildRequires:  flac-devel >= 1.2.1
21 BuildRequires:  gettext-devel >= 0.18.3
22 BuildRequires:  libid3tag-devel
23 BuildRequires:  libltdl-devel
24 BuildRequires:  libmad-devel
25 BuildRequires:  libtool
26 BuildRequires:  libvorbis-devel
27 BuildRequires:  pcre-devel >= 1.0
28 BuildRequires:  pkgconfig
29 %if %{with apidocs}
30 BuildRequires:  doxygen
31 BuildRequires:  graphviz
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The mp3Splt project provides utilities to split mp3 and ogg files, by
37 selecting a begin and an end time position, without decoding. It is
38 very useful to split large mp3/ogg into smaller files, or to split
39 entire albums to obtain original tracks. To split an album, the split
40 points and filenames can be selected manually or automatically from
41 CDDB (internet or a local file), or from .cue files.
42
43 It supports automatic silence detection, which can be used to adjust
44 cddb/cue split points. It is also possible to extract tracks from
45 Mp3Wrap or AlbumWrap files in a few seconds.
46
47 %description -l pl.UTF-8
48 Projekt mp3Splt dostarcza narzędzi umożliwiających dzielenie plików w
49 formacie mp3 i ogg poprzez zaznaczenie pozycji początku i końca
50 dzielenia, bez potrzeby dekodowania. Dzielenie dużych plików mp3/ogg
51 na mniejsze części jest bardzo użyteczne, można w ten sposób dzielić
52 całe albumy by otrzymać oryginalne ścieżki. Żeby podzielić album
53 punkty podziału i nazwy plików mogą zostać wybrane ręcznie lub
54 automatycznie z wykorzystaniem CDDB (z Internetu lub lokalnie), albo z
55 plików .cue.
56
57 Projekt wspiera automatyczne wykrywanie ciszy, które może zostać
58 wykorzystane do ustawienia punktów podziału cddb/cue. Jest również
59 możliwe wyciągnięcie ścieżek z plików Mp3Wrap lub AlbumWrap w ciągu
60 kilku sekund.
61
62 %package devel
63 Summary:        Header files for libmp3splt library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmp3splt
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description devel
69 Header files for libmp3splt library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libmp3splt.
73
74 %package static
75 Summary:        Static libmp3splt library
76 Summary(pl.UTF-8):      Statyczna biblioteka libmp3splt
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libmp3splt library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libmp3splt.
85
86 %package apidocs
87 Summary:        libmp3splt API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki libmp3splt
89 Group:          Documentation
90
91 %description apidocs
92 API and internal documentation for libmp3splt library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki libmp3splt.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 sed -i -e 's/fr_FR/fr/;s/de_DE/de/;' po/LINGUAS
102 mv po/de_DE.po po/de.po
103 mv po/fr_FR.po po/fr.po
104
105 %build
106 %{__gettextize}
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --enable-flac \
114         --enable-id3tag \
115         --enable-mp3 \
116         --enable-ogg \
117         --enable-pcre \
118         --with-ltdl-lib=%{_libdir} \
119         --with-ltdl-include=%{_includedir} \
120         %{!?with_static_libs:--disable-static}
121
122 %{__make}
123 %if %{with apidocs}
124 %{__make} -C doc doc
125 %endif
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmp3splt0/*.{a,la}
134 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
135
136 %find_lang libmp3splt0
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files -f libmp3splt0.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README TODO
147 %attr(755,root,root) %{_libdir}/libmp3splt.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libmp3splt.so.0
149 %dir %{_libdir}/libmp3splt0
150 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_flac.so
151 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_mp3.so
152 %attr(755,root,root) %{_libdir}/libmp3splt0/libsplt_ogg.so
153
154 %files devel
155 %defattr(644,root,root,755)
156 %{_libdir}/libmp3splt.so
157 %{_libdir}/libmp3splt.la
158 %{_includedir}/libmp3splt
159 %{_pkgconfigdir}/libmp3splt.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libmp3splt.a
165 %endif
166
167 %if %{with apidocs}
168 %files apidocs
169 %defattr(644,root,root,755)
170 %doc doc/doxygen/*
171 %endif
This page took 0.175758 seconds and 4 git commands to generate.