]> git.pld-linux.org Git - packages/libiodbc.git/blob - libiodbc.spec
- x32 rebuild
[packages/libiodbc.git] / libiodbc.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # don't build iodbcadm and GUI elements in drvproxy
4 #
5 Summary:        iODBC Driver Manager
6 Summary(pl.UTF-8):      Zarządca sterowników iODBC
7 Name:           libiodbc
8 Version:        3.52.7
9 Release:        5
10 License:        LGPL v2 or BSD
11 Group:          Libraries
12 Source0:        http://www.iodbc.org/downloads/iODBC/%{name}-%{version}.tar.gz
13 # Source0-md5:  ddbd274cb31d65be6a78da58fc09079a
14 Patch0:         %{name}-make-jN.patch
15 Patch1:         %{name}-build.patch
16 URL:            http://www.iodbc.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.9.2
19 BuildRequires:  gtk+2-devel >= 1:2.0.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The iODBC Driver Manager is a free implementation of the SAG CLI and
26 ODBC compliant driver manager which allows developers to write ODBC
27 compliant applications that can connect to various databases using
28 appropriate backend drivers.
29
30 The iODBC Driver Manager was originally created by Ke Jin and is
31 currently maintained by OpenLink Software under an LGPL license.
32
33 %description -l pl.UTF-8
34 Zarządca sterowników iODBC jest wolną implementacją zarządcy
35 sterowników zgodną z SAG CLI i ODBC, pozwalającą programistom pisać
36 aplikacje zgodne z ODBC, które mogą łączyć się z różnymi bazami
37 z wykorzystaniem właściwych sterowników wewnętrznych.
38
39 Zarządca sterowników iODBC pierwotnie został napisany przez Ke Jina,
40 aktualnie jest rozwijany przez OpenLink Software.
41
42 %package devel
43 Summary:        Header files for iODBC development
44 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwoju aplikacji na iODBC
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 The iODBC Driver Manager is a free implementation of the SAG CLI and
50 ODBC compliant driver manager which allows developers to write ODBC
51 compliant applications that can connect to various databases using
52 appropriate backend drivers.
53
54 This package contains the header files needed to develop program that
55 use the driver manager.
56
57 %description devel -l pl.UTF-8
58 Zarządca sterowników iODBC jest wolną implementacją zarządcy
59 sterowników zgodną z SAG CLI i ODBC, pozwalającą programistom pisać
60 aplikacje zgodne z ODBC, które mogą łączyć się z różnymi bazami
61 z wykorzystaniem właściwych sterowników wewnętrznych.
62
63 Ten pakiet zawiera pliki nagłówkowe potrzebne do budowania aplikacji
64 korzystających z zarządcy sterowników iODBC.
65
66 %package static
67 Summary:        Static version of iODBC libraries
68 Summary(pl.UTF-8):      Statyczna wersja bibliotek iODBC
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static version of iODBC libraries.
74
75 %description static -l pl.UTF-8
76 Statyczna wersja bibliotek iODBC.
77
78 %package gtk
79 Summary:        GTK+-based GUI for iODBC administration
80 Summary(pl.UTF-8):      Oparty o GTK+ interfejs do administrowania iODBC
81 Group:          X11/Applications
82 Requires:       %{name} = %{version}-%{release}
83
84 %description gtk
85 GTK+-based GUI for iODBC administration.
86
87 %description gtk -l pl.UTF-8
88 Oparty o GTK+ graficzny interfejs do administrowania iODBC.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I admin
98 %{__automake}
99 %{__autoheader}
100 %{__autoconf}
101 %configure \
102         --with-layout=gentoo
103         %{!?with_gtk:--disable-gui}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_sysconfdir}/iodbc
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install etc/odbc.ini.sample $RPM_BUILD_ROOT%{_sysconfdir}/iodbc/odbc.ini
115 rm -rf $RPM_BUILD_ROOT/usr/share/libiodbc/samples/
116
117 # dlopened by lib*.so
118 rm -f $RPM_BUILD_ROOT%{_libdir}/lib{iodbcadm,drvproxy}.{a,la}
119 # build process side-effects
120 rm -f $RPM_BUILD_ROOT%{_libdir}/lib{iodbcadm,drvproxy}-gtk.{a,la}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %post   gtk -p /sbin/ldconfig
129 %postun gtk -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog LICENSE LICENSE.BSD NEWS README
134 %dir %{_sysconfdir}/iodbc
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/iodbc/odbc.ini
136 %attr(755,root,root) %{_bindir}/iodbctest
137 %attr(755,root,root) %{_bindir}/iodbctestw
138 %attr(755,root,root) %{_libdir}/libiodbc.so.2.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libiodbc.so.2
140 %attr(755,root,root) %{_libdir}/libiodbcinst.so.2.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libiodbcinst.so.2
142 %{_mandir}/man1/iodbctest.1*
143 %{_mandir}/man1/iodbctestw.1
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/iodbc-config
148 %attr(755,root,root) %{_libdir}/libiodbc.so
149 %attr(755,root,root) %{_libdir}/libiodbcinst.so
150 %{_libdir}/libiodbc.la
151 %{_libdir}/libiodbcinst.la
152 %{_includedir}/iodbc
153 %{_pkgconfigdir}/libiodbc.pc
154 %{_mandir}/man1/iodbc-config.1*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libiodbc.a
159 %{_libdir}/libiodbcinst.a
160
161 %if %{with gtk}
162 %files gtk
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/iodbcadm-gtk
165 %attr(755,root,root) %{_libdir}/libiodbcadm.so.2.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libiodbcadm.so.2
167 %attr(755,root,root) %{_libdir}/libdrvproxy.so.2.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libdrvproxy.so.2
169 %attr(755,root,root) %{_libdir}/libiodbcadm.so
170 %attr(755,root,root) %{_libdir}/libdrvproxy.so
171 %{_mandir}/man1/iodbcadm-gtk.1*
172 %endif
This page took 0.194776 seconds and 3 git commands to generate.