]> git.pld-linux.org Git - packages/libgusb.git/blob - libgusb.spec
- up to 0.2.11
[packages/libgusb.git] / libgusb.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # Vala API
5
6 Summary:        GUsb - GObject wrapper for libusb1 library
7 Summary(pl.UTF-8):      GUsb - obudowanie GObject biblioteki libusb1
8 Name:           libgusb
9 Version:        0.2.11
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        https://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
14 # Source0-md5:  fa2b41b828c749f9190edf888948a77b
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  glib2-devel >= 1:2.38.0
18 BuildRequires:  gobject-introspection-devel >= 1.29
19 BuildRequires:  gtk-doc >= 1.9
20 BuildRequires:  libtool >= 2:2.2
21 BuildRequires:  libusb-devel >= 1.0.19
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 %{?with_vala:BuildRequires:     vala >= 2:0.16}
25 BuildRequires:  xz
26 Requires:       glib2 >= 1:2.38.0
27 Requires:       libusb >= 1.0.19
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 GUsb is a GObject wrapper for libusb1 that makes it easy to do
32 asynchronous control, bulk and interrupt transfers with proper
33 cancellation and integration into a mainloop. This makes it easy to
34 integrate low level USB transfers with your high-level application or
35 system daemon.
36
37 %description -l pl.UTF-8
38 GUsb to obudowanie GObject biblioteki libusb1, ułatwiające
39 asynchroniczne sterowanie oraz przesyłanie danych (typu bulk jak i z
40 użyciem przerwań) z właściwym przerywaniem i integracją w głównej
41 pętli. Ułatwia to integrowanie niskopoziomowego przesyłania danych po
42 USB w wysokopoziomowej aplikacji lub demonie systemowym.
43
44 %package devel
45 Summary:        Header files for GUsb library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GUsb
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.38.0
50 Requires:       libusb-devel >= 1.0.19
51
52 %description devel
53 Header files for GUsb library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki GUsb.
57
58 %package static
59 Summary:        Static GUsb library
60 Summary(pl.UTF-8):      Statyczna biblioteka GUsb
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GUsb library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka GUsb.
69
70 %package apidocs
71 Summary:        GUsb API documentation
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki GUsb
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API and internal documentation for GUsb library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki GUsb.
83
84 %package -n vala-libgusb
85 Summary:        Vala API for libgusb
86 Summary(pl.UTF-8):      API języka Vala do libgusb
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.16
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-libgusb
95 Vala API for libgusb.
96
97 %description -n vala-libgusb -l pl.UTF-8
98 API języka Vala do libgusb.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         %{!?with_vala:--disable-vala} \
112         --with-html-dir=%{_gtkdocdir}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # obsoleted by pkg-config
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgusb.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS MAINTAINERS NEWS README TODO
133 %attr(755,root,root) %{_bindir}/gusbcmd
134 %attr(755,root,root) %{_libdir}/libgusb.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgusb.so.2
136 %{_libdir}/girepository-1.0/GUsb-1.0.typelib
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libgusb.so
141 %{_includedir}/gusb-1
142 %{_datadir}/gir-1.0/GUsb-1.0.gir
143 %{_pkgconfigdir}/gusb.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libgusb.a
148
149 %if %{with apidocs}
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_gtkdocdir}/gusb
153 %endif
154
155 %if %{with vala}
156 %files -n vala-libgusb
157 %defattr(644,root,root,755)
158 %{_datadir}/vala/vapi/gusb.vapi
159 %endif
This page took 0.079761 seconds and 3 git commands to generate.