]> git.pld-linux.org Git - packages/libgltf.git/blob - libgltf.spec
- release 4 (by relup.sh)
[packages/libgltf.git] / libgltf.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        C++ library for rendering OpenGL models stored in glTF format
6 Summary(pl.UTF-8):      Biblioteka C++ do renderowania modeli OpenGL zapisanych w formacie glTF
7 Name:           libgltf
8 Version:        0.0.2
9 Release:        4
10 License:        MPL v2.0
11 Group:          Libraries
12 Source0:        http://dev-www.libreoffice.org/src/libgltf/%{name}-%{version}.tar.bz2
13 # Source0-md5:  d63a9f47ab048f5009d90693d6aa6424
14 URL:            http://www.libreoffice.org/
15 BuildRequires:  GLM >= 0.9.0.0
16 BuildRequires:  OpenGL-devel >= 3.0
17 BuildRequires:  boost-devel >= 1.41.0
18 BuildRequires:  glew-devel >= 1.8.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  pkgconfig >= 1:0.20
21 Requires:       OpenGL >= 3.0
22 Requires:       glew >= 1.8.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libgltf is a C++ library for rendering OpenGL models stored in glTF
27 format.
28
29 The glTF, the GL Transmission Format, is the runtime asset format for
30 the GL APIs: WebGL, OpenGL ES, and OpenGL. glTF bridges the gap
31 between formats used by modeling tools and the GL APIs. You can read
32 more about the format in it's specification:
33 https://github.com/KhronosGroup/glTF/blob/schema/specification/README.md
34
35 libgltf provides methods to load the OpenGL scene from glTF format and
36 render it into an existing OpenGL context. libgltf also allows to
37 change the camera position so the scene can be displayed from
38 different points of view.
39
40 Summary, libgltf can be a good base of a glTF viewer.
41
42 %description -l pl.UTF-8
43 libgltf to biblioteka C++ do renderowania modeli OpenGL zapisanych w
44 formacie glTF.
45
46 glTF (GL Transmission Format - format transmisyjny GL) to format
47 danych uruchomieniowych dla API GL: WebGL, OpenGL ES oraz OpenGL. glTF
48 wypełnia lukę między formatami używanymi przez narzędzia modelujące
49 oraz API GL. Więcej o formacie można znaleźć w specyfikacji:
50 https://github.com/KhronosGroup/glTF/blob/schema/specification/README.md
51
52 libgltf udostępnia metody do wczytywania sceny OpenGL z formatu glTF
53 oraz renderowania jej w istniejącym kontekście OpenGL. Pozwala także
54 zmieniać położenie kamery, dzięki czemu scena może być wyświetlana z
55 innych punktów widzenia.
56
57 Podsumowując, libgltf może być dobrą podstawą dla przeglądarki glTF.
58
59 %package devel
60 Summary:        Header files for libgltf library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgltf
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       GLM >= 0.9.0.0
65 Requires:       glew-devel >= 1.8.0
66 Requires:       libstdc++-devel
67
68 %description devel
69 Header files for libgltf library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libgltf.
73
74 %package static
75 Summary:        Static libgltf library
76 Summary(pl.UTF-8):      Statyczna biblioteka libgltf
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libgltf library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libgltf.
85
86 %prep
87 %setup -q
88
89 %build
90 %configure \
91         --disable-silent-rules \
92         %{?with_static_libs:--enable-static}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgltf-*.la
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog LICENSE NEWS README
113 %attr(755,root,root) %{_libdir}/libgltf-0.0.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libgltf-0.0.so.0
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libgltf-0.0.so
119 %{_includedir}/libgltf-0.0
120 %{_pkgconfigdir}/libgltf-0.0.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libgltf-0.0.a
126 %endif
This page took 0.190218 seconds and 3 git commands to generate.