]> git.pld-linux.org Git - packages/libgcrypt.git/commitdiff
up to 1.9.0 auto/th/libgcrypt-1.9.0-1
authorJan Palus <atler@pld-linux.org>
Wed, 20 Jan 2021 12:21:16 +0000 (13:21 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 20 Jan 2021 12:21:16 +0000 (13:21 +0100)
- kdf selftest patch from mailing list (fixes startup failure in
  keeepassxc)

kdf-selftest.patch [new file with mode: 0644]
libgcrypt-poll.patch
libgcrypt.spec

diff --git a/kdf-selftest.patch b/kdf-selftest.patch
new file mode 100644 (file)
index 0000000..72e9721
--- /dev/null
@@ -0,0 +1,31 @@
+From: Jussi Kivilinna <jussi.kivilinna@iki.fi>
+Date: Tue, 19 Jan 2021 19:13:32 +0100
+Subject: [PATCH 1/2] kdf: add missing null-terminator for self-test test-vector array
+
+* cipher/kdf.c (selftest_pbkdf2): Add null-terminator to TV array.
+--
+
+This was causing kdf sefl-test to fail on s390x builds.
+
+Signed-off-by: Jussi Kivilinna <jussi.kivilinna at iki.fi>
+---
+ cipher/kdf.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/cipher/kdf.c b/cipher/kdf.c
+index 3d707bd0..b916a3f8 100644
+--- a/cipher/kdf.c
++++ b/cipher/kdf.c
+@@ -452,7 +452,8 @@ selftest_pbkdf2 (int extended, selftest_report_func_t report)
+       "\x34\x8c\x89\xdb\xcb\xd3\x2b\x2f\x32\xd8\x14\xb8\x11\x6e\x84\xcf"
+       "\x2b\x17\x34\x7e\xbc\x18\x00\x18\x1c\x4e\x2a\x1f\xb8\xdd\x53\xe1"
+       "\xc6\x35\x51\x8c\x7d\xac\x47\xe9"
+-    }
++    },
++    { NULL }
+   };
+   const char *what;
+   const char *errtxt;
+-- 
+2.27.0
+
index e8b4a473b435c8bc7395ff38fe4cddd454f0209d..e8896b1abbe7298d0b48fa50a41319f2b67c9006 100644 (file)
@@ -5,9 +5,9 @@
  #include <unistd.h>
  #include <fcntl.h>
 +#include <poll.h>
- #if defined(__linux__) && defined(HAVE_SYSCALL)
+ #if defined(__linux__) || !defined(HAVE_GETENTROPY)
+ #ifdef HAVE_SYSCALL
  # include <sys/syscall.h>
- #endif
 @@ -216,8 +217,7 @@
                   return with something we will actually use 100ms. */
    while (length)
index 80b7f9d3f94e410e0c4c6d7a7f5ff9d95b7050ba..c4bd25b1091e47fbe40f5739c19e4476c7d894ba 100644 (file)
@@ -8,15 +8,16 @@ Summary(es.UTF-8):    Libgcrypt es una biblioteca general de desarrole embasada em
 Summary(pl.UTF-8):     Biblioteka kryptograficzna oparta na kodzie GnuPG
 Summary(pt_BR.UTF-8):  libgcrypt é uma biblioteca de criptografia de uso geral baseada no GnuPG
 Name:          libgcrypt
-Version:       1.8.7
+Version:       1.9.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.gnupg.org/gcrypt/libgcrypt/%{name}-%{version}.tar.bz2
-# Source0-md5: 291c40a06d6fc2f285a34f0f0e846325
+# Source0-md5: 5ef99d1838092bc15c0ddafb22830a02
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-libgcrypt_config.patch
 Patch2:                %{name}-poll.patch
+Patch3:                kdf-selftest.patch
 URL:           https://directory.fsf.org/wiki/Libgcrypt
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.14
@@ -24,10 +25,10 @@ BuildRequires:      binutils >= 2:2.12
 %{?with_dietlibc:BuildRequires:        dietlibc-static >= 2:0.31-5}
 BuildRequires: gcc >= 5:3.2
 %{?with_libcap:BuildRequires:  libcap-devel}
-BuildRequires: libgpg-error-devel >= 1.25
+BuildRequires: libgpg-error-devel >= 1.27
 BuildRequires: libtool >= 2:2.2.6
 BuildRequires: texinfo
-Requires:      libgpg-error >= 1.25
+Requires:      libgpg-error >= 1.27
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # for some reason known only to rpm there must be "\\|" not "\|" here
@@ -121,6 +122,7 @@ Biblioteka statyczna dietlibc libgcrypt.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__rm} m4/libtool.m4
This page took 0.281803 seconds and 4 git commands to generate.