]> git.pld-linux.org Git - packages/libftdi1.git/commitdiff
- added cmake patch (fix include dirs in .pc files); release 2 auto/th/libftdi1-1.5-2
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Jul 2020 19:49:08 +0000 (21:49 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 30 Jul 2020 19:49:08 +0000 (21:49 +0200)
libftdi1-cmake.patch [new file with mode: 0644]
libftdi1.spec

diff --git a/libftdi1-cmake.patch b/libftdi1-cmake.patch
new file mode 100644 (file)
index 0000000..ec36659
--- /dev/null
@@ -0,0 +1,45 @@
+--- libftdi1-1.5/CMakeLists.txt.orig   2020-07-07 21:32:55.000000000 +0200
++++ libftdi1-1.5/CMakeLists.txt        2020-07-30 20:20:30.815434396 +0200
+@@ -136,7 +136,6 @@
+ add_subdirectory(src)
+ if ( FTDIPP )
+-  project(libftdipp1 C CXX)
+   add_subdirectory(ftdipp)
+ endif ()
+ if ( PYTHON_BINDINGS )
+@@ -157,6 +156,7 @@
+ set(prefix      ${CMAKE_INSTALL_PREFIX})
+ set(exec_prefix ${CMAKE_INSTALL_PREFIX}/bin)
+ set(includedir  ${CMAKE_INSTALL_PREFIX}/include/${PROJECT_NAME})
++set(ppincludedir ${CMAKE_INSTALL_PREFIX}/include/libftdipp1)
+ if(${UNIX})
+    set(libdir      ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+--- libftdi1-1.5/ftdipp/CMakeLists.txt.orig    2020-07-30 20:25:51.163698920 +0200
++++ libftdi1-1.5/ftdipp/CMakeLists.txt 2020-07-30 20:26:21.460201456 +0200
+@@ -1,4 +1,5 @@
+ # vim: ts=2:sw=2:sts=2
++project(libftdipp1 C CXX)
+ # Targets
+ set(cpp_sources ${CMAKE_CURRENT_SOURCE_DIR}/ftdi.cpp CACHE INTERNAL "List of cpp sources" )
+@@ -42,6 +43,6 @@
+ endif ()
+ install ( FILES ${cpp_headers}
+-                                      DESTINATION include/${PROJECT_NAME}
++                                      DESTINATION include/libftdipp1
+                                       COMPONENT headers
+                               )
+--- libftdi1-1.5/libftdipp1.pc.in.orig 2020-07-07 21:32:55.000000000 +0200
++++ libftdi1-1.5/libftdipp1.pc.in      2020-07-30 20:50:23.035725105 +0200
+@@ -1,7 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+-includedir=@includedir@
++includedir=@ppincludedir@
+ Name: libftdipp1
+ Description: C++ wrapper for libftdi1
index de22df620624b8012ce1969c58447e45cf7bb748..8ebe86e60774f917861219496427a64c979f70cf 100644 (file)
@@ -7,12 +7,13 @@ Summary:      Library to talk to FTDI's chips including the popular bitbang mode
 Summary(pl.UTF-8):     Biblioteka do komunikacji z układami FTDI włącznie z trybem bitbang
 Name:          libftdi1
 Version:       1.5
-Release:       1
+Release:       2
 License:       LGPL v2
 Group:         Libraries
 #Source0Download: https://www.intra2net.com/en/developer/libftdi/download.php
 Source0:       https://www.intra2net.com/en/developer/libftdi/download/%{name}-%{version}.tar.bz2
 # Source0-md5: f515d7d69170a9afc8b273e8f1466a80
+Patch0:                %{name}-cmake.patch
 URL:           https://www.intra2net.com/en/developer/libftdi/
 BuildRequires: boost-devel >= 1.33
 BuildRequires: cmake >= 2.6
@@ -141,6 +142,7 @@ Wiązanie Pythona 3 do libftdi1.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 install -d build-doc
This page took 0.129854 seconds and 4 git commands to generate.