]> git.pld-linux.org Git - packages/libfreehand.git/blob - libfreehand.spec
- BR: boost-devel, perl, C++11
[packages/libfreehand.git] / libfreehand.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Library for parsing the FreeHand file format structure
6 Summary(pl.UTF-8):      Biblioteka do analizy struktury formatu plików FreeHand
7 Name:           libfreehand
8 Version:        0.1.2
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 Source0:        http://dev-www.libreoffice.org/src/libfreehand/%{name}-%{version}.tar.xz
13 # Source0-md5:  c3788f5686839fd097bd77d8f51c3d04
14 URL:            http://www.freedesktop.org/wiki/Software/libfreehand/
15 BuildRequires:  boost-devel
16 BuildRequires:  doxygen
17 BuildRequires:  gperf >= 3.0.0
18 BuildRequires:  lcms2-devel >= 2
19 BuildRequires:  libicu-devel
20 BuildRequires:  librevenge-devel >= 0.0
21 BuildRequires:  libstdc++-devel >= 6:4.7
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig >= 1:0.20
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Libfreehand is library providing ability to interpret and import
31 Adobe/Macromedia drawings into various applications.
32
33 %description -l pl.UTF-8
34 Libfreehand to biblioteka umożliwiająca interpretowanie i import do
35 różnych aplikacji rysunków w formacie Adobe/Macromedia.
36
37 %package devel
38 Summary:        Header files for libfreehand library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfreehand
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       librevenge-devel >= 0.0
43 Requires:       libstdc++-devel >= 6:4.7
44 Requires:       zlib-devel
45
46 %description devel
47 Header files for libfreehand library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libfreehand.
51
52 %package static
53 Summary:        Static libfreehand library
54 Summary(pl.UTF-8):      Statyczna biblioteka libfreehand
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libfreehand library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libfreehand.
63
64 %package apidocs
65 Summary:        libfreehand API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki libfreehand
67 Group:          Documentation
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 API documentation for libfreehand library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki libfreehand.
77
78 %package tools
79 Summary:        Tools to transform FreeHand drawings into other formats
80 Summary(pl.UTF-8):      Programy przekształcania rysunków FreeHand do innych formatów
81 Group:          Applications/Publishing
82 Requires:       %{name} = %{version}-%{release}
83
84 %description tools
85 Tools to transform FreeHand drawings into other formats. Currently
86 supported: SVG, raw.
87
88 %description tools -l pl.UTF-8
89 Narzędzia do przekształcania rysunków FreeHand do innych formatów.
90 Aktualnie obsługiwane są SVG i format surowy.
91
92 %prep
93 %setup -q
94
95 %build
96 %configure \
97         --disable-silent-rules \
98         %{?with_static_libs:--enable-static}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfreehand-*.la
109 # packaged as %doc in -apidocs
110 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libfreehand
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS
121 %attr(755,root,root) %{_libdir}/libfreehand-0.1.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libfreehand-0.1.so.1
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libfreehand-0.1.so
127 %{_includedir}/libfreehand-0.1
128 %{_pkgconfigdir}/libfreehand-0.1.pc
129
130 %if %{with static_libs}
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libfreehand-0.1.a
134 %endif
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %doc docs/doxygen/html/*
139
140 %files tools
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/fh2raw
143 %attr(755,root,root) %{_bindir}/fh2svg
144 %attr(755,root,root) %{_bindir}/fh2text
This page took 0.184098 seconds and 4 git commands to generate.