]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
909dbec2881cdf16ff1e52f7204e098469b0e444
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.17.1
11 Release:        2
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  7cecda7c08f141223076487490374cb5
16 URL:            https://lib.filezilla-project.org/
17 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
20 BuildRequires:  glibc-localedb-all
21 %endif
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  gettext-tools >= 0.11.0
25 BuildRequires:  gnutls-devel >= 3.5.7
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  nettle-devel >= 3.1
28 BuildRequires:  pkgconfig >= 1:0.7
29 # -std=c++17
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  rpmbuild(macros) >= 1.583
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libfilezilla is a free, open source C++ library, offering some basic
36 functionality to build high-performing, platform-independent programs.
37 Some of the highlights include:
38
39 - A typesafe, multi-threaded event system that's very simple to use
40   yet extremely efficient
41 - Timers for periodic events
42 - A datetime class that not only tracks timestamp but also their
43   accuracy, which simplifies dealing with timestamps originating from
44   different sources
45 - Simple process handling for spawning child processes with redirected
46   I/O
47
48 %description -l pl.UTF-8
49 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
50 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
51 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
52 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
53   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
54 - zegary do zdarzeń regularnych
55 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
56   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
57   różnych źródeł
58 - prostą obsługę procesów do tworzenia procesów potomnych z
59   przekierowanym wejściem/wyjściem
60
61 %package devel
62 Summary:        Header files for libfilezilla library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       libstdc++-devel >= 6:7
67
68 %description devel
69 Header files for libfilezilla library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libfilezilla.
73
74 %package static
75 Summary:        Static libfilezilla library
76 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libfilezilla library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libfilezilla.
85
86 %package apidocs
87 Summary:        %{name} API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for %{name} library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki %{name}.
96
97 %prep
98 %setup -q
99
100 cd locales
101 %{__mv} bg{_BG,}.po
102 %{__mv} ca{_ES,}@valencia.po
103 %{__mv} cs{_CZ,}.po
104 %{__mv} fa{_IR,}.po
105 %{__mv} fi{_FI,}.po
106 %{__mv} gl{_ES,}.po
107 %{__mv} he{_IL,}.po
108 %{__mv} hu{_HU,}.po
109 %{__mv} id{_ID,}.po
110 %{__mv} ja{_JP,}.po
111 %{__mv} ko{_KR,}.po
112 %{__mv} lo{_LA,}.po
113 %{__mv} lt{_LT,}.po
114 %{__mv} lv{_LV,}.po
115 %{__mv} mk{_MK,}.po
116 %{__mv} nb{_NO,}.po
117 %{__mv} nn{_NO,}.po
118 %{__mv} pl{_PL,}.po
119 %{__mv} pt{_PT,}.po
120 %{__mv} ro{_RO,}.po
121 %{__mv} sk{_SK,}.po
122 %{__mv} sl{_SI,}.po
123 %{__mv} th{_TH,}.po
124 %{__mv} uk{_UA,}.po
125 %{__mv} vi{_VN,}.po
126
127 %build
128 %{__libtoolize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         %{!?with_static_libs:--disable-static}
135 %{__make}
136
137 %if %{with tests}
138 # wide char conversion test fails with plain C locale
139 LC_ALL=C.UTF-8 \
140 %{__make} check
141 %endif
142
143 %if %{with apidocs}
144 %{__make} -C doc html
145 %endif
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
154
155 # not supported by glibc (as of 2.25)
156 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
157
158 %find_lang %{name}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog NEWS README
169 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libfilezilla.so
175 %{_includedir}/libfilezilla
176 %{_pkgconfigdir}/libfilezilla.pc
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libfilezilla.a
182 %endif
183
184 %if %{with apidocs}
185 %files apidocs
186 %defattr(644,root,root,755)
187 %doc doc/doxygen-doc/html/*
188 %endif
This page took 0.116294 seconds and 2 git commands to generate.