]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- up to 0.28.0
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.28.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  934d6a5e7ae5bb339fc46aa29223a74f
16 URL:            https://lib.filezilla-project.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
20 %{?with_apidocs:BuildRequires:  doxygen}
21 BuildRequires:  gettext-tools >= 0.11.0
22 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
23 BuildRequires:  glibc-localedb-all
24 %endif
25 BuildRequires:  gnutls-devel >= 3.5.8
26 # -std=c++17
27 BuildRequires:  libstdc++-devel >= 6:7
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  nettle-devel >= 3.3
30 BuildRequires:  pkgconfig >= 1:0.7
31 BuildRequires:  rpmbuild(macros) >= 1.583
32 Requires:       gnutls-libs >= 3.5.8
33 Requires:       nettle >= 3.3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libfilezilla is a free, open source C++ library, offering some basic
38 functionality to build high-performing, platform-independent programs.
39 Some of the highlights include:
40
41 - A typesafe, multi-threaded event system that's very simple to use
42   yet extremely efficient
43 - Timers for periodic events
44 - A datetime class that not only tracks timestamp but also their
45   accuracy, which simplifies dealing with timestamps originating from
46   different sources
47 - Simple process handling for spawning child processes with redirected
48   I/O
49
50 %description -l pl.UTF-8
51 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
52 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
53 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
54 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
55   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
56 - zegary do zdarzeń regularnych
57 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
58   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
59   różnych źródeł
60 - prostą obsługę procesów do tworzenia procesów potomnych z
61   przekierowanym wejściem/wyjściem
62
63 %package devel
64 Summary:        Header files for libfilezilla library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       libstdc++-devel >= 6:7
69 Requires:       gnutls-devel >= 3.5.8
70 Requires:       nettle-devel >= 3.3
71
72 %description devel
73 Header files for libfilezilla library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki libfilezilla.
77
78 %package static
79 Summary:        Static libfilezilla library
80 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static libfilezilla library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka libfilezilla.
89
90 %package apidocs
91 Summary:        %{name} API documentation
92 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
93 Group:          Documentation
94
95 %description apidocs
96 API documentation for %{name} library.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API biblioteki %{name}.
100
101 %prep
102 %setup -q
103
104 cd locales
105 %{__mv} bg{_BG,}.po
106 %{__mv} ca{_ES,}@valencia.po
107 %{__mv} cs{_CZ,}.po
108 %{__mv} fa{_IR,}.po
109 %{__mv} fi{_FI,}.po
110 %{__mv} gl{_ES,}.po
111 %{__mv} he{_IL,}.po
112 %{__mv} hu{_HU,}.po
113 %{__mv} id{_ID,}.po
114 %{__mv} ja{_JP,}.po
115 %{__mv} ko{_KR,}.po
116 %{__mv} lo{_LA,}.po
117 %{__mv} lt{_LT,}.po
118 %{__mv} lv{_LV,}.po
119 %{__mv} mk{_MK,}.po
120 %{__mv} nb{_NO,}.po
121 %{__mv} nn{_NO,}.po
122 %{__mv} pl{_PL,}.po
123 %{__mv} pt{_PT,}.po
124 %{__mv} ro{_RO,}.po
125 %{__mv} sk{_SK,}.po
126 %{__mv} sl{_SI,}.po
127 %{__mv} th{_TH,}.po
128 %{__mv} uk{_UA,}.po
129 %{__mv} vi{_VN,}.po
130
131 %build
132 %{__libtoolize}
133 %{__aclocal} -I m4
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 %configure \
138         %{!?with_static_libs:--disable-static}
139 %{__make}
140
141 %if %{with tests}
142 # wide char conversion test fails with plain C locale
143 LC_ALL=C.UTF-8 \
144 %{__make} check
145 %endif
146
147 %if %{with apidocs}
148 %{__make} -C doc html
149 %endif
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
158
159 # not supported by glibc (as of 2.25)
160 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog NEWS README
173 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.13
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libfilezilla.so
179 %{_includedir}/libfilezilla
180 %{_pkgconfigdir}/libfilezilla.pc
181
182 %if %{with static_libs}
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libfilezilla.a
186 %endif
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %doc doc/doxygen-doc/html/*
192 %endif
This page took 0.102529 seconds and 3 git commands to generate.