]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- release 2, rebuild against libnettle.so.6 (nettle-3.5)
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.16.0
11 Release:        2
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  045c8358067e48d8a2584284e8676139
16 URL:            https://lib.filezilla-project.org/
17 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
20 BuildRequires:  glibc-localedb-all
21 %endif
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  nettle-devel >= 3.1
26 BuildRequires:  pkgconfig >= 1:0.7
27 # -std=c++14
28 BuildRequires:  libstdc++-devel >= 6:5
29 BuildRequires:  rpmbuild(macros) >= 1.583
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libfilezilla is a free, open source C++ library, offering some basic
34 functionality to build high-performing, platform-independent programs.
35 Some of the highlights include:
36
37 - A typesafe, multi-threaded event system that's very simple to use
38   yet extremely efficient
39 - Timers for periodic events
40 - A datetime class that not only tracks timestamp but also their
41   accuracy, which simplifies dealing with timestamps originating from
42   different sources
43 - Simple process handling for spawning child processes with redirected
44   I/O
45
46 %description -l pl.UTF-8
47 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
48 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
49 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
50 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
51   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
52 - zegary do zdarzeń regularnych
53 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
54   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
55   różnych źródeł
56 - prostą obsługę procesów do tworzenia procesów potomnych z
57   przekierowanym wejściem/wyjściem
58
59 %package devel
60 Summary:        Header files for libfilezilla library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       libstdc++-devel >= 6:5
65
66 %description devel
67 Header files for libfilezilla library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki libfilezilla.
71
72 %package static
73 Summary:        Static libfilezilla library
74 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libfilezilla library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka libfilezilla.
83
84 %package apidocs
85 Summary:        %{name} API documentation
86 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
87 Group:          Documentation
88
89 %description apidocs
90 API documentation for %{name} library.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki %{name}.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         %{!?with_static_libs:--disable-static}
106 %{__make}
107
108 %if %{with tests}
109 # wide char conversion test fails with plain C locale
110 LC_ALL=C.UTF-8 \
111 %{__make} check
112 %endif
113
114 %if %{with apidocs}
115 %{__make} -C doc html
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog NEWS README
135 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libfilezilla.so
141 %{_includedir}/libfilezilla
142 %{_pkgconfigdir}/libfilezilla.pc
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libfilezilla.a
148 %endif
149
150 %if %{with apidocs}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %doc doc/doxygen-doc/html/*
154 %endif
This page took 0.08212 seconds and 3 git commands to generate.