]> git.pld-linux.org Git - packages/libffi.git/blob - libffi.spec
- updated to 3.4.4
[packages/libffi.git] / libffi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Foreign Function Interface library
6 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface
7 Name:           libffi
8 Version:        3.4.4
9 Release:        1
10 Epoch:          7
11 License:        MIT-like
12 Group:          Libraries
13 #Source0Download: https://github.com/libffi/libffi/releases/
14 Source0:        https://github.com/libffi/libffi/releases/download/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  0da1a5ed7786ac12dcbaf0d499d8a049
16 Patch0:         %{name}-info.patch
17 URL:            http://www.sourceware.org/libffi/
18 BuildRequires:  autoconf >= 2.68
19 BuildRequires:  automake
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libtool
22 BuildRequires:  texinfo
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The libffi library provides a portable, high level programming
27 interface to various calling conventions. This allows a programmer to
28 call any function specified by a call interface description at
29 run-time.
30
31 Ffi stands for Foreign Function Interface. A foreign function
32 interface is the popular name for the interface that allows code
33 written in one language to call code written in another language. The
34 libffi library really only provides the lowest, machine dependent
35 layer of a fully featured foreign function interface. A layer must
36 exist above libffi that handles type conversions for values passed
37 between the two languages.
38
39 %description -l pl.UTF-8
40 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
41 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
42 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
43 działania programu.
44
45 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
46 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
47 napisanemu w jednym języku wywoływać kod napisany w innym języku.
48 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
49 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
50 typów dla wartości przekazywanych pomiędzy różnymi językami.
51
52 %package devel
53 Summary:        libffi development package
54 Summary(pl.UTF-8):      libffi - część dla programistów
55 Group:          Development/Libraries
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57
58 %description devel
59 Header files for libffi.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe do biblioteki libffi.
63
64 %package static
65 Summary:        libffi static library
66 Summary(pl.UTF-8):      Statyczna biblioteka libffi
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
69
70 %description static
71 Static version of libffi.
72
73 %description static -l pl.UTF-8
74 Statyczna wersja biblioteki libffi.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --disable-multi-os-directory \
88         %{!?with_static_libs:--disable-static}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post   devel -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %postun devel -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc ChangeLog* LICENSE README.md
113 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libffi.so.8
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libffi.so
119 %{_libdir}/libffi.la
120 %{_includedir}/ffi*.h
121 %{_pkgconfigdir}/libffi.pc
122 %{_mandir}/man3/ffi*.3*
123 %{_infodir}/libffi.info*
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libffi.a
129 %endif
This page took 0.102445 seconds and 4 git commands to generate.