]> git.pld-linux.org Git - packages/libexif.git/blob - libexif.spec
fix build without static libs after disabling silent rules
[packages/libexif.git] / libexif.spec
1 #
2 # NOTE:
3 # - exif headers should be included as <libexif/something.h>
4 #   so don't ,,fix'' pkgconfig file
5 #
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8
9 Summary:        Library for parsing EXIF files from digital cameras
10 Summary(pl.UTF-8):      Biblioteka do czytania plików EXIF z kamer cyfrowych
11 Name:           libexif
12 Version:        0.6.22
13 %define tagver  %(echo %{version} | tr . _)
14 Release:        1
15 Epoch:          1
16 License:        LGPL v2+
17 Group:          Libraries
18 #Source0Download: https://github.com/libexif/libexif/releases
19 Source0:        https://github.com/libexif/libexif/releases/download/libexif-%{tagver}-release/%{name}-%{version}.tar.xz
20 # Source0-md5:  1070601438443fdd5b8635565693cf99
21 URL:            https://libexif.github.io/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  doxygen
25 BuildRequires:  gettext-tools >= 0.14.1
26 BuildRequires:  libtool
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Obsoletes:      libexif7
30 Obsoletes:      libmnote
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Most digital cameras produce EXIF files, which are JPEG files with
35 extra tags that contain information about the image. The EXIF library
36 allows you to parse an EXIF file and read the data from those tags.
37
38 %description -l pl.UTF-8
39 Większość kamer cyfrowych tworzy pliki EXIF, które są JPEGami z
40 dodatkowymi znacznikami zawierającymi informacje o obrazie. Biblioteka
41 EXIF pozwala czytać informacje z tych znaczników.
42
43 %package devel
44 Summary:        Header files for libexif
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla libexif
46 Group:          Development/Libraries
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48 Obsoletes:      libexif7-devel
49 Obsoletes:      libmnote-devel
50
51 %description devel
52 Header files for libexif.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla libexif.
56
57 %package static
58 Summary:        Static version of libexif
59 Summary(pl.UTF-8):      Statyczna wersja libexif
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
62 Obsoletes:      libmnote-static
63
64 %description static
65 Static version of libexif.
66
67 %description static -l pl.UTF-8
68 Statyczna wersja libexif.
69
70 %package apidocs
71 Summary:        libexif API documentation
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libexif
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "4.6"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API and internal documentation for libexif library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API oraz wewnętrzna dla biblioteki libexif.
83
84 %prep
85 %setup -q
86
87 %build
88 %{__gettextize}
89 %{__libtoolize}
90 %{__aclocal} -I m4m
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --disable-silent-rules \
96         %{!?with_static_libs:--disable-static}
97
98 # docs generation fails with -jN>1
99 %{__make} -j1
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexif.la
109 # packaged as %doc
110 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libexif
111
112 %find_lang %{name}-12
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files -f %{name}-12.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README
123 %attr(755,root,root) %{_libdir}/libexif.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libexif.so.12
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libexif.so
129 %{_includedir}/libexif
130 %{_pkgconfigdir}/libexif.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libexif.a
136 %endif
137
138 %files apidocs
139 %defattr(644,root,root,755)
140 %doc doc/doxygen-output/libexif*
This page took 0.488367 seconds and 3 git commands to generate.