]> git.pld-linux.org Git - packages/libexif.git/blob - libexif.spec
- docs generation fails with -jN>1
[packages/libexif.git] / libexif.spec
1 #
2 # NOTE:
3 # - exif headers should be included as <libexif/something.h>
4 #   so don't ,,fix'' pkgconfig file
5
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8 #
9 Summary:        Library for parsing EXIF files from digital cameras
10 Summary(pl):    Biblioteka do czytania plików EXIF z kamer cyfrowych
11 Name:           libexif
12 Version:        0.6.13
13 Release:        4
14 Epoch:          1
15 License:        MIT
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libexif/%{name}-%{version}.tar.bz2
18 # Source0-md5:  1b1e2b495c5aa20c08725f30545a110b
19 Patch0:         %{name}-pl.po-update.patch
20 Patch1:         %{name}-ac.patch
21 URL:            http://libexif.sourceforge.net/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.8
24 BuildRequires:  doxygen
25 BuildRequires:  gettext-devel >= 0.14.1
26 BuildRequires:  libtool
27 Obsoletes:      libexif7
28 Obsoletes:      libmnote
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Most digital cameras produce EXIF files, which are JPEG files with
33 extra tags that contain information about the image. The EXIF library
34 allows you to parse an EXIF file and read the data from those tags.
35
36 %description -l pl
37 Wiêkszo¶æ kamer cyfrowych tworzy pliki EXIF, które s± JPEGami z
38 dodatkowymi znacznikami zawieraj±cymi informacje o obrazie. Biblioteka
39 EXIF pozwala czytaæ informacje z tych znaczników.
40
41 %package devel
42 Summary:        Header files for libexif
43 Summary(pl):    Pliki nag³ówkowe dla libexif
44 Group:          Development/Libraries
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46 Obsoletes:      libexif7-devel
47 Obsoletes:      libmnote-devel
48
49 %description devel
50 Header files for libexif.
51
52 %description devel -l pl
53 Pliki nag³ówkowe dla libexif.
54
55 %package static
56 Summary:        Static version of libexif
57 Summary(pl):    Statyczna wersja libexif
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
60 Obsoletes:      libmnote-static
61
62 %description static
63 Static version of libexif.
64
65 %description static -l pl
66 Statyczna wersja libexif.
67
68 %package apidocs
69 Summary:        libexif API documentation
70 Summary(pl):    Dokumentacja API biblioteki libexif
71 Group:          Documentation
72
73 %description apidocs
74 API and internal documentation for libexif library.
75
76 %description apidocs -l pl
77 Dokumentacja API oraz wewnêtrzna dla biblioteki libexif.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 rm -f po/stamp-po
85
86 %build
87 %{__gettextize}
88 %{__libtoolize}
89 %{__aclocal} -I m4m
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{!?with_static_libs:--disable-static}
95
96 # docs generation fails with -jN>1
97 %{__make} -j1
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 rm -rf $RPM_BUILD_ROOT%{_docdir}/libexif
106
107 %find_lang %{name}-12
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files -f %{name}-12.lang
116 %defattr(644,root,root,755)
117 %doc README ChangeLog
118 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/lib*.so
123 %{_libdir}/lib*.la
124 %{_includedir}/%{name}
125 %{_pkgconfigdir}/*.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/lib*.a
131 %endif
132
133 %files apidocs
134 %defattr(644,root,root,755)
135 %doc doc/doxygen-output/libexif*
This page took 0.095679 seconds and 3 git commands to generate.