]> git.pld-linux.org Git - packages/libetonyek.git/blob - libetonyek.spec
update for mdds 2.0.x
[packages/libetonyek.git] / libetonyek.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Library and tools for reading and converting Apple Keynote presentations
6 Summary(pl.UTF-8):      Biblioteka i narzędzia do odczytu i konwersji prezentacji Apple Keynote
7 Name:           libetonyek
8 Version:        0.1.10
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 Source0:        https://dev-www.libreoffice.org/src/libetonyek/%{name}-%{version}.tar.xz
13 # Source0-md5:  c29792ef7d4cb98463e3c3ec3e56ace6
14 URL:            https://wiki.documentfoundation.org/DLP/Libraries/libetonyek
15 BuildRequires:  GLM
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf
19 BuildRequires:  liblangtag-devel
20 BuildRequires:  librevenge-devel >= 0.0
21 BuildRequires:  libstdc++-devel >= 6:4.7
22 BuildRequires:  libxml2-devel >= 2.0
23 BuildRequires:  mdds-devel >= 2.0
24 BuildRequires:  pkgconfig >= 1:0.20
25 BuildRequires:  rpm-build >= 4.6
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libetonyek is a library and a set of tools for reading and converting
33 Apple Keynote presentations. The library tries to extract the most
34 important parts of version 2 format of Keynote (version 1 is not
35 supported yet, but it should be in the future). See FEATURES for what
36 is currently supported.
37
38 %description -l pl.UTF-8
39 libetonyek to biblioteka i zestaw narzędzi do odczytu i konwersji
40 prezentacji Apple Keynote. Biblioteka próbuje wydobyć najważniejsze
41 części formatu Keynote w wersji 2 (wersja 1 nie jest jeszcze
42 obsługiwana, ale powinna być w przyszłości). Informacje o
43 obsługiwanych elementach można znaleźć w pliku FEATURES.
44
45 %package devel
46 Summary:        Header files for libetonyek library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libetonyek
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       librevenge-devel >= 0.0
51 Requires:       libstdc++-devel >= 6:4.7
52 Requires:       libxml2-devel >= 2.0
53 Requires:       zlib-devel
54
55 %description devel
56 Header files for libetonyek library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki libetonyek.
60
61 %package static
62 Summary:        Static libetonyek library
63 Summary(pl.UTF-8):      Statyczna biblioteka libetonyek
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static libetonyek library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libetonyek.
72
73 %package apidocs
74 Summary:        libetonyek API documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki libetonyek
76 Group:          Documentation
77 BuildArch:      noarch
78
79 %description apidocs
80 API documentation for libetonyek library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki libetonyek.
84
85 %package tools
86 Summary:        Tools to transform Apple Keynote presentations into other formats
87 Summary(pl.UTF-8):      Programy przekształcania prezentacji Apple Keynote do innych formatów
88 Group:          Applications/Publishing
89 Requires:       %{name} = %{version}-%{release}
90
91 %description tools
92 Tools to transform Apple Keynote presentations into other formats.
93 Currently supported: XHTML, raw.
94
95 %description tools -l pl.UTF-8
96 Narzędzia do przekształcania prezentacji Apple Keynote do innych
97 formatów. Aktualnie obsługiwane są XHTML i format surowy.
98
99 %prep
100 %setup -q
101
102 %build
103 %configure \
104         --disable-silent-rules \
105         %{?with_static_libs:--enable-static} \
106         --with-mdds=2.0
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # obsoleted by pkg-config
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libetonyek-*.la
118 # packaged as %doc in -apidocs
119 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libetonyek
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog FEATURES NEWS README TODO
130 %attr(755,root,root) %{_libdir}/libetonyek-0.1.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libetonyek-0.1.so.1
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libetonyek-0.1.so
136 %{_includedir}/libetonyek-0.1
137 %{_pkgconfigdir}/libetonyek-0.1.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libetonyek-0.1.a
143 %endif
144
145 %files apidocs
146 %defattr(644,root,root,755)
147 %doc docs/doxygen/html/*
148
149 %files tools
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/key2raw
152 %attr(755,root,root) %{_bindir}/key2text
153 %attr(755,root,root) %{_bindir}/key2xhtml
154 %attr(755,root,root) %{_bindir}/numbers2csv
155 %attr(755,root,root) %{_bindir}/numbers2raw
156 %attr(755,root,root) %{_bindir}/numbers2text
157 %attr(755,root,root) %{_bindir}/pages2html
158 %attr(755,root,root) %{_bindir}/pages2raw
159 %attr(755,root,root) %{_bindir}/pages2text
This page took 0.171998 seconds and 3 git commands to generate.