]> git.pld-linux.org Git - packages/libepc.git/commitdiff
- avoid using deprecated G_CONST_RETURN auto/th/libepc-0_4_1-2
authorArtur Frysiak <artur@frysiak.net>
Fri, 30 Sep 2011 20:58:02 +0000 (20:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rel. 2

Changed files:
    G_CONST_RETURN.patch -> 1.1
    libepc.spec -> 1.17

G_CONST_RETURN.patch [new file with mode: 0644]
libepc.spec

diff --git a/G_CONST_RETURN.patch b/G_CONST_RETURN.patch
new file mode 100644 (file)
index 0000000..cee00c5
--- /dev/null
@@ -0,0 +1,51 @@
+From e3e1141ed96f3d377bdd902225865cce16526bfd Mon Sep 17 00:00:00 2001
+From: Ionut Biru <ibiru@archlinux.org>
+Date: Fri, 30 Sep 2011 10:57:14 +0000
+Subject: Avoid use of deprecated G_CONST_RETURN
+
+  * libepc/enums.c.in: Avoid use of deprecated G_CONST_RETURN.
+  Bug #660558
+---
+diff --git a/ChangeLog b/ChangeLog
+index a7d235d..857feb2 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,10 @@
++2011-08-31  Ionut Biru <ibiru@archlinux.org>
++
++  Avoid use of deprecated G_CONST_RETURN
++    
++  * libepc/enums.c.in: Avoid use of deprecated G_CONST_RETURN.
++  Bug #660558
++
+       === Release 0.4.1 ===
+       
+ 2011-08-31  Murray Cumming  <murrayc@murrayc.com>
+diff --git a/libepc/enums.c.in b/libepc/enums.c.in
+index 75f737c..bc81b84 100644
+--- a/libepc/enums.c.in
++++ b/libepc/enums.c.in
+@@ -65,7 +65,7 @@ G@Type@Class*
+  *
+  * Returns: The string representation of @value, or %NULL.
+  */
+-G_CONST_RETURN gchar*
++const gchar*
+ @enum_name@_to_string (@EnumName@ value)
+ {
+   const G@Type@Value *@type@_value = g_@type@_get_value (@enum_name@_get_class (), value);
+diff --git a/libepc/enums.h.in b/libepc/enums.h.in
+index fea8b07..48973e5 100644
+--- a/libepc/enums.h.in
++++ b/libepc/enums.h.in
+@@ -19,7 +19,7 @@ G_BEGIN_DECLS
+ GType                 @enum_name@_get_type  (void) G_GNUC_CONST;
+ G@Type@Class*           @enum_name@_get_class (void) G_GNUC_CONST;
+-G_CONST_RETURN gchar* @enum_name@_to_string (@EnumName@ value) G_GNUC_PURE;
++const gchar* @enum_name@_to_string (@EnumName@ value) G_GNUC_PURE;
+ /*** END value-header ***/
+ /*** BEGIN file-tail ***/
+--
+cgit v0.9.0.2
index df85792cb9c334443324af0c0bdc148d6cbbd415..d8c82fe14fae5dd1f6e9b9498bbf43866183bbe6 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       Easy Publish and Consume library
 Name:          libepc
 Version:       0.4.1
-Release:       1
+Release:       2
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/libepc/0.4/%{name}-%{version}.tar.xz
 # Source0-md5: 6854ad8d6dd94070f56b033329a320ac
+Patch0:                G_CONST_RETURN.patch
 URL:           http://live.gnome.org/libepc
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.10.3
@@ -124,6 +125,7 @@ libepc - przykładowe programy.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__gtkdocize}
This page took 0.090518 seconds and 4 git commands to generate.