]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
b4393a565895428e27a65de75e05386cc9bd2d9a
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # don't build gui stuff
4 %bcond_with     mmx             # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4 %{x8664}
8 %define         with_mmx        1
9 %endif
10 Summary:        DV video software codec
11 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
12 Name:           libdv
13 Version:        1.0.0
14 Release:        2
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
18 # Source0-md5:  f895162161cfa4bb4a94c070a7caa6c7
19 Patch0:         %{name}-include_fix.patch
20 URL:            http://libdv.sourceforge.net/
21 %if %{with gui}
22 BuildRequires:  SDL-devel >= 1.1.6
23 BuildRequires:  gtk+-devel >= 1.2.10-3
24 BuildRequires:  xorg-lib-libXv-devel
25 %endif
26 BuildRequires:  autoconf >= 2.59-9
27 BuildRequires:  automake
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig >= 1:0.7
30 BuildRequires:  popt-devel
31 BuildRequires:  rpmbuild(macros) >= 1.213
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Quasar DV codec (libdv) is a software codec for DV video. DV is
36 the encoding format used by most digital camcorders, typically those
37 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
38 was developed according to the official standards for DV video, IEC
39 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
40
41 %description -l pl
42 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
43 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
44 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
45 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
46
47 %package -n dv
48 Summary:        Programs to encode and play DV files
49 Summary(pl):    Programy do kodowania i odtwarzania plików DV
50 Group:          X11/Applications/Multimedia
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n dv
54 Programs to encode and play DV files.
55
56 %description -n dv -l pl
57 Programy do kodowania i odtwarzania plików DV.
58
59 %package devel
60 Summary:        DV library headers
61 Summary(pl):    Pliki nag³ówkowe biblioteki DV
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 This is the libraries, include files and other resources you can use
67 to incorporate libdv into applications.
68
69 %description devel -l pl
70 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
71 libdv.
72
73 %package static
74 Summary:        DV static libraries
75 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 This is package with static libdv libraries.
81
82 %description static -l pl
83 Statyczna wersja biblioteki libdv.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --enable-shared \
97 %if %{with gui}
98         --enable-sdl \
99         --enable-gtk \
100 %else
101         --disable-sdl \
102         --disable-gtk \
103 %endif
104         --without-debug \
105         %{!?with_mmx:--disable-asm} \
106         %{!?with_static_libs:--disable-static}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         pkgconfigdir=%{_pkgconfigdir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README.* TODO
126 %attr(755,root,root) %{_libdir}/libdv.so.*.*.*
127
128 %if %{with gui}
129 %files -n dv
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/*
132 %{_mandir}/man1/*
133 %endif
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libdv.so
138 %{_libdir}/libdv.la
139 %{_includedir}/libdv
140 %{_pkgconfigdir}/libdv.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libdv.a
146 %endif
This page took 0.094244 seconds and 2 git commands to generate.