]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
49d1508f8e417775d3df269a9c039b0611146319
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4
8 # %{x8664} skipped - gas generates PIC-incompatible relocation entries
9 %define         with_mmx        1
10 %endif
11 Summary:        DV video software codec
12 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
13 Name:           libdv
14 Version:        0.104
15 Release:        2
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
19 # Source0-md5:  f6b08efce7472daa20685e6e8431f542
20 Patch0:         %{name}-include_fix.patch
21 URL:            http://libdv.sourceforge.net/
22 %if %{with gui}
23 BuildRequires:  SDL-devel >= 1.1.6
24 BuildRequires:  XFree86-devel
25 BuildRequires:  gtk+-devel >= 1.2.10-3
26 %endif
27 BuildRequires:  automake
28 BuildRequires:  pkgconfig >= 1:0.7
29 BuildRequires:  popt-devel
30 BuildRequires:  rpmbuild(macros) >= 1.213
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The Quasar DV codec (libdv) is a software codec for DV video. DV is
35 the encoding format used by most digital camcorders, typically those
36 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
37 was developed according to the official standards for DV video, IEC
38 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
39
40 %description -l pl
41 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
42 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
43 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
44 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
45
46 %package -n dv
47 Summary:        Programs to encode and play DV files
48 Summary(pl):    Programy do kodowania i odtwarzania plików DV
49 Group:          X11/Applications/Multimedia
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n dv
53 Programs to encode and play DV files.
54
55 %description -n dv -l pl
56 Programy do kodowania i odtwarzania plików DV.
57
58 %package devel
59 Summary:        DV library headers
60 Summary(pl):    Pliki nag³ówkowe biblioteki DV
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description devel
65 This is the libraries, include files and other resources you can use
66 to incorporate libdv into applications.
67
68 %description devel -l pl
69 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
70 libdv.
71
72 %package static
73 Summary:        DV static libraries
74 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 This is package with static libdv libraries.
80
81 %description static -l pl
82 Statyczna wersja biblioteki libdv.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 cp /usr/share/automake/config.sub .
90 %configure \
91         --enable-shared \
92 %if %{with gui}
93         --enable-sdl \
94         --enable-gtk \
95 %else
96         --disable-sdl \
97         --disable-gtk \
98 %endif
99         --without-debug \
100         %{!?with_mmx:--disable-asm} \
101         %{!?with_static_libs:--disable-static}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         pkgconfigdir=%{_pkgconfigdir}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README.* TODO
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
122
123 %if %{with gui}
124 %files -n dv
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man1/*
128 %endif
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %{_libdir}/*.la
134 %{_includedir}/libdv
135 %{_pkgconfigdir}/*
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/lib*.a
141 %endif
This page took 0.097947 seconds and 3 git commands to generate.