]> git.pld-linux.org Git - packages/libdsk.git/commitdiff
- added javadoc fixes to java patch auto/th/libdsk-1.4.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 1 Aug 2016 16:46:53 +0000 (18:46 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 1 Aug 2016 16:46:53 +0000 (18:46 +0200)
- release 2

libdsk-java.patch
libdsk.spec

index 6e25df61f61e9cac325a15f5b29d3fcbe1101190..9c9ec7472e7ecc3e2e4d05c9e0ab05153c44a6be 100644 (file)
 +      $(mkinstalldirs) $(DESTDIR)$(javadir)
 +      if test x@LIBDSKJAR@ = x; then true; else $(INSTALL_DATA) @LIBDSKJAR@ $(DESTDIR)$(javadir); fi
  
+--- libdsk-1.4.0/lib/uk/co/demon/seasip/libdsk/Drive.java.orig 2015-04-28 22:06:20.000000000 +0200
++++ libdsk-1.4.0/lib/uk/co/demon/seasip/libdsk/Drive.java      2016-08-01 18:33:24.505272401 +0200
+@@ -120,7 +120,7 @@
+   * @param cyl The physical cylinder containing the sector. 
+   * @param head The physical head to use.
+   * @param cylExpected The expected cylinder number in the sector header.
+-  * @param cylExpected The expected head number in the sector header.
++  * @param headExpected The expected head number in the sector header.
+   * @param sector The number of the sector.
+   * @param sectorLen The number of bytes to transfer (may be less than a 
+   *                 full sector).
+@@ -165,7 +165,7 @@
+   * @param cyl The physical cylinder containing the sector. 
+   * @param head The physical head to use.
+   * @param cylExpected The expected cylinder number in the sector header.
+-  * @param cylExpected The expected head number in the sector header.
++  * @param headExpected The expected head number in the sector header.
+   * @param sector The number of the sector.
+   * @param sectorLen The number of bytes to transfer (may be less than a 
+   *                 full sector).
+@@ -209,7 +209,7 @@
+   * @param cyl The physical cylinder containing the sector. 
+   * @param head The physical head to use.
+   * @param cylExpected The expected cylinder number in the sector header.
+-  * @param cylExpected The expected head number in the sector header.
++  * @param headExpected The expected head number in the sector header.
+   * @param sector The number of the sector.
+   * @param sectorLen The number of bytes to transfer (may be less than a 
+   *                 full sector).
+@@ -228,7 +228,7 @@
+ /** Format a track, using physical cylinder/sector.
+  *
+  * @param g The drive geometry to use.
+- * @param c The physical cylinder to use. 
++ * @param cyl The physical cylinder to use. 
+  * @param h The physical head to use.
+  * @param fd An array of FormatData objects containing sector headers.
+  * @param filler The byte with which to fill the empty sectors. 
+@@ -252,7 +252,7 @@
+   * it will just do repeated sector reads.
+   * @param g The drive geometry to use. 
+   * @param buf The buffer to be filled with data. 
+-  * @param cyl The physical cylinder to use. 
++  * @param cylinder The physical cylinder to use. 
+   * @param head The physical head to use.
+   * @exception DskException If the read failed for any reason, or the driver cannot
+   *                     read sectors.
+@@ -280,10 +280,10 @@
+   * use this call.
+   * @param g The drive geometry to use. 
+   * @param buf The buffer to be filled with data. 
+-  * @param cyl The physical cylinder to use. 
++  * @param cylinder The physical cylinder to use. 
+   * @param head The physical head to use.
+   * @param cylExpected The expected cylinder number in the sector header.
+-  * @param cylExpected The expected head number in the sector header.
++  * @param headExpected The expected head number in the sector header.
+   * @exception DskException If the read failed for any reason, or the driver cannot
+   *                     read sectors.
+   */
+@@ -294,7 +294,7 @@
+  * Linux floppies.
+  *
+  * @param g The drive geometry to use.
+- * @param cyl The physical cylinder to use. 
++ * @param cylinder The physical cylinder to use. 
+  * @param head The physical head to use.
+  * @param filler The byte with which to fill the empty sectors. 
+  * @exception DskException If the format failed for any reason, or the driver cannot
+@@ -402,7 +402,7 @@
+       public native void setComment(String c) throws DskException;
+ /** Set the number of times an operation will be retried.
+- * @param n The number of times to retry a read, write or format, 1 or more. 
++ * @param c The number of times to retry a read, write or format, 1 or more. 
+  * @exception DskException If the number passed is 0. */
+       public native void setRetry(int c) throws DskException; 
index f2721c1b1cd25a44cc2d22a5f5adf3268b11fff9..3c422c84646abd3ec74e1e3324c7ad4d91911571 100644 (file)
@@ -8,7 +8,7 @@ Summary(pl.UTF-8):      Biblioteka libdsk
 Name:          libdsk
 # note: 1.4.x is stable, 1.5.x development version
 Version:       1.4.0
-Release:       1
+Release:       2
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://www.seasip.info/Unix/LibDsk/%{name}-%{version}.tar.gz
@@ -16,7 +16,7 @@ Source0:      http://www.seasip.info/Unix/LibDsk/%{name}-%{version}.tar.gz
 Patch0:                %{name}-am.patch
 Patch1:                %{name}-java.patch
 URL:           http://www.seasip.info/Unix/LibDsk/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: bzip2-devel
 %{?with_java:BuildRequires:    jdk}
This page took 2.207342 seconds and 4 git commands to generate.