]> git.pld-linux.org Git - packages/libdaemon.git/blob - libdaemon.spec
- x32 rebuild
[packages/libdaemon.git] / libdaemon.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Lightweight C library which eases the writing of UNIX daemons
6 Summary(pl.UTF-8):      Prosta biblioteka C ułatwiająca pisanie demonów uniksowych
7 Name:           libdaemon
8 Version:        0.14
9 Release:        2
10 Epoch:          0
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://0pointer.de/lennart/projects/libdaemon/%{name}-%{version}.tar.gz
14 # Source0-md5:  509dc27107c21bcd9fbf2f95f5669563
15 URL:            http://0pointer.de/lennart/projects/libdaemon/
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  libtool
19 BuildRequires:  doxygen
20 BuildRequires:  lynx
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 libdaemon is a lightweight C library which eases the writing of UNIX
25 daemons.
26
27 %description -l pl.UTF-8
28 libdaemon jest prostą biblioteką C ułatwiającą pisanie demonów
29 uniksowych.
30
31 %package devel
32 Summary:        Header files and development documentation for libdaemon
33 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty biblioteki libdaemon
34 Group:          Development/Libraries
35 Requires:       %{name} = %{epoch}:%{version}-%{release}
36
37 %description devel
38 This package contains Header files and development documentation for
39 libdaemon.
40
41 %description devel -l pl.UTF-8
42 Ten pakiet zawiera pliki nagłówkowe i dokumentację programisty
43 biblioteki libdaemon.
44
45 %package static
46 Summary:        Static libdaemon library
47 Summary(pl.UTF-8):      Statyczna biblioteka libdaemon
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
50
51 %description static
52 This package contains static libdaemon library.
53
54 %description static -l pl.UTF-8
55 Ten pakiet zawiera statyczną wersję biblioteki libdaemon.
56
57 %prep
58 %setup -q
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I m4
63 %{__autoconf}
64 %{__autoheader}
65 %{__automake}
66 %configure \
67         --disable-silent-rules \
68         %{!?with_static_libs:--disable-static}
69 %{__make}
70 %{__make} doxygen
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_mandir}
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 cp -a doc/reference/man/* $RPM_BUILD_ROOT%{_mandir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README
90 %attr(755,root,root) %{_libdir}/libdaemon.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libdaemon.so.0
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libdaemon.so
96 %{_libdir}/libdaemon.la
97 %{_includedir}/%{name}
98 %{_pkgconfigdir}/libdaemon.pc
99 %{_mandir}/man3/daemon.h.3*
100 %{_mandir}/man3/dexec.h.3*
101 %{_mandir}/man3/dfork.h.3*
102 %{_mandir}/man3/dlog.h.3*
103 %{_mandir}/man3/dnonblock.h.3*
104 %{_mandir}/man3/dpid.h.3*
105 %{_mandir}/man3/dsignal.h.3*
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libdaemon.a
111 %endif
This page took 0.250801 seconds and 3 git commands to generate.