]> git.pld-linux.org Git - packages/libcaca.git/commitdiff
- added format patch to fix build with -Werror=format-security
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 4 Dec 2012 19:29:26 +0000 (20:29 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 4 Dec 2012 19:29:26 +0000 (20:29 +0100)
libcaca-format.patch [new file with mode: 0644]
libcaca.spec

diff --git a/libcaca-format.patch b/libcaca-format.patch
new file mode 100644 (file)
index 0000000..e0847ab
--- /dev/null
@@ -0,0 +1,38 @@
+--- libcaca-0.99.beta18/ruby/caca-display.c.orig       2012-04-06 22:36:17.000000000 +0200
++++ libcaca-0.99.beta18/ruby/caca-display.c    2012-12-04 20:28:37.435444821 +0100
+@@ -84,7 +84,7 @@
+     if(display == NULL)
+     {
+-        rb_raise(rb_eRuntimeError, strerror(errno));
++        rb_raise(rb_eRuntimeError, "%s", strerror(errno));
+     }
+     _SELF = display;
+@@ -131,7 +131,7 @@
+ {
+     if(caca_set_display_title(_SELF, StringValuePtr(t))<0)
+     {
+-        rb_raise(rb_eRuntimeError, strerror(errno));
++        rb_raise(rb_eRuntimeError, "%s", strerror(errno));
+     }
+     return t;
+ }
+@@ -252,7 +252,7 @@
+ {
+     if(caca_set_display_driver(_SELF, StringValuePtr(driver))<0)
+     {
+-        rb_raise(rb_eRuntimeError, strerror(errno));
++        rb_raise(rb_eRuntimeError, "%s", strerror(errno));
+     }
+     return driver;
+ }
+@@ -267,7 +267,7 @@
+ {
+     if(caca_set_cursor(_SELF, flag)<0)
+     {
+-        rb_raise(rb_eRuntimeError, strerror(errno));
++        rb_raise(rb_eRuntimeError, "%s", strerror(errno));
+     }
+     return flag;
+ }
index f77567ceab60324cd94ef848168793080f97a845..66c133742c4ca4964e42f05f7f520bc7786ce188 100644 (file)
@@ -23,6 +23,7 @@ Source0:      http://libcaca.zoy.org/files/libcaca/%{name}-%{version}.%{subver}.tar.g
 # Source0-md5: 93d35dbdb0527d4c94df3e9a02e865cc
 Patch0:                install.patch
 Patch1:                %{name}-ruby1.9.patch
+Patch2:                %{name}-format.patch
 URL:           http://libcaca.zoy.org/
 BuildRequires: OpenGL-devel
 BuildRequires: autoconf >= 2.50
@@ -243,6 +244,7 @@ Wiązania języka Ruby do libcaca.
 %undos */Makefile.am
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
This page took 0.047395 seconds and 4 git commands to generate.