]> git.pld-linux.org Git - packages/libcaca.git/blob - libcaca.spec
- updated URLs
[packages/libcaca.git] / libcaca.spec
1 Summary:        Graphics library that outputs text instead of pixels
2 Summary(pl):    Biblioteka graficzna wy¶wietlaj±ca tekst zamiast pikseli
3 Name:           libcaca
4 Version:        0.9
5 Release:        2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://libcaca.zoy.org/files/%{name}-%{version}.tar.bz2
9 # Source0-md5:  c7d5c46206091a9203fcb214abb25e4a
10 URL:            http://libcaca.zoy.org/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  imlib2-devel
15 BuildRequires:  libtool
16 BuildRequires:  slang-devel >= 2.0.0
17 # shouldn't these be in doxygen requirements?
18 BuildRequires:  tetex-fonts-jknappen
19 BuildRequires:  tetex-makeindex
20 BuildRequires:  tetex-metafont
21 BuildRequires:  XFree86-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         specflags       -fomit-frame-pointer
25
26 %description
27 The libcaca library is a graphics library that outputs text instead of
28 pixels, so that it can work on older video cards or text terminals. It
29 is not unlike the famous AAlib library.
30
31 The differences with AAlib are the following:
32 - 16 available colours for character output (256 colour pairs)
33 - dithering of colour images
34 - basic sprite primitives
35
36 But libcaca also has the following limitations:
37 - no support for brightness, contrast, gamma
38 - unefficient character-choosing algorithms
39 - no raw keyboard support
40
41 %description -l pl
42 Biblioteka libcaca to biblioteka graficzna wy¶wietlaj±ca tekst zamiast
43 pikseli, dziêki czemu mo¿e dzia³aæ na starszych kartach graficznych
44 oraz terminalach tekstowych. Pod tym wzglêdem jest podobna do s³ynnej
45 biblioteki AAlib.
46
47 Ró¿nice w stosunku do AAlib s± nastêpuj±ce:
48 - 16 dostêpnych kolorów dla znaków (256 par kolorów)
49 - dithering kolorowych obrazów
50 - proste kszta³ty duszków (sprites)
51
52 Ale libcaca ma tak¿e nastêpuj±ce ograniczenia:
53 - brak obs³ugi jasno¶ci, kontrastu, korekcji gamma
54 - ma³o wydajne algorytmy wyboru znaków
55 - brak obs³ugi klawiatury w trybie surowym
56
57 %package devel
58 Summary:        Header files for libcaca library
59 Summary(pl):    Pliki nag³ówkowe biblioteki libcaca
60 Group:          Development/Libraries
61 # to be restored when switching to shared lib
62 #Requires:      %{name} = %{version}-%{release}
63 Requires:       slang-devel
64
65 %description devel
66 Header files for libcaca library.
67
68 %description devel -l pl
69 Pliki nag³ówkowe biblioteki libcaca.
70
71 %package static
72 Summary:        Static libcaca library
73 Summary(pl):    Statyczna biblioteka libcaca
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static libcaca library.
79
80 %description static -l pl
81 Statyczna biblioteka libcaca.
82
83 %prep
84 %setup -q
85
86 %build
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         --enable-x11 \
94         --disable-ncurses \
95         --enable-slang
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 mv doc/man/man3caca doc/man/man3
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # replace symlink by groff include
106 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/caca{ball,fire,moir,plas}.1
107 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaball.1
108 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacafire.1
109 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacamoir.1
110 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaplas.1
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 #%post  -p /sbin/ldconfig
116 #%postun        -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS BUGS ChangeLog NEWS NOTES README TODO
121 %attr(755,root,root) %{_bindir}/cacaball
122 %attr(755,root,root) %{_bindir}/cacademo
123 %attr(755,root,root) %{_bindir}/cacafire
124 %attr(755,root,root) %{_bindir}/cacamoir
125 %attr(755,root,root) %{_bindir}/cacaplas
126 %attr(755,root,root) %{_bindir}/cacaview
127 #%attr(755,root,root) %{_libdir}/libcaca.so.*.*.*
128
129 %{_datadir}/%{name}
130 %{_mandir}/man1/cacaball.1*
131 %{_mandir}/man1/cacademo.1*
132 %{_mandir}/man1/cacafire.1*
133 %{_mandir}/man1/cacamoir.1*
134 %{_mandir}/man1/cacaplas.1*
135 %{_mandir}/man1/cacaview.1*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %doc doc/html/*
140 %attr(755,root,root) %{_bindir}/caca-config
141 #%attr(755,root,root) %{_libdir}/libcaca.so
142 #%{_libdir}/libcaca.la
143 %{_libdir}/libcaca.a
144 %{_libdir}/libcaca_pic.a
145 %{_includedir}/*.h
146 %{_mandir}/man1/caca-config.1*
147 # man3 pages have too common base names to be included
148
149 #%files static
150 #%defattr(644,root,root,755)
151 #%{_libdir}/libcaca.a
This page took 0.041583 seconds and 4 git commands to generate.