]> git.pld-linux.org Git - packages/libcaca.git/blob - libcaca.spec
- -devel doesn't require base (until shared lib comes)
[packages/libcaca.git] / libcaca.spec
1 Summary:        Graphics library that outputs text instead of pixels
2 Summary(pl):    Biblioteka graficzna wy¶wietlaj±ca tekst zamiast pikseli
3 Name:           libcaca
4 Version:        0.9
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://sam.zoy.org/projects/libcaca/%{name}-%{version}.tar.bz2
9 # Source0-md5:  c7d5c46206091a9203fcb214abb25e4a
10 URL:            http://sam.zoy.org/projects/libcaca/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  imlib2-devel
15 BuildRequires:  libtool
16 BuildRequires:  slang-devel
17 # shouldn't these be in doxygen requirements?
18 BuildRequires:  tetex-fonts-jknappen
19 BuildRequires:  tetex-makeindex
20 BuildRequires:  XFree86-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         specflags       -fomit-frame-pointer
24
25 %description
26 The libcaca library is a graphics library that outputs text instead of
27 pixels, so that it can work on older video cards or text terminals. It
28 is not unlike the famous AAlib library.
29
30 The differences with AAlib are the following:
31 - 16 available colours for character output (256 colour pairs)
32 - dithering of colour images
33 - basic sprite primitives
34
35 But libcaca also has the following limitations:
36 - no support for brightness, contrast, gamma
37 - unefficient character-choosing algorithms
38 - no raw keyboard support
39
40 %description -l pl
41 Biblioteka libcaca to biblioteka graficzna wy¶wietlaj±ca tekst zamiast
42 pikseli, dziêki czemu mo¿e dzia³aæ na starszych kartach graficznych
43 oraz terminalach tekstowych. Pod tym wzglêdem jest podobna do s³ynnej
44 biblioteki AAlib.
45
46 Ró¿nice w stosunku do AAlib s± nastêpuj±ce:
47 - 16 dostêpnych kolorów dla znaków (256 par kolorów)
48 - dithering kolorowych obrazów
49 - proste kszta³ty duszków (sprites)
50
51 Ale libcaca ma tak¿e nastêpuj±ce ograniczenia:
52 - brak obs³ugi jasno¶ci, kontrakstu, korekcji gamma
53 - ma³o wydajne algorytmy wyboru znaków
54 - brak obs³ugi klawiatury w trybie surowym
55
56 %package devel
57 Summary:        Header files for libcaca library
58 Summary(pl):    Pliki nag³ówkowe biblioteki libcaca
59 Group:          Development/Libraries
60 # to be restored when switching to shared lib
61 #Requires:      %{name} = %{version}-%{release}
62 Requires:       slang-devel
63
64 %description devel
65 Header files for libcaca library.
66
67 %description devel -l pl
68 Pliki nag³ówkowe biblioteki libcaca.
69
70 %package static
71 Summary:        Static libcaca library
72 Summary(pl):    Statyczna biblioteka libcaca
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libcaca library.
78
79 %description static -l pl
80 Statyczna biblioteka libcaca.
81
82 %prep
83 %setup -q
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         --enable-x11 \
93         --disable-ncurses \
94         --enable-slang
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # replace symlink by groff include
105 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/caca{ball,fire,moir,plas}.1
106 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaball.1
107 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacafire.1
108 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacamoir.1
109 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaplas.1
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 #%post  -p /sbin/ldconfig
115 #%postun        -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS BUGS ChangeLog NEWS NOTES README TODO
120 %attr(755,root,root) %{_bindir}/cacaball
121 %attr(755,root,root) %{_bindir}/cacademo
122 %attr(755,root,root) %{_bindir}/cacafire
123 %attr(755,root,root) %{_bindir}/cacamoir
124 %attr(755,root,root) %{_bindir}/cacaplas
125 %attr(755,root,root) %{_bindir}/cacaview
126 #%attr(755,root,root) %{_libdir}/libcaca.so.*.*.*
127
128 %{_datadir}/%{name}
129 %{_mandir}/man1/cacaball.1*
130 %{_mandir}/man1/cacademo.1*
131 %{_mandir}/man1/cacafire.1*
132 %{_mandir}/man1/cacamoir.1*
133 %{_mandir}/man1/cacaplas.1*
134 %{_mandir}/man1/cacaview.1*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/html/*
139 %attr(755,root,root) %{_bindir}/caca-config
140 #%attr(755,root,root) %{_libdir}/libcaca.so
141 #%{_libdir}/libcaca.la
142 %{_libdir}/libcaca.a
143 %{_libdir}/libcaca_pic.a
144 %{_includedir}/*.h
145 %{_mandir}/man1/caca-config.1*
146 # man3 pages have too common base names to be included
147
148 #%files static
149 #%defattr(644,root,root,755)
150 #%{_libdir}/libcaca.a
This page took 0.571375 seconds and 4 git commands to generate.