]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
bitstring.3 conflict with fcron
[packages/libbsd.git] / libbsd.spec
1 # TODO
2 # - take french bitstring.3 from fcron?
3 Summary:        Utility functions from BSD systems
4 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
5 Name:           libbsd
6 Version:        0.7.0
7 Release:        2
8 License:        BSD, MIT (depending on part)
9 Group:          Libraries
10 Source0:        http://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
11 # Source0-md5:  fcceb4e66fd448ca4ed42ba22a8babb0
12 URL:            http://libbsd.freedesktop.org/
13 BuildRequires:  sed >= 4.0
14 BuildRequires:  tar >= 1:1.22
15 BuildRequires:  xz
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This library provides useful functions commonly found on BSD systems,
20 and lacking on others like GNU systems, thus making it easier to port
21 projects with strong BSD origins, without needing to embed the same
22 code over and over again on each project.
23
24 %description -l pl.UTF-8
25 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
26 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
27 portowanie projektów mających silne korzenie BSD bez potrzeby
28 osadzania ciągle tego samego kodu w każdym projekcie.
29
30 %package devel
31 Summary:        Header files for BSD library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for BSD library.
38
39 Note: to avoid clash with libbsd.a from glibc, library provided by
40 this package is available as -lbsdutil.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki BSD.
44
45 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
46 dostarczana przez ten pakiet jest dostępna jako -lbsdutil.
47
48 %package static
49 Summary:        Static BSD library
50 Summary(pl.UTF-8):      Statyczna biblioteka BSD
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static BSD library.
56
57 Note: to avoid clash with libbsd.a from glibc, library provided by
58 this package is available as libbsdutil.a.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka BSD.
62
63 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
64 dostarczana przez ten pakiet jest dostępna jako libbsdutil.a.
65
66 %prep
67 %setup -q
68
69 %build
70 %configure \
71         --disable-silent-rules
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 # avoid clash with libbsd.a from glibc
81 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.so
82 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.a
83 sed -i -e 's/-lbsd/-lbsdutil/' $RPM_BUILD_ROOT%{_pkgconfigdir}/{libbsd,libbsd-overlay}.pc
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc COPYING ChangeLog README TODO
95 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libbsdutil.so
101 %{_libdir}/libbsd-ctor.a
102 %{_includedir}/bsd
103 %{_pkgconfigdir}/libbsd.pc
104 %{_pkgconfigdir}/libbsd-ctor.pc
105 %{_pkgconfigdir}/libbsd-overlay.pc
106 %{_mandir}/man3/arc4random*.3*
107 %{_mandir}/man3/bitstring.3*
108 %{_mandir}/man3/closefrom.3*
109 %{_mandir}/man3/dehumanize_number.3*
110 %{_mandir}/man3/expand_number.3*
111 %{_mandir}/man3/fgetln.3*
112 %{_mandir}/man3/fgetwln.3*
113 %{_mandir}/man3/flopen.3*
114 %{_mandir}/man3/fmtcheck.3*
115 %{_mandir}/man3/fparseln.3*
116 %{_mandir}/man3/funopen.3*
117 %{_mandir}/man3/getbsize.3*
118 %{_mandir}/man3/getmode.3*
119 %{_mandir}/man3/getpeereid.3*
120 %{_mandir}/man3/getprogname.3*
121 %{_mandir}/man3/heapsort.3*
122 %{_mandir}/man3/humanize_number.3*
123 %{_mandir}/man3/md5.3bsd*
124 %{_mandir}/man3/mergesort.3*
125 %{_mandir}/man3/nlist.3*
126 %{_mandir}/man3/pidfile.3*
127 %{_mandir}/man3/queue.3bsd*
128 %{_mandir}/man3/radixsort.3*
129 %{_mandir}/man3/readpassphrase.3*
130 %{_mandir}/man3/reallocf.3*
131 %{_mandir}/man3/setmode.3*
132 %{_mandir}/man3/setproctitle.3*
133 %{_mandir}/man3/setprogname.3*
134 %{_mandir}/man3/sradixsort.3*
135 %{_mandir}/man3/stringlist.3*
136 %{_mandir}/man3/strlcat.3*
137 %{_mandir}/man3/strlcpy.3*
138 %{_mandir}/man3/strmode.3*
139 %{_mandir}/man3/strnstr.3*
140 %{_mandir}/man3/strtonum.3*
141 %{_mandir}/man3/tree.3*
142 %{_mandir}/man3/unvis.3*
143 %{_mandir}/man3/vis.3*
144 %{_mandir}/man3/wcslcat.3*
145 %{_mandir}/man3/wcslcpy.3*
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libbsdutil.a
This page took 0.062252 seconds and 3 git commands to generate.