]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
3a9ac4be7f9447a2d8feac1ad80552c170ca7027
[packages/libbsd.git] / libbsd.spec
1 # TODO
2 # - take french bitstring.3 from fcron?
3 Summary:        Utility functions from BSD systems
4 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
5 Name:           libbsd
6 Version:        0.8.2
7 Release:        1
8 License:        BSD, MIT (depending on part)
9 Group:          Libraries
10 Source0:        https://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
11 # Source0-md5:  cdee252ccff978b50ad2336278c506c9
12 URL:            https://libbsd.freedesktop.org/
13 BuildRequires:  sed >= 4.0
14 BuildRequires:  tar >= 1:1.22
15 BuildRequires:  xz
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This library provides useful functions commonly found on BSD systems,
20 and lacking on others like GNU systems, thus making it easier to port
21 projects with strong BSD origins, without needing to embed the same
22 code over and over again on each project.
23
24 %description -l pl.UTF-8
25 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
26 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
27 portowanie projektów mających silne korzenie BSD bez potrzeby
28 osadzania ciągle tego samego kodu w każdym projekcie.
29
30 %package devel
31 Summary:        Header files for BSD library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Conflicts:      glibc-devel < 6:2.19
36
37 %description devel
38 Header files for BSD library.
39
40 Note: to avoid clash with libbsd.a from glibc, library provided by
41 this package is available as -lbsdutil.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki BSD.
45
46 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
47 dostarczana przez ten pakiet jest dostępna jako -lbsdutil.
48
49 %package static
50 Summary:        Static BSD library
51 Summary(pl.UTF-8):      Statyczna biblioteka BSD
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54 Conflicts:      glibc-devel < 6:2.19
55
56 %description static
57 Static BSD library.
58
59 Note: to avoid clash with libbsd.a from glibc, library provided by
60 this package is available as libbsdutil.a.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka BSD.
64
65 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
66 dostarczana przez ten pakiet jest dostępna jako libbsdutil.a.
67
68 %prep
69 %setup -q
70
71 %build
72 %configure \
73         --disable-silent-rules
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 # obsoleted by pkg-config
83 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc COPYING ChangeLog README TODO
94 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libbsd.so
100 %{_libdir}/libbsd-ctor.a
101 %{_includedir}/bsd
102 %{_pkgconfigdir}/libbsd.pc
103 %{_pkgconfigdir}/libbsd-ctor.pc
104 %{_pkgconfigdir}/libbsd-overlay.pc
105 %{_mandir}/man3/arc4random*.3*
106 %{_mandir}/man3/bitstring.3*
107 %{_mandir}/man3/closefrom.3*
108 %{_mandir}/man3/dehumanize_number.3*
109 %{_mandir}/man3/expand_number.3*
110 %{_mandir}/man3/explicit_bzero.3*
111 %{_mandir}/man3/fgetln.3*
112 %{_mandir}/man3/fgetwln.3*
113 %{_mandir}/man3/flopen.3*
114 %{_mandir}/man3/fmtcheck.3*
115 %{_mandir}/man3/fparseln.3*
116 %{_mandir}/man3/funopen.3*
117 %{_mandir}/man3/getbsize.3*
118 %{_mandir}/man3/getmode.3*
119 %{_mandir}/man3/getpeereid.3*
120 %{_mandir}/man3/getprogname.3*
121 %{_mandir}/man3/heapsort.3*
122 %{_mandir}/man3/humanize_number.3*
123 %{_mandir}/man3/md5.3bsd*
124 %{_mandir}/man3/mergesort.3*
125 %{_mandir}/man3/nlist.3*
126 %{_mandir}/man3/pidfile.3*
127 %{_mandir}/man3/queue.3bsd*
128 %{_mandir}/man3/radixsort.3*
129 %{_mandir}/man3/readpassphrase.3*
130 %{_mandir}/man3/reallocarray.3*
131 %{_mandir}/man3/reallocf.3*
132 %{_mandir}/man3/setmode.3*
133 %{_mandir}/man3/setproctitle.3*
134 %{_mandir}/man3/setprogname.3*
135 %{_mandir}/man3/sradixsort.3*
136 %{_mandir}/man3/stringlist.3*
137 %{_mandir}/man3/strlcat.3*
138 %{_mandir}/man3/strlcpy.3*
139 %{_mandir}/man3/strmode.3*
140 %{_mandir}/man3/strnstr.3*
141 %{_mandir}/man3/strtonum.3*
142 %{_mandir}/man3/tree.3*
143 %{_mandir}/man3/unvis.3*
144 %{_mandir}/man3/vis.3*
145 %{_mandir}/man3/wcslcat.3*
146 %{_mandir}/man3/wcslcpy.3*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libbsd.a
This page took 0.097377 seconds and 3 git commands to generate.