]> git.pld-linux.org Git - packages/libayatana-indicator.git/blob - libayatana-indicator.spec
rename to libayatana-indicator
[packages/libayatana-indicator.git] / libayatana-indicator.spec
1 Summary:        Shared functions for Ayatana indicators (GTK+ 2.x version)
2 Summary(pl.UTF-8):      Funkcje współdzielone dla wskaźników Ayatana (wersja dla GTK+ 2.x)
3 Name:           libindicator
4 Version:        12.10.1
5 Release:        3
6 License:        GPL v3
7 Group:          Libraries
8 #Source0Download: https://launchpad.net/libindicator/+download
9 Source0:        http://launchpad.net/libindicator/12.10/%{version}/+download/%{name}-%{version}.tar.gz
10 # Source0-md5:  5fd4d6bab339fc9611078b64c44a85a8
11 Patch0:         %{name}-sh.patch
12 URL:            https://launchpad.net/libindicator
13 BuildRequires:  autoconf >= 2.64
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  glib2-devel >= 1:2.22
16 BuildRequires:  gtk+2-devel >= 2:2.18
17 BuildRequires:  gtk+3-devel >= 3.0
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  pkgconfig
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  which
22 Requires:       glib2 >= 1:2.22
23 Requires:       gtk+2 >= 2:2.18
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A set of symbols and convenience functions that all Ayatana indicators
28 are likely to use. This package contains GTK+ 2.x version.
29
30 %description -l pl.UTF-8
31 Zbiór symboli i wygodnych funkcji, które mogą być używane przez
32 wszystkie wskaźniki Ayatana. Ten pakiet zawiera wersję dla GTK+ 2.x.
33
34 %package devel
35 Summary:        Development files for libindicator (GTK+ 2.x version)
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libindicator (wersja dla GTK+ 2.x)
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       glib2-devel >= 1:2.22
40 Requires:       gtk+2-devel >= 2:2.18
41
42 %description devel
43 This package contains the header files for developing applications
44 that use libindicator (GTK+ 2.x version).
45
46 %description devel -l pl.UTF-8
47 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
48 wykorzystujących bibliotekę libindicator (w wersji dla GTK+ 2.x).
49
50 %package gtk3
51 Summary:        Shared functions for Ayatana indicators (GTK+ 3.x version)
52 Summary(pl.UTF-8):      Funkcje współdzielone dla wskaźników Ayatana (wersja dla GTK+ 3.x)
53 Group:          Libraries
54 Requires:       glib2 >= 1:2.22
55 Requires:       gtk+3 >= 3.0
56
57 %description gtk3
58 A set of symbols and convenience functions that all Ayatana indicators
59 are likely to use. This package contains GTK+ 3.x version.
60
61 %description gtk3 -l pl.UTF-8
62 Zbiór symboli i wygodnych funkcji, które mogą być używane przez
63 wszystkie wskaźniki Ayatana. Ten pakiet zawiera wersję dla GTK+ 3.x.
64
65 %package gtk3-devel
66 Summary:        Development files for libindicator (GTK+ 3.x version)
67 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libindicator (wersja dla GTK+ 3.x)
68 Group:          Development/Libraries
69 Requires:       %{name}-gtk3 = %{version}-%{release}
70 Requires:       glib2-devel >= 1:2.22
71 Requires:       gtk+3-devel >= 3.0
72
73 %description gtk3-devel
74 This package contains the header files for developing applications
75 that use libindicator (GTK+ 3.x version).
76
77 %description gtk3-devel -l pl.UTF-8
78 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
79 wykorzystujących bibliotekę libindicator (w wersji dla GTK+ 3.x).
80
81 %prep
82 %setup -q
83 %patch0 -p1
84
85 %{__sed} -i -e 's|-Werror||g' */Makefile.am
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 # we build it twice, once against GTK+ 3 and once against GTK+ 2, so
94 # both GTK+ 2 and GTK+ 3 apps can use it; the GTK+ 3 build is
95 # libindicator-gtk3. When we have no need for the GTK+ 2 build any more
96 # we can drop the -gtk3 package and have the main package build against
97 # GTK+ 3.
98 install -d build-gtk{2,3}
99 cd build-gtk2
100 ../%configure \
101         --disable-silent-rules \
102         --disable-static \
103         --with-gtk=2
104 %{__make}
105
106 cd ../build-gtk3
107 ../%configure \
108         --disable-silent-rules \
109         --disable-static \
110         --with-gtk=3
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} -C build-gtk2 install -j1 \
117         DESTDIR=$RPM_BUILD_ROOT
118 %{__make} -C build-gtk3 install -j1 \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
122
123 # dirs for library users, see .pc files for paths
124 install -d $RPM_BUILD_ROOT%{_libdir}/{indicators,indicators3}/7
125 install -d $RPM_BUILD_ROOT%{_datadir}/libindicator/icons
126
127 # this dummy indicator is fairly useless, it's not shipped in Ubuntu
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdummy-indicator*.so
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %post   gtk3 -p /sbin/ldconfig
137 %postun gtk3 -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS
142 %attr(755,root,root) %{_libdir}/libindicator.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libindicator.so.7
144 %attr(755,root,root) %{_libexecdir}/indicator-loader
145 %dir %{_libdir}/indicators
146 %dir %{_libdir}/indicators/7
147 %dir %{_datadir}/libindicator
148 %dir %{_datadir}/libindicator/icons
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libindicator.so
153 %{_includedir}/libindicator-0.4
154 %{_pkgconfigdir}/indicator-0.4.pc
155 # This is marked as 'for development use only'
156 %{_datadir}/libindicator/80indicator-debugging
157
158 %files gtk3
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog NEWS
161 %attr(755,root,root) %{_libdir}/libindicator3.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libindicator3.so.7
163 %attr(755,root,root) %{_libexecdir}/indicator-loader3
164 %dir %{_libdir}/indicators3
165 %dir %{_libdir}/indicators3/7
166 %dir %{_datadir}/libindicator
167 %dir %{_datadir}/libindicator/icons
168
169 %files gtk3-devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libindicator3.so
172 %{_includedir}/libindicator3-0.4
173 %{_pkgconfigdir}/indicator3-0.4.pc
This page took 0.063132 seconds and 3 git commands to generate.