]> git.pld-linux.org Git - packages/libayatana-indicator.git/blob - libayatana-indicator.spec
new maintained version of libindicator
[packages/libayatana-indicator.git] / libayatana-indicator.spec
1 # TODO:
2 # - package systemd user target unit
3
4 Summary:        Shared functions for Ayatana indicators (GTK+ 2.x version)
5 Summary(pl.UTF-8):      Funkcje współdzielone dla wskaźników Ayatana (wersja dla GTK+ 2.x)
6 Name:           libayatana-indicator
7 Version:        0.8.4
8 Release:        1
9 License:        GPL v3
10 Group:          Libraries
11 #Source0Download: https://github.com/AyatanaIndicators/libayatana-indicator/releases
12 Source0:        https://github.com/AyatanaIndicators/libayatana-indicator/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  5b61141bbd42ba5a161e59adcaafc9d8
14 URL:            https://github.com/AyatanaIndicators/libayatana-indicator
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  ayatana-ido-devel >= 0.8.0
18 BuildRequires:  glib2-devel >= 1:2.37
19 BuildRequires:  gtk+2-devel >= 2:2.18
20 BuildRequires:  gtk+3-devel >= 3.6
21 BuildRequires:  libtool >= 2:2.2
22 BuildRequires:  pkgconfig
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  which
25 Requires:       glib2 >= 1:2.37
26 Requires:       gtk+2 >= 2:2.18
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 A set of symbols and convenience functions that all Ayatana indicators
31 are likely to use. This package contains GTK+ 2.x version.
32
33 %description -l pl.UTF-8
34 Zbiór symboli i wygodnych funkcji, które mogą być używane przez
35 wszystkie wskaźniki Ayatana. Ten pakiet zawiera wersję dla GTK+ 2.x.
36
37 %package devel
38 Summary:        Development files for libayatana-indicator (GTK+ 2.x version)
39 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libayatana-indicator (wersja dla GTK+ 2.x)
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       glib2-devel >= 1:2.37
43 Requires:       gtk+2-devel >= 2:2.18
44
45 %description devel
46 This package contains the header files for developing applications
47 that use libayatana-indicator (GTK+ 2.x version).
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
51 wykorzystujących bibliotekę libayatana-indicator (w wersji dla GTK+
52 2.x).
53
54 %package gtk3
55 Summary:        Shared functions for Ayatana indicators (GTK+ 3.x version)
56 Summary(pl.UTF-8):      Funkcje współdzielone dla wskaźników Ayatana (wersja dla GTK+ 3.x)
57 Group:          Libraries
58 Requires:       glib2 >= 1:2.37
59 Requires:       gtk+3 >= 3.6
60
61 %description gtk3
62 A set of symbols and convenience functions that all Ayatana indicators
63 are likely to use. This package contains GTK+ 3.x version.
64
65 %description gtk3 -l pl.UTF-8
66 Zbiór symboli i wygodnych funkcji, które mogą być używane przez
67 wszystkie wskaźniki Ayatana. Ten pakiet zawiera wersję dla GTK+ 3.x.
68
69 %package gtk3-devel
70 Summary:        Development files for libayatana-indicator (GTK+ 3.x version)
71 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libayatana-indicator (wersja dla GTK+ 3.x)
72 Group:          Development/Libraries
73 Requires:       %{name}-gtk3 = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.37
75 Requires:       gtk+3-devel >= 3.6
76
77 %description gtk3-devel
78 This package contains the header files for developing applications
79 that use libayatana-indicator (GTK+ 3.x version).
80
81 %description gtk3-devel -l pl.UTF-8
82 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
83 wykorzystujących bibliotekę libayatana-indicator (w wersji dla GTK+
84 3.x).
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 # we build it twice, once against GTK+ 3 and once against GTK+ 2, so
96 # both GTK+ 2 and GTK+ 3 apps can use it; the GTK+ 3 build is
97 # libayatana-indicator-gtk3. When we have no need for the GTK+ 2 build any more
98 # we can drop the -gtk3 package and have the main package build against
99 # GTK+ 3.
100 install -d build-gtk{2,3}
101 cd build-gtk2
102 ../%configure \
103         --disable-silent-rules \
104         --disable-static \
105         --with-gtk=2
106 %{__make}
107
108 cd ../build-gtk3
109 ../%configure \
110         --disable-silent-rules \
111         --disable-static \
112         --with-gtk=3
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} -C build-gtk2 install -j1 \
119         DESTDIR=$RPM_BUILD_ROOT
120 %{__make} -C build-gtk3 install -j1 \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
124
125 # dirs for library users, see .pc files for paths
126 install -d $RPM_BUILD_ROOT%{_libdir}/ayatana-{indicators,indicators3}/7
127 install -d $RPM_BUILD_ROOT%{_datadir}/libayatana-indicator/icons
128
129 # this dummy indicator is fairly useless, it's not shipped in Ubuntu
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdummy-indicator*.so
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %post   gtk3 -p /sbin/ldconfig
139 %postun gtk3 -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS
144 %attr(755,root,root) %{_libdir}/libayatana-indicator.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libayatana-indicator.so.7
146 %dir %{_libdir}/ayatana-indicators
147 %dir %{_libdir}/ayatana-indicators/7
148 %dir %{_datadir}/libayatana-indicator
149 %dir %{_datadir}/libayatana-indicator/icons
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libayatana-indicator.so
154 %{_includedir}/libayatana-indicator-0.4
155 %{_pkgconfigdir}/ayatana-indicator-0.4.pc
156 # This is marked as 'for development use only'
157 %{_datadir}/libayatana-indicator/80indicator-debugging
158
159 %files gtk3
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog NEWS
162 %attr(755,root,root) %{_libdir}/libayatana-indicator3.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libayatana-indicator3.so.7
164 %attr(755,root,root) %{_libexecdir}/ayatana-indicator-loader3
165 %dir %{_libdir}/ayatana-indicators3
166 %dir %{_libdir}/ayatana-indicators3/7
167 %dir %{_datadir}/libayatana-indicator
168 %dir %{_datadir}/libayatana-indicator/icons
169
170 %files gtk3-devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libayatana-indicator3.so
173 %{_includedir}/libayatana-indicator3-0.4
174 %{_pkgconfigdir}/ayatana-indicator3-0.4.pc
This page took 0.084847 seconds and 3 git commands to generate.