]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
- download URL
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        Library to create and read several different archive formats
6 Summary(pl.UTF-8):      Biblioteka do tworzenia i odczytu różnych formatów archiwów
7 Name:           libarchive
8 Version:        2.8.4
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/libarchive/downloads/list
13 Source0:        http://libarchive.googlecode.com/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  83b237a542f27969a8d68ac217dc3796
15 Patch0:         %{name}-man_progname.patch
16 URL:            http://people.freebsd.org/~kientzle/libarchive/
17 BuildRequires:  acl-devel
18 BuildRequires:  attr-devel
19 #BuildRequires: autoconf >= 2.50
20 #BuildRequires: automake
21 BuildRequires:  bzip2-devel
22 # for <ext2fs/ext2_fs.h>
23 BuildRequires:  e2fsprogs-devel
24 BuildRequires:  libmd5-devel
25 #BuildRequires: libtool
26 BuildRequires:  libxml2-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  xz-devel
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Libarchive is a programming library that can create and read several
34 different streaming archive formats, including most popular TAR
35 variants and several CPIO formats. It can also write SHAR archives.
36
37 %description -l pl.UTF-8
38 Libarchive jest biblioteką służacą to tworzenia i odczytu wielu
39 różnych strumieniowych formatów archiwów, włączając w to popularne
40 odmiany TAR oraz wiele formatów CPIO. Biblioteka ta potrafi także
41 zapisywać archiwa SHAR.
42
43 %package devel
44 Summary:        Header files for libarchive library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       acl-devel
49 Requires:       attr-devel
50 Requires:       bzip2-devel
51 Requires:       libxml2-devel
52 Requires:       openssl-devel
53 Requires:       xz-devel
54 Requires:       zlib-devel
55
56 %description devel
57 Header files for libarchive library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki libarchive.
61
62 %package static
63 Summary:        Static libarchive library
64 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static libarchive library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka libarchive.
73
74 %package -n bsdcpio
75 Summary:        bsdcpio - cpio(1) implementation based on libarchive
76 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
77 Group:          Applications/Archiving
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n bsdcpio
81 bsdcpio - cpio(1) implementation based on libarchive.
82
83 %description -n bsdcpio -l pl.UTF-8
84 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
85
86 %package -n bsdtar
87 Summary:        bsdtar - tar(1) implementation based on libarchive
88 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
89 Group:          Applications/Archiving
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n bsdtar
93 bsdtar - tar(1) implementation based on libarchive.
94
95 %description -n bsdtar -l pl.UTF-8
96 bsdtar - implementacja programu tar(1), oparta na libarchive.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 #%%{__libtoolize}
104 #%%{__aclocal}
105 #%%{__autoconf}
106 #%%{__autoheader}
107 #%%{__automake}
108 %configure \
109         --enable-static%{!?with_static_libs:=no}
110 %{__make} -j1
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.2
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libarchive.so
131 %{_libdir}/libarchive.la
132 %{_includedir}/archive*.h
133 %{_mandir}/man3/archive_*.3*
134 %{_mandir}/man3/libarchive.3*
135 %{_mandir}/man3/libarchive_internals.3*
136 %{_mandir}/man5/libarchive-formats.5*
137 %{_mandir}/man5/cpio.5*
138 %{_mandir}/man5/mtree.5*
139 %{_mandir}/man5/tar.5*
140 %{_pkgconfigdir}/libarchive.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libarchive.a
146 %endif
147
148 %files -n bsdcpio
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/bsdcpio
151 %{_mandir}/man1/bsdcpio.1*
152
153 %files -n bsdtar
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/bsdtar
156 %{_mandir}/man1/bsdtar.1*
This page took 0.035182 seconds and 4 git commands to generate.