]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
- x32 rebuild
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        Library to create and read several different archive formats
6 Summary(pl.UTF-8):      Biblioteka do tworzenia i odczytu różnych formatów archiwów
7 Name:           libarchive
8 Version:        3.1.2
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://www.libarchive.org/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  efad5a503f66329bb9d2f4308b5de98a
14 Patch0:         %{name}-man_progname.patch
15 URL:            http://www.libarchive.org/
16 BuildRequires:  acl-devel
17 BuildRequires:  attr-devel
18 #BuildRequires: autoconf >= 2.65
19 #BuildRequires: automake
20 BuildRequires:  bzip2-devel
21 # for <ext2fs/ext2_fs.h>
22 BuildRequires:  e2fsprogs-devel
23 #BuildRequires: libtool
24 BuildRequires:  libxml2-devel
25 BuildRequires:  lzo-devel >= 2
26 BuildRequires:  nettle-devel
27 BuildRequires:  xz-devel
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Libarchive is a programming library that can create and read several
33 different streaming archive formats, including most popular TAR
34 variants and several CPIO formats. It can also write SHAR archives.
35
36 %description -l pl.UTF-8
37 Libarchive jest biblioteką służacą to tworzenia i odczytu wielu
38 różnych strumieniowych formatów archiwów, włączając w to popularne
39 odmiany TAR oraz wiele formatów CPIO. Biblioteka ta potrafi także
40 zapisywać archiwa SHAR.
41
42 %package devel
43 Summary:        Header files for libarchive library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       acl-devel
48 Requires:       attr-devel
49 Requires:       bzip2-devel
50 Requires:       libxml2-devel
51 Requires:       nettle-devel
52 Requires:       xz-devel
53 Requires:       zlib-devel
54
55 %description devel
56 Header files for libarchive library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki libarchive.
60
61 %package static
62 Summary:        Static libarchive library
63 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static libarchive library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libarchive.
72
73 %package -n bsdcpio
74 Summary:        bsdcpio - cpio(1) implementation based on libarchive
75 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
76 Group:          Applications/Archiving
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n bsdcpio
80 bsdcpio - cpio(1) implementation based on libarchive.
81
82 %description -n bsdcpio -l pl.UTF-8
83 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
84
85 %package -n bsdtar
86 Summary:        bsdtar - tar(1) implementation based on libarchive
87 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
88 Group:          Applications/Archiving
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n bsdtar
92 bsdtar - tar(1) implementation based on libarchive.
93
94 %description -n bsdtar -l pl.UTF-8
95 bsdtar - implementacja programu tar(1), oparta na libarchive.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 #%%{__libtoolize}
103 #%%{__aclocal}
104 #%%{__autoconf}
105 #%%{__autoheader}
106 #%%{__automake}
107 %configure \
108         --disable-silent-rules \
109         --enable-bsdcpio=shared \
110         --enable-bsdtar=shared \
111         --enable-static%{!?with_static_libs:=no}
112 %{__make} -j1
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.13
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libarchive.so
133 %{_libdir}/libarchive.la
134 %{_includedir}/archive*.h
135 %{_mandir}/man3/archive_*.3*
136 %{_mandir}/man3/libarchive.3*
137 %{_mandir}/man3/libarchive_changes.3*
138 %{_mandir}/man3/libarchive_internals.3*
139 %{_mandir}/man5/libarchive-formats.5*
140 %{_mandir}/man5/cpio.5*
141 %{_mandir}/man5/mtree.5*
142 %{_mandir}/man5/tar.5*
143 %{_pkgconfigdir}/libarchive.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libarchive.a
149 %endif
150
151 %files -n bsdcpio
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/bsdcpio
154 %{_mandir}/man1/bsdcpio.1*
155
156 %files -n bsdtar
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/bsdtar
159 %{_mandir}/man1/bsdtar.1*
This page took 0.112578 seconds and 4 git commands to generate.