]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
- updated to 3.0.2 (note: new soname)
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        Library to create and read several different archive formats
6 Summary(pl.UTF-8):      Biblioteka do tworzenia i odczytu różnych formatów archiwów
7 Name:           libarchive
8 Version:        3.0.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/libarchive/downloads/list
13 Source0:        http://libarchive.googlecode.com/files/%{name}-%{version}.tar.gz
14 # Source0-md5:  4df33cb107c9702c80473e0794ddf833
15 Patch0:         %{name}-man_progname.patch
16 URL:            http://people.freebsd.org/~kientzle/libarchive/
17 BuildRequires:  acl-devel
18 BuildRequires:  attr-devel
19 #BuildRequires: autoconf >= 2.65
20 #BuildRequires: automake
21 BuildRequires:  bzip2-devel
22 # for <ext2fs/ext2_fs.h>
23 BuildRequires:  e2fsprogs-devel
24 #BuildRequires: libtool
25 BuildRequires:  libxml2-devel
26 BuildRequires:  nettle-devel
27 BuildRequires:  xz-devel
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Libarchive is a programming library that can create and read several
33 different streaming archive formats, including most popular TAR
34 variants and several CPIO formats. It can also write SHAR archives.
35
36 %description -l pl.UTF-8
37 Libarchive jest biblioteką służacą to tworzenia i odczytu wielu
38 różnych strumieniowych formatów archiwów, włączając w to popularne
39 odmiany TAR oraz wiele formatów CPIO. Biblioteka ta potrafi także
40 zapisywać archiwa SHAR.
41
42 %package devel
43 Summary:        Header files for libarchive library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       acl-devel
48 Requires:       attr-devel
49 Requires:       bzip2-devel
50 Requires:       libxml2-devel
51 Requires:       nettle-devel
52 Requires:       xz-devel
53 Requires:       zlib-devel
54
55 %description devel
56 Header files for libarchive library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki libarchive.
60
61 %package static
62 Summary:        Static libarchive library
63 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static libarchive library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libarchive.
72
73 %package -n bsdcpio
74 Summary:        bsdcpio - cpio(1) implementation based on libarchive
75 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
76 Group:          Applications/Archiving
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n bsdcpio
80 bsdcpio - cpio(1) implementation based on libarchive.
81
82 %description -n bsdcpio -l pl.UTF-8
83 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
84
85 %package -n bsdtar
86 Summary:        bsdtar - tar(1) implementation based on libarchive
87 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
88 Group:          Applications/Archiving
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n bsdtar
92 bsdtar - tar(1) implementation based on libarchive.
93
94 %description -n bsdtar -l pl.UTF-8
95 bsdtar - implementacja programu tar(1), oparta na libarchive.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 #%%{__libtoolize}
103 #%%{__aclocal}
104 #%%{__autoconf}
105 #%%{__autoheader}
106 #%%{__automake}
107 %configure \
108         --enable-bsdcpio=shared \
109         --enable-bsdtar=shared \
110         --enable-static%{!?with_static_libs:=no}
111 %{__make} -j1
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.12
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libarchive.so
132 %{_libdir}/libarchive.la
133 %{_includedir}/archive*.h
134 %{_mandir}/man3/archive_*.3*
135 %{_mandir}/man3/libarchive.3*
136 %{_mandir}/man3/libarchive_internals.3*
137 %{_mandir}/man5/libarchive-formats.5*
138 %{_mandir}/man5/cpio.5*
139 %{_mandir}/man5/mtree.5*
140 %{_mandir}/man5/tar.5*
141 %{_pkgconfigdir}/libarchive.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libarchive.a
147 %endif
148
149 %files -n bsdcpio
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/bsdcpio
152 %{_mandir}/man1/bsdcpio.1*
153
154 %files -n bsdtar
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/bsdtar
157 %{_mandir}/man1/bsdtar.1*
This page took 0.07455 seconds and 4 git commands to generate.