]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
cleanup, update desc
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4
5 Summary:        Multi-format archive and compression library
6 Summary(pl.UTF-8):      Biblioteka do tworzenia i odczytu różnych formatów archiwów
7 Name:           libarchive
8 Version:        3.1.2
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://www.libarchive.org/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  efad5a503f66329bb9d2f4308b5de98a
14 Patch0:         %{name}-man_progname.patch
15 URL:            http://www.libarchive.org/
16 BuildRequires:  acl-devel
17 BuildRequires:  attr-devel
18 BuildRequires:  bzip2-devel
19 # for <ext2fs/ext2_fs.h>
20 BuildRequires:  e2fsprogs-devel
21 BuildRequires:  libxml2-devel
22 BuildRequires:  lzo-devel >= 2
23 BuildRequires:  nettle-devel
24 BuildRequires:  xz-devel
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Libarchive is a programming library that can create and read several
30 different streaming archive formats, including most popular TAR
31 variants, several CPIO formats, and both BSD and GNU ar variants. It
32 can also write SHAR archives and read ISO9660 CDROM images and ZIP
33 archives.
34
35 See README for complete format support.
36
37 %description -l pl.UTF-8
38 Libarchive jest biblioteką służacą to tworzenia i odczytu wielu
39 różnych strumieniowych formatów archiwów, włączając w to popularne
40 odmiany TAR oraz wiele formatów CPIO. Biblioteka ta potrafi także
41 zapisywać archiwa SHAR.
42
43 %package devel
44 Summary:        Header files for libarchive library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       acl-devel
49 Requires:       attr-devel
50 Requires:       bzip2-devel
51 Requires:       libxml2-devel
52 Requires:       nettle-devel
53 Requires:       xz-devel
54 Requires:       zlib-devel
55
56 %description devel
57 Header files for libarchive library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki libarchive.
61
62 %package static
63 Summary:        Static libarchive library
64 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static libarchive library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka libarchive.
73
74 %package -n bsdcpio
75 Summary:        bsdcpio - cpio(1) implementation based on libarchive
76 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
77 Group:          Applications/Archiving
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n bsdcpio
81 bsdcpio - cpio(1) implementation based on libarchive.
82
83 %description -n bsdcpio -l pl.UTF-8
84 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
85
86 %package -n bsdtar
87 Summary:        bsdtar - tar(1) implementation based on libarchive
88 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
89 Group:          Applications/Archiving
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n bsdtar
93 bsdtar - tar(1) implementation based on libarchive.
94
95 %description -n bsdtar -l pl.UTF-8
96 bsdtar - implementacja programu tar(1), oparta na libarchive.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %configure \
104         --disable-silent-rules \
105         --enable-bsdcpio=shared \
106         --enable-bsdtar=shared \
107         --enable-static%{!?with_static_libs:=no}
108 %{__make} -j1
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README NEWS COPYING
124 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.13
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libarchive.so
130 %{_libdir}/libarchive.la
131 %{_includedir}/archive*.h
132 %{_mandir}/man3/archive_*.3*
133 %{_mandir}/man3/libarchive.3*
134 %{_mandir}/man3/libarchive_changes.3*
135 %{_mandir}/man3/libarchive_internals.3*
136 %{_mandir}/man5/libarchive-formats.5*
137 %{_mandir}/man5/cpio.5*
138 %{_mandir}/man5/mtree.5*
139 %{_mandir}/man5/tar.5*
140 %{_pkgconfigdir}/libarchive.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libarchive.a
146 %endif
147
148 %files -n bsdcpio
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/bsdcpio
151 %{_mandir}/man1/bsdcpio.1*
152
153 %files -n bsdtar
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/bsdtar
156 %{_mandir}/man1/bsdtar.1*
This page took 0.117486 seconds and 3 git commands to generate.