]> git.pld-linux.org Git - packages/libabw.git/blob - libabw.spec
- unconditional noarch subpackages
[packages/libabw.git] / libabw.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define         apiversion      0.1
6 Summary:        A library for import of AbiWord files
7 Summary(pl.UTF-8):      Biblioteka do importowania plików AbiWorda
8 Name:           libabw
9 Version:        0.1.3
10 Release:        1
11 License:        MPL v2.0
12 Group:          Libraries
13 Source0:        https://dev-www.libreoffice.org/src/libabw/%{name}-%{version}.tar.xz
14 # Source0-md5:  0ec0331abbbf653f08eecceb1fb787a0
15 URL:            https://wiki.documentfoundation.org/DLP/Libraries/libabw
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf >= 3.0.0
19 BuildRequires:  librevenge-devel >= 0.0
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libabw is a library for import of AbiWord files.
30
31 %description -l pl.UTF-8
32 libabw to biblioteka do importowania plików AbiWorda.
33
34 %package devel
35 Summary:        Development files for libabw
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libabw
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       librevenge-devel >= 0.0
40 Requires:       libstdc++-devel >= 6:4.7
41 Requires:       libxml2-devel >= 2.0
42 Requires:       zlib-devel
43
44 %description devel
45 This package contains the header files for developing applications
46 that use libabw.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera biblioteki i pliki nagłówkowe do tworzenia
50 aplikacji wykorzystujących bibliotekę libabw.
51
52 %package static
53 Summary:        Static libabw library
54 Summary(pl.UTF-8):      Statyczna biblioteka libabw
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libabw library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libabw.
63
64 %package apidocs
65 Summary:        API documentation for libabw library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki libabw
67 Group:          Documentation
68 BuildArch:      noarch
69
70 %description apidocs
71 API documentation for libabw library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki libabw.
75
76 %package tools
77 Summary:        Tools to transform AbiWord files into other formats
78 Summary(pl.UTF-8):      Narzędzia do przekształcania plików AbiWorda do innych formatów
79 Group:          Applications/Publishing
80 Requires:       %{name} = %{version}-%{release}
81
82 %description tools
83 Tools to transform AbiWord files into other formats. Currently
84 supported: XHTML, raw, text.
85
86 %description tools -l pl.UTF-8
87 Narzędzia do przekształcania plików AbiWorda do innych formatów.
88 Obecnie obsługiwane są: XHTML, surowy, tekst.
89
90 %prep
91 %setup -q
92
93 %build
94 %configure \
95         --disable-silent-rules \
96         %{?with_static_libs:--enable-static}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
106
107 # we install API docs directly from build
108 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc CREDITS ChangeLog NEWS README
119 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libabw-%{apiversion}.so.1
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so
125 %{_includedir}/libabw-%{apiversion}
126 %{_pkgconfigdir}/libabw-%{apiversion}.pc
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libabw-%{apiversion}.a
132 %endif
133
134 %files apidocs
135 %defattr(644,root,root,755)
136 %doc docs/doxygen/html/*
137
138 %files tools
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/abw2raw
141 %attr(755,root,root) %{_bindir}/abw2text
142 %attr(755,root,root) %{_bindir}/abw2html
This page took 0.097534 seconds and 3 git commands to generate.