]> git.pld-linux.org Git - packages/leveldb.git/blob - leveldb.spec
6086ff4ec18832ab245f2a13e847c0f56873c376
[packages/leveldb.git] / leveldb.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4
5 %ifarch x32
6 %undefine       with_tcmalloc
7 %endif
8
9 Summary:        LevelDB - key-value store library
10 Summary(pl.UTF-8):      LevelDB - biblioteka bazy danych klucz-wartość
11 Name:           leveldb
12 Version:        1.15.0
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 #Source0Download: http://code.google.com/p/leveldb/downloads/list
17 Source0:        http://leveldb.googlecode.com/files/%{name}-%{version}.tar.gz
18 # Source0-md5:  e91fd7cbced8b84e21f357a866ad226a
19 URL:            http://code.google.com/p/leveldb/
20 BuildRequires:  libstdc++-devel
21 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
22 BuildRequires:  snappy-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 LevelDB is a fast key-value storage library written at Google that
27 provides an ordered mapping from string keys to string values.
28
29 %description -l pl.UTF-8
30 LevelDB to napisana w Google szybka biblioteka do przechowywania par
31 klucz-wartość, udostępniająca uporządkowane odwzorowanie z kluczy
32 będących łańcuchami znaków do wartości tego samego typu.
33
34 %package devel
35 Summary:        Header files for LevelDB library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LevelDB
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libstdc++-devel
40 Requires:       libtcmalloc-devel
41 Requires:       snappy-devel
42
43 %description devel
44 Header files for LevelDB library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki LevelDB.
48
49 %package static
50 Summary:        Static LevelDB library
51 Summary(pl.UTF-8):      Statyczna biblioteka LevelDB
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static LevelDB library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka LevelDB.
60
61 %prep
62 %setup -q
63
64 %build
65 %{__make} \
66         CXX="%{__cxx}" \
67         OPT="%{rpmcflags} %{!?debug:-DNDEBUG}"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
72
73 cp -dp libleveldb.so* libleveldb.a $RPM_BUILD_ROOT%{_libdir}
74 cp -a include/leveldb $RPM_BUILD_ROOT%{_includedir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS LICENSE NEWS README TODO
85 %attr(755,root,root) %{_libdir}/libleveldb.so.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libleveldb.so.1
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc doc/*
91 %attr(755,root,root) %{_libdir}/libleveldb.so
92 %{_includedir}/leveldb
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/libleveldb.a
This page took 0.178431 seconds and 2 git commands to generate.