]> git.pld-linux.org Git - packages/lessfs.git/commitdiff
- fix building with gcc 10+, rebuild with openssl 3.0.0, rel 2 master auto/th/lessfs-1.7.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 17 Oct 2021 19:19:01 +0000 (21:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 17 Oct 2021 19:19:01 +0000 (21:19 +0200)
gcc10.patch [new file with mode: 0644]
lessfs.spec

diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..47ac099
--- /dev/null
@@ -0,0 +1,62 @@
+diff -u lessfs-1.7.0/lib_cfg.c lessfs-1.7.0-gcc10/lib_cfg.c
+--- lessfs-1.7.0/lib_cfg.c     2011-09-30 20:13:08.000000000 +0200
++++ lessfs-1.7.0-gcc10/lib_cfg.c       2021-10-17 21:12:40.750623419 +0200
+@@ -34,6 +34,8 @@
+ #include "lib_str.h"
+ #include "retcodes.h"
++struct configdata *config;
++
+ int r_env_cfg(char *configfile)
+ {
+     FILE *config;
+diff -u lessfs-1.7.0/lib_cfg.h lessfs-1.7.0-gcc10/lib_cfg.h
+--- lessfs-1.7.0/lib_cfg.h     2012-04-21 18:09:54.000000000 +0200
++++ lessfs-1.7.0-gcc10/lib_cfg.h       2021-10-17 21:12:31.999872984 +0200
+@@ -88,7 +88,7 @@
+ // Counter is increase by normal ops, decreased by truncation.
+ // (background) Truncation will therefore become slower when other tasks are running.
+ };
+-struct configdata *config;
++extern struct configdata *config;
+ int read_s_cfg(char *cfgfile, char *value, int size);
+ int read_m_cfg(char *cfgfile, char *value, char *value2, int size);
+diff -u lessfs-1.7.0/lib_tc.c lessfs-1.7.0-gcc10/lib_tc.c
+--- lessfs-1.7.0/lib_tc.c      2013-11-16 05:09:05.000000000 +0100
++++ lessfs-1.7.0-gcc10/lib_tc.c        2021-10-17 21:15:33.016360983 +0200
+@@ -74,14 +74,14 @@
+ extern int max_threads;
+ extern char *passwd;
+-TCHDB *dbb;
+-TCHDB *dbu;
+-TCHDB *dbp;
+-TCBDB *dbl;
+-TCHDB *dbs;
+-TCHDB *dbdta;
+-TCBDB *dbdirent;
+-TCBDB *freelist;
++extern TCHDB *dbb;
++extern TCHDB *dbu;
++extern TCHDB *dbp;
++extern TCBDB *dbl;
++extern TCHDB *dbs;
++extern TCHDB *dbdta;
++extern TCBDB *dbdirent;
++extern TCBDB *freelist;
+ extern TCTREE *workqtree;       // Used to buffer incoming data (writes) 
+ extern TCTREE *readcachetree;   // Used to cache chunks of data that are likely to be read
+@@ -96,9 +96,9 @@
+ extern unsigned long long nextoffset;
+ int written = 0;
+-const char *offset_lockedby;
++extern const char *offset_lockedby;
+-u_int32_t db_flags, env_flags;
++extern u_int32_t db_flags, env_flags;
+ int btree_test_transaction(TCBDB * bdb)
+ {
index b90278f5c77a741afea8f3afb1dea54b40c68084..2269411cc8c03e308639aa9556da6950059cbdfd 100644 (file)
@@ -2,12 +2,13 @@ Summary:      Lessfs is an inline data deduplicating filesystem
 Summary(pl.UTF-8):     Lessfs is an inline data deduplicating filesystem.
 Name:          lessfs
 Version:       1.7.0
-Release:       1
+Release:       2
 License:       GPL v3
 Group:         Applications
 Source0:       http://downloads.sourceforge.net/lessfs/%{name}-%{version}.tar.gz
 # Source0-md5: 8afdb925dba24a58b74fff74d7f3180e
 Patch0:                openssl.patch
+Patch1:                gcc10.patch
 URL:           http://www.lessfs.com/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -30,6 +31,7 @@ Lessfs is an inline data deduplicating filesystem.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.094696 seconds and 4 git commands to generate.