]> git.pld-linux.org Git - packages/ldns.git/blob - ldns.spec
- rel 4; openssl 1.1.1 rebuild; force gost support
[packages/ldns.git] / ldns.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # OpenSSL DANE functions for verification (requires openssl >= 1.1.0)
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  python          # Python modules
6 #
7 Summary:        ldns - a library with the aim to simplify DNS programing in C
8 Summary(pl.UTF-8):      ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
9 Name:           ldns
10 Version:        1.7.0
11 Release:        4
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
15 # Source0-md5:  74b75c9ba69fb3af2a0c26244ecfd9f6
16 Patch0:         python-install.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.nlnetlabs.nl/ldns/
19 BuildRequires:  autoconf >= 2.56
20 BuildRequires:  automake
21 BuildRequires:  doxygen
22 BuildRequires:  libtool >= 2:2
23 %if %{with dane}
24 BuildRequires:  openssl-devel >= 1.1.0
25 %else
26 BuildRequires:  openssl-devel >= 1.0.0
27 %endif
28 %if %{with python}
29 BuildRequires:  python-devel >= 1:2.4.0
30 BuildRequires:  rpmbuild(macros) >= 1.219
31 BuildRequires:  swig-python
32 %endif
33 Requires:       openssl >= 1.0.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 ldns is a library with the aim to simplify DNS programing in C. It is
38 heavily based upon the Net::DNS module from perl.
39
40 %description -l pl.UTF-8
41 ldns jest biblioteka mającą na celu uproszczenie programowania
42 związanego z usługą DNS w C. Jest w dużym stopniu oparta na module
43 Perla Net::DNS.
44
45 %package devel
46 Summary:        Header files for ldns library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ldns
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %if %{with dane}
51 Requires:       openssl-devel >= 1.1.0
52 %else
53 Requires:       openssl-devel >= 1.0.0
54 %endif
55
56 %description devel
57 Header files for ldns library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki ldns.
61
62 %package static
63 Summary:        Static ldns library
64 Summary(pl.UTF-8):      Statyczna biblioteka ldns
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static ldns library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka ldns.
73
74 %package -n python-ldns
75 Summary:        Python interface do ldns library
76 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki ldns
77 Group:          Libraries/Python
78 Requires:       %{name} = %{version}-%{release}
79
80 %description -n python-ldns
81 Python interface do ldns library.
82
83 %description -n python-ldns -l pl.UTF-8
84 Pythonowy interfejs do biblioteki ldns.
85
86 %package -n drill
87 Summary:        drill - tool to get all sorts of information out of the DNS(SEC)
88 Summary(pl.UTF-8):      drill - narzędzie do pobierania dowolnych informacji z DNS(SEC)
89 Group:          Applications/Network
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n drill
93 drill is a tool to get all sorts of information out of the DNS. It is
94 specifically designed to be used with DNSSEC.
95
96 %description -n drill -l pl.UTF-8
97 drill to narzędzie do pobierania dowolnych informacji z DNS. Jest
98 zaprojektowane szczególnie z myślą o użyciu z DNSSEC.
99
100 %package tools
101 Summary:        Example tools for ldns.
102 Summary(pl.UTF-8):      Przykładowe narzędzie wykorzystujące ldns.
103 Group:          Applications/Network
104 Requires:       %{name} = %{version}-%{release}
105
106 %description tools
107 These tools are examples of ldns usage. They are not meant for
108 production systems and will not be supported as such.
109
110 %description tools -l pl.UTF-8
111 Te narzędzia są przykładami użycia biblioteki ldns.
112 Nie są przeznaczone do produkcyjnego użycia i jako takie
113 nie będa wspierane.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119
120 %build
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoconf}
124 %{__autoheader}
125 %configure \
126         --enable-gost-anyway \
127         %{!?with_dane:--disable-dane-ta-usage} \
128         --enable-static%{!?with_static_libs:=no} \
129         --with-drill \
130         %{?with_python:--with-pyldns}
131 %{__make}
132 %{__make} doc
133
134 cd examples
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__autoheader}
139 %configure
140 %{__make}
141 cd ..
142
143 # change symlinks into .so redirects
144 cd doc/man/man3
145 for f in `find . -type l`; do
146         d=`readlink $f`
147         %{__rm} $f
148         echo ".so $d" > $f
149 done
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 %if %{with python}
158 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.la
159 %if %{with static_libs}
160 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.a
161 %endif
162 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
163 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
164 %py_postclean
165 %endif
166
167 cd examples
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170 cd ..
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc Changelog LICENSE README
181 %attr(755,root,root) %{_libdir}/libldns.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libldns.so.2
183
184 %files devel
185 %defattr(644,root,root,755)
186 %doc doc/{*.html,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle}
187 %attr(755,root,root) %{_bindir}/ldns-config
188 %attr(755,root,root) %{_libdir}/libldns.so
189 %{_libdir}/libldns.la
190 %{_includedir}/%{name}
191 %{_mandir}/man1/ldns-config.1*
192 %{_mandir}/man3/ldns_*.3*
193
194 %if %{with static_libs}
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libldns.a
198 %endif
199
200 %if %{with python}
201 %files -n python-ldns
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{py_sitedir}/_ldns.so*
204 %{py_sitedir}/ldns.py[co]
205 %{py_sitedir}/ldnsx.py[co]
206 %endif
207
208 %files -n drill
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/drill
211 %{_mandir}/man1/drill.1*
212
213 %files tools
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/ldns-chaos
216 %attr(755,root,root) %{_bindir}/ldns-compare-zones
217 %attr(755,root,root) %{_bindir}/ldns-dane
218 %attr(755,root,root) %{_bindir}/ldns-dpa
219 %attr(755,root,root) %{_bindir}/ldns-gen-zone
220 %attr(755,root,root) %{_bindir}/ldns-key2ds
221 %attr(755,root,root) %{_bindir}/ldns-keyfetcher
222 %attr(755,root,root) %{_bindir}/ldns-keygen
223 %attr(755,root,root) %{_bindir}/ldns-mx
224 %attr(755,root,root) %{_bindir}/ldns-notify
225 %attr(755,root,root) %{_bindir}/ldns-nsec3-hash
226 %attr(755,root,root) %{_bindir}/ldns-read-zone
227 %attr(755,root,root) %{_bindir}/ldns-resolver
228 %attr(755,root,root) %{_bindir}/ldns-revoke
229 %attr(755,root,root) %{_bindir}/ldns-rrsig
230 %attr(755,root,root) %{_bindir}/ldns-signzone
231 %attr(755,root,root) %{_bindir}/ldns-test-edns
232 %attr(755,root,root) %{_bindir}/ldns-testns
233 %attr(755,root,root) %{_bindir}/ldns-update
234 %attr(755,root,root) %{_bindir}/ldns-verify-zone
235 %attr(755,root,root) %{_bindir}/ldns-version
236 %attr(755,root,root) %{_bindir}/ldns-walk
237 %attr(755,root,root) %{_bindir}/ldns-zcat
238 %attr(755,root,root) %{_bindir}/ldns-zsplit
239 %attr(755,root,root) %{_bindir}/ldnsd
240 %{_mandir}/man1/ldns-chaos.1*
241 %{_mandir}/man1/ldns-compare-zones.1*
242 %{_mandir}/man1/ldns-dane.1*
243 %{_mandir}/man1/ldns-dpa.1*
244 %{_mandir}/man1/ldns-gen-zone.1*
245 %{_mandir}/man1/ldns-key2ds.1*
246 %{_mandir}/man1/ldns-keyfetcher.1*
247 %{_mandir}/man1/ldns-keygen.1*
248 %{_mandir}/man1/ldns-mx.1*
249 %{_mandir}/man1/ldns-notify.1*
250 %{_mandir}/man1/ldns-nsec3-hash.1*
251 %{_mandir}/man1/ldns-read-zone.1*
252 %{_mandir}/man1/ldns-resolver.1*
253 %{_mandir}/man1/ldns-revoke.1*
254 %{_mandir}/man1/ldns-rrsig.1*
255 %{_mandir}/man1/ldns-signzone.1*
256 %{_mandir}/man1/ldns-test-edns.1*
257 %{_mandir}/man1/ldns-testns.1*
258 %{_mandir}/man1/ldns-update.1*
259 %{_mandir}/man1/ldns-verify-zone.1*
260 %{_mandir}/man1/ldns-version.1*
261 %{_mandir}/man1/ldns-walk.1*
262 %{_mandir}/man1/ldns-zcat.1*
263 %{_mandir}/man1/ldns-zsplit.1*
264 %{_mandir}/man1/ldnsd.1*
This page took 0.045074 seconds and 3 git commands to generate.