]> git.pld-linux.org Git - packages/lcms.git/blame - lcms.spec
- ghost soname symlink
[packages/lcms.git] / lcms.spec
CommitLineData
86fd4aa9
JB
1#
2# Conditional build:
3%bcond_without python # don't build python bindings
4#
914017f0 5Summary: Little CMS - a library to transform between colour profiles
ba784bd7 6Summary(pl.UTF-8): Little CMS - biblioteka do konwersji między profilami kolorów
914017f0 7Name: lcms
896f7926 8Version: 1.17
9cefcb82 9Release: 2
896f7926 10License: MIT
914017f0 11Group: Libraries
429231dc 12Source0: http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
896f7926 13# Source0-md5: 07bdbb4cfb05d21caa58fe3d1c84ddc1
14847a72 14Patch0: %{name}-python.patch
914017f0 15URL: http://www.littlecms.com/
429231dc 16BuildRequires: autoconf >= 2.57
63b969c4 17BuildRequires: automake >= 1:1.7.2
38ffa639 18BuildRequires: libjpeg-devel
429231dc 19BuildRequires: libstdc++-devel
38ffa639 20BuildRequires: libtiff-devel
429231dc 21BuildRequires: libtool >= 1:1.4.2-9
4af9957c 22BuildRequires: sed >= 4.0
64ad2df3 23%if %{with python}
14847a72
JB
24BuildRequires: python-devel >= 2.2
25BuildRequires: swig-python >= 1.3.30
64ad2df3 26%endif
38ffa639 27BuildRequires: zlib-devel
914017f0
JB
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30# There is no pretty description in source archive... use these.
31
32%description
33lcms does not allow to write profiles, and profile manipulation is not
34its goal. Instead, lcms focus on implement fast transforms between
35profiles.
36
b3bff7a9
JR
37%description -l pl.UTF-8
38lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
39tej biblioteki. Natomiast lcms skupia się na implementacji szybkiej
40konwersji między profilami.
914017f0
JB
41
42%package devel
43Summary: Little CMS - header files and developer's documentation
ba784bd7 44Summary(pl.UTF-8): Little CMS - pliki nagłówkowe i dokumentacja
914017f0 45Group: Development/Libraries
d4a273c7 46Requires: %{name} = %{version}-%{release}
914017f0
JB
47
48%description devel
49Header files needed to compile programs with liblcms and some
50documentation useful for programmers.
51
b3bff7a9
JR
52%description devel -l pl.UTF-8
53Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
54dla programistów.
914017f0
JB
55
56%package static
57Summary: Little CMS - static library
ba784bd7 58Summary(pl.UTF-8): Little CMS - biblioteka statyczna
914017f0 59Group: Development/Libraries
d4a273c7 60Requires: %{name}-devel = %{version}-%{release}
914017f0
JB
61
62%description static
63Static version of liblcms.
64
b3bff7a9 65%description static -l pl.UTF-8
914017f0
JB
66Statyczna biblioteka liblcms.
67
38ffa639
JB
68%package progs
69Summary: Example and demonstration programs for Little CMS
ba784bd7 70Summary(pl.UTF-8): Programy przykładowe i demonstracyjne do Little CMS
38ffa639 71Group: Applications/Graphics
d4a273c7 72Requires: %{name} = %{version}-%{release}
38ffa639
JB
73
74%description progs
75Example and demonstration programs for Little CMS.
76
b3bff7a9
JR
77%description progs -l pl.UTF-8
78Programy przykładowe i demonstracyjne do Little CMS.
38ffa639 79
429231dc
JB
80%package -n python-lcms
81Summary: Little CMS module for Python
ba784bd7 82Summary(pl.UTF-8): Moduł Little CMS dla Pythona
429231dc 83Group: Libraries/Python
d4a273c7 84Requires: %{name} = %{version}-%{release}
429231dc
JB
85%pyrequires_eq python
86
87%description -n python-lcms
88Little CMS module for Python.
89
b3bff7a9
JR
90%description -n python-lcms -l pl.UTF-8
91Moduł Little CMS dla Pythona.
429231dc 92
914017f0
JB
93%prep
94%setup -q
14847a72 95%patch0 -p1
914017f0
JB
96
97%build
14847a72
JB
98# rebuild using newer swig (needed for g++ 4/python 2.5)
99cd python
100rm -f lcms.py lcms_wrap.cxx
101swig -python -c++ -I../include lcms.i
102cd ..
5ec09a5a 103%{__libtoolize}
104%{__aclocal}
105%{__autoconf}
106%{__automake}
429231dc 107%configure \
64ad2df3 108 --with%{!?with_python:out}-python
5ec09a5a 109
429231dc 110%{__make}
914017f0
JB
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
5ec09a5a 115%{__make} install \
116 DESTDIR=$RPM_BUILD_ROOT
914017f0 117
38ffa639
JB
118install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
119
429231dc
JB
120rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
121
914017f0
JB
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
128%files
129%defattr(644,root,root,755)
896f7926 130%doc AUTHORS COPYING NEWS README.1ST
14847a72 131%attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
f723569a 132%attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
914017f0
JB
133
134%files devel
135%defattr(644,root,root,755)
44e323b4 136%doc doc/*
14847a72
JB
137%attr(755,root,root) %{_libdir}/liblcms.so
138%{_libdir}/liblcms.la
429231dc 139%{_includedir}/*.h
14847a72 140%{_pkgconfigdir}/lcms.pc
914017f0
JB
141
142%files static
143%defattr(644,root,root,755)
14847a72 144%{_libdir}/liblcms.a
38ffa639
JB
145
146%files progs
147%defattr(644,root,root,755)
148%attr(755,root,root) %{_bindir}/*
02971f77 149%{_mandir}/man1/*.1*
429231dc 150
64ad2df3 151%if %{with python}
429231dc
JB
152%files -n python-lcms
153%defattr(644,root,root,755)
154%attr(755,root,root) %{py_sitedir}/_lcms.so
155%{py_sitedir}/lcms.py
64ad2df3 156%endif
This page took 0.09619 seconds and 4 git commands to generate.