]> git.pld-linux.org Git - packages/lcms.git/blame - lcms.spec
- really fix python install
[packages/lcms.git] / lcms.spec
CommitLineData
2c5ebcc4 1#
2# Conditional build:
3%bcond_without python # don't build python bindings
4#
5Summary: Little CMS - a library to transform between colour profiles
6Summary(pl.UTF-8): Little CMS - biblioteka do konwersji między profilami kolorów
7Name: lcms
8Version: 1.19
711a6c1a 9Release: 6
2c5ebcc4 10License: MIT
11Group: Libraries
12Source0: http://downloads.sourceforge.net/lcms/%{name}-%{version}.tar.gz
13# Source0-md5: 8af94611baf20d9646c7c2c285859818
14Patch0: %{name}-python.patch
15URL: http://www.littlecms.com/
16BuildRequires: autoconf >= 2.57
17BuildRequires: automake >= 1:1.7.2
18BuildRequires: libjpeg-devel
19BuildRequires: libstdc++-devel
20BuildRequires: libtiff-devel
21BuildRequires: libtool >= 1:1.4.2-9
22BuildRequires: sed >= 4.0
23%if %{with python}
24BuildRequires: python-devel >= 2.2
25BuildRequires: python-modules
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.566
28BuildRequires: swig-python >= 1.3.30
29%endif
30BuildRequires: zlib-devel
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Little CMS intends to be a small-footprint color management engine,
35with special focus on accuracy and performance. It uses the
36International Color Consortium standard (ICC), which is the modern
37standard when regarding to color management.
38
39Little CMS 1.x supports ICC profile specification v3.4.
40
41%description -l pl.UTF-8
42Little CMS jest lekkim silnikiem zarządzania kolorami, tworzonym
43przede wszystkim z myślą o dokładności i wydajności. Wykorzystuje
44standard International Color Consortium (ICC), będący współczesnym
45standardem zarządzania kolorami.
46
47Little CMS 1.x obsługuje specyfikację profili ICC w wersji 3.4.
48
49%package devel
50Summary: Little CMS - header files and developer's documentation
51Summary(pl.UTF-8): Little CMS - pliki nagłówkowe i dokumentacja
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Header files needed to compile programs with liblcms and some
57documentation useful for programmers.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
61dla programistów.
62
63%package static
64Summary: Little CMS - static library
65Summary(pl.UTF-8): Little CMS - biblioteka statyczna
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static version of liblcms.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka liblcms.
74
75%package progs
76Summary: Example and demonstration programs for Little CMS
77Summary(pl.UTF-8): Programy przykładowe i demonstracyjne do Little CMS
78Group: Applications/Graphics
79Requires: %{name} = %{version}-%{release}
80
81%description progs
82Example and demonstration programs for Little CMS.
83
84%description progs -l pl.UTF-8
85Programy przykładowe i demonstracyjne do Little CMS.
86
87%package -n python-lcms
88Summary: Little CMS module for Python
89Summary(pl.UTF-8): Moduł Little CMS dla Pythona
90Group: Libraries/Python
91Requires: %{name} = %{version}-%{release}
92%pyrequires_eq python
93
94%description -n python-lcms
95Little CMS module for Python.
96
97%description -n python-lcms -l pl.UTF-8
98Moduł Little CMS dla Pythona.
99
100%prep
101%setup -q
102%undos configure.ac
103%patch0 -p1
104
105%build
106# rebuild using newer swig (needed for g++ 4/python 2.5)
107cd python
108rm -f lcms.py lcms_wrap.cxx
109swig -python -c++ -I../include lcms.i
110cd ..
111%{__libtoolize}
112%{__aclocal}
113%{__autoconf}
114%{__automake}
115%configure \
116 --with%{!?with_python:out}-python
117
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%{__make} install \
124 DESTDIR=$RPM_BUILD_ROOT
125
126install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
127
128%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
136%files
137%defattr(644,root,root,755)
138%doc AUTHORS COPYING NEWS README.1ST
139%attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
141
142%files devel
143%defattr(644,root,root,755)
144%doc doc/*
145%attr(755,root,root) %{_libdir}/liblcms.so
146%{_libdir}/liblcms.la
147%{_includedir}/icc34.h
148%{_includedir}/lcms.h
149%{_pkgconfigdir}/lcms.pc
150
151%files static
152%defattr(644,root,root,755)
153%{_libdir}/liblcms.a
154
155%files progs
156%defattr(644,root,root,755)
157%attr(755,root,root) %{_bindir}/icc2ps
158%attr(755,root,root) %{_bindir}/icclink
159%attr(755,root,root) %{_bindir}/icctrans
160%attr(755,root,root) %{_bindir}/jpegicc
161%attr(755,root,root) %{_bindir}/tiffdiff
162%attr(755,root,root) %{_bindir}/tifficc
163%attr(755,root,root) %{_bindir}/wtpt
164%{_mandir}/man1/icc2ps.1*
165%{_mandir}/man1/icclink.1*
166%{_mandir}/man1/jpegicc.1*
167%{_mandir}/man1/tifficc.1*
168%{_mandir}/man1/wtpt.1*
169
170%if %{with python}
171%files -n python-lcms
172%defattr(644,root,root,755)
173%attr(755,root,root) %{py_sitedir}/_lcms.so
174%{py_sitedir}/lcms.py
175%endif
This page took 0.110189 seconds and 5 git commands to generate.