]> git.pld-linux.org Git - packages/lash.git/blob - lash.spec
switch to swig3
[packages/lash.git] / lash.spec
1 Summary:        LASH Audio Session Handler
2 Summary(pl.UTF-8):      LASH Audio Session Handler - obsługa sesji dźwiękowych
3 Name:           lash
4 Version:        0.5.4
5 Release:        8
6 License:        GPL v2+
7 Group:          Applications/Sound
8 Source0:        http://download.savannah.gnu.org/releases/lash/%{name}-%{version}.tar.gz
9 # Source0-md5:  8eeb7e91f9127d7d9fc6ec076cbe14ed
10 Patch0:         %{name}-link.patch
11 Patch1:         %{name}-glibc2.8.patch
12 Patch2:         %{name}-swig2.patch
13 Patch3:         texinfo5.patch
14 Patch4:         rlimit.patch
15 Patch5:         %{name}-swig3.patch
16 Patch6:         %{name}-linking.patch
17 URL:            http://lash.nongnu.org/
18 BuildRequires:  /usr/bin/texi2html
19 BuildRequires:  alsa-lib-devel >= 0.9
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  gtk+2-devel >= 1:2.0.0
23 BuildRequires:  jack-audio-connection-kit-devel >= 0.99.17
24 BuildRequires:  libtool
25 BuildRequires:  libuuid-devel
26 BuildRequires:  libxml2-devel >= 2.0.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel
29 BuildRequires:  readline-devel
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.219
32 BuildRequires:  swig3-python
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 LASH Audio Session Handler consists of a daemon, a client library and
38 a some clients that implement a session management system for audio
39 applications on Linux.
40
41 %description -l pl.UTF-8
42 LASH Audio Session Handler składa się z demona, biblioteki klienckiej
43 i kilku programów klienckich implementujących system zarządzania
44 sesjami dla aplikacji dźwiękowych działających pod Linuksem.
45
46 %package gtk
47 Summary:        GTK+ based LASH clients
48 Summary(pl.UTF-8):      Programy klienckie LASH oparte na GTK+
49 Group:          X11/Applications/Sound
50 Requires:       %{name}-libs = %{version}-%{release}
51
52 %description gtk
53 GTK+ based LASH clients.
54
55 %description gtk -l pl.UTF-8
56 Programy klienckie LASH oparte na GTK+.
57
58 %package libs
59 Summary:        LASH Audio Session Handler library
60 Summary(pl.UTF-8):      Biblioteka LASH Audio Session Handler
61 Group:          Libraries
62
63 %description libs
64 LASH Audio Session Handler library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka LASH Audio Session Handler do obsługi sesji dźwiękowych.
68
69 %package devel
70 Summary:        Header files for LASH library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LASH
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       libuuid-devel
75
76 %description devel
77 Header files for LASH library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki LASH.
81
82 %package static
83 Summary:        Static LASH library
84 Summary(pl.UTF-8):      Statyczna biblioteka LASH
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static LASH library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka LASH.
93
94 %package -n python-lash
95 Summary:        Python bindings for LASH library
96 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LASH
97 Group:          Libraries/Python
98 Requires:       %{name}-libs = %{version}-%{release}
99 %pyrequires_eq  python-libs
100
101 %description -n python-lash
102 Python bindings for LASH library.
103
104 %description -n python-lash -l pl.UTF-8
105 Wiązania Pythona do biblioteki LASH.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p0
111 %patch2 -p1
112 %patch3 -p1
113 %patch4 -p1
114 %patch5 -p1
115 %patch6 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         SWIG=/usr/bin/swig-3
125 %{__make} \
126         pkgpyexecdir="\$(pyexecdir)"
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         pkgpyexecdir="\$(pyexecdir)"
134
135 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
136 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
137 %py_postclean
138 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_lash.{la,a}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   libs -p /sbin/ldconfig
144 %postun libs -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog NEWS README README.SECURITY TODO docs/lash-manual-html-split/lash-manual*
149 %attr(755,root,root) %{_bindir}/lash_control
150 %attr(755,root,root) %{_bindir}/lash_simple_client
151 %attr(755,root,root) %{_bindir}/lash_synth
152 %attr(755,root,root) %{_bindir}/lashd
153 %{_datadir}/lash
154
155 %files gtk
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/lash_panel
158 %attr(755,root,root) %{_bindir}/lash_save_button
159
160 %files libs
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/liblash.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/liblash.so.1
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/liblash.so
168 %{_libdir}/liblash.la
169 %{_includedir}/lash-1.0
170 %{_pkgconfigdir}/lash-1.0.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/liblash.a
175
176 %files -n python-lash
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{py_sitedir}/_lash.so
179 %{py_sitedir}/lash.py[co]
This page took 0.094814 seconds and 4 git commands to generate.