]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- Groups fixed for shared libs
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl.UTF-8):      Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.1.1
5 Release:        4
6 License:        freely distributable
7 Group:          Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}-%{version}.tgz
9 # Source0-md5:  00b21551a899bcfbaa7b8443e1faeef9
10 Source1:        http://www.netlib.org/lapack/manpages-%{version}.tgz
11 # Source1-md5:  e5b46d8915f7cc8a1e50aa3e70c9f86e
12 Patch0:         %{name}-automake_support.patch
13 URL:            http://www.netlib.org/lapack/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gcc-fortran
17 BuildRequires:  libtool >= 2:1.5
18 Requires:       blas = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # see http://www.netlib.org/lapack/faq.html#1.13 (2nd note from top)
22 # and http://www.netlib.org/lapack/faq.html#1.25
23 # anybody to prepare appropriate fix?
24 %define       rpmcflags -O0
25
26 %description
27 LAPACK (Linear Algebra PACKage) is a standard library for numerical
28 linear algebra. LAPACK provides routines for solving systems of
29 simultaneous linear equations, least-squares solutions of linear
30 systems of equations, eigenvalue problems, and singular value
31 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
32 Schur, and generalized Schur) and related computations (i.e.,
33 reordering of Schur factorizations and estimating condition numbers)
34 are also included. LAPACK can handle dense and banded matrices, but
35 not general sparse matrices. Similar functionality is provided for
36 real and complex matrices in both single and double precision. LAPACK
37 is coded in Fortran77.
38
39 %description -l pl.UTF-8
40 LAPACK (Linear Algebra PACKage) jest standardową biblioteką numeryczną
41 do algebry liniowej. Dostarcza funkcje rozwiązywania: układów równań
42 liniowych, układów równań metodą najmniejszych kwadratów, problemów
43 własnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
44 QR, SVD, Schura, uogólnioną Schura) i związanych z tym obliczeń (np.
45 przenumerowywanie w faktoryzacji Schura i estymację uwarunkowania).
46 LAPACK może obsługiwać macierze blokowe i pasmowe, ale nie rzadkie w
47 ogólnym przypadku. Zapewnia funkcjonalność dla macierzy rzeczywistych
48 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
49 napisany w Fortranie 77.
50
51 %package devel
52 Summary:        LAPACK header files
53 Summary(pl.UTF-8):      Pliki nagłówkowe LAPACK
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       blas-devel = %{version}-%{release}
57 Obsoletes:      lapack-man
58
59 %description devel
60 LAPACK header files.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe LAPACK.
64
65 %package static
66 Summary:        Static LAPACK libraries
67 Summary(pl.UTF-8):      Biblioteki statyczne LAPACK
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static LAPACK libraries.
73
74 %description static -l pl.UTF-8
75 Biblioteki statyczne LAPACK.
76
77 %package -n blas
78 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
79 Summary(pl.UTF-8):      Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
80 Group:          Libraries
81 Obsoletes:      lapack-blas
82
83 %description -n blas
84 BLAS (Basic Linear Algebra Subprograms) is a standard library for
85 numerical algebra. BLAS provides a number of basic algorithms for
86 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
87 77.
88
89 Warning: this is a reference implementation from Netlib. If possible,
90 use version optimized for your architecture instead.
91
92 %description -n blas -l pl.UTF-8
93 BLAS (Basic Linear Algebra Subprograms) jest standardową biblioteką
94 numeryczną algebry. Dostarcza wiele podstawowych algorytmów dla
95 algebry liniowej. Jest szybka i dobrze przetestowana, została napisana
96 w Fortranie 77.
97
98 Ostrzeżenie: to jest implementacja przykładowa z repozytorium Netlib.
99 Jeżeli to możliwe, należy używać zamiast niej wersji zoptymalizowanej
100 pod daną architekturę.
101
102 %package -n blas-devel
103 Summary:        BLAS header files
104 Summary(pl.UTF-8):      Pliki nagłówkowe BLAS
105 Group:          Development/Libraries
106 Requires:       blas = %{version}-%{release}
107 Obsoletes:      blas-man
108
109 %description -n blas-devel
110 BLAS header files.
111
112 %description -n blas-devel -l pl.UTF-8
113 Pliki nagłówkowe BLAS.
114
115 %package -n blas-static
116 Summary:        Static BLAS libraries
117 Summary(pl.UTF-8):      Biblioteki statyczne BLAS
118 Group:          Development/Libraries
119 Requires:       blas-devel = %{version}-%{release}
120
121 %description -n blas-static
122 Static BLAS libraries.
123
124 %description -n blas-static -l pl.UTF-8
125 Biblioteki statyczne BLAS.
126
127 %prep
128 %setup -q -a1
129 %patch0 -p1
130 # directory INSTALL conflicts with file INSTALL needed by automake
131 mv -f INSTALL install
132 # or maybe it should fail while trying to overwrite a file?
133 cp -f install/*.f SRC/
134
135 %build
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__autoconf}
140 %{__automake}
141 %configure
142
143 %{__make} \
144         LTTAG="--tag=F77"
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # present both in blas and lapack
153 rm -f man/manl/{lsame,xerbla}.l
154
155 install -d $RPM_BUILD_ROOT%{_mandir}/man3
156 for d in manpages/man/manl/*.l manpages/blas/man/manl/*.l ; do
157         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
158 done
159
160 echo "%defattr(644, root, root, 755)" > blasmans.list
161 find manpages/blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
162 echo "%defattr(644, root, root, 755)" > mans.list
163 find manpages/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
164
165 %clean
166 rm -fr $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %post   -n blas -p /sbin/ldconfig
172 %postun -n blas -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc README
177 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
178
179 %files devel -f mans.list
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/liblapack.so
182 %{_libdir}/liblapack.la
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/liblapack.a
187
188 %files -n blas
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
191
192 %files -n blas-devel -f blasmans.list
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libblas.so
195 %{_libdir}/libblas.la
196
197 %files -n blas-static
198 %defattr(644,root,root,755)
199 %{_libdir}/libblas.a
This page took 0.269238 seconds and 4 git commands to generate.