]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- split to devel and static subpackages
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra.
2 Name:           lapack
3 Version:        3.0
4 Release:        4
5 Copyright:      Freely distributable
6 Group:          Development/Libraries
7 Group(fr):      Development/Librairies
8 Group(pl):      Programowanie/Biblioteki
9 Source0:        http://www.netlib.org/lapack/%{name}.tar.bz2
10 Source1:        http://www.netlib.org/lapack/manpages.tar.bz2
11 #Source2:       Makefile.blas
12 #Source3:       Makefile.lapack
13 Patch0:         %{name}-automake_support.patch
14 URL:            http://www.netlib.org/lapack/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 LAPACK (Linear Algebra PACKage) is a standard library for numerical
19 linear algebra. LAPACK provides routines for solving systems of
20 simultaneous linear equations, least-squares solutions of linear
21 systems of equations, eigenvalue problems, and singular value
22 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
23 Schur, and generalized Schur) and related computations (i.e.,
24 reordering of Schur factorizations and estimating condition numbers)
25 are also included. LAPACK can handle dense and banded matrices, but
26 not general sparse matrices. Similar functionality is provided for
27 real and complex matrices in both single and double precision. LAPACK
28 is coded in Fortran77 and is built with egcs.
29
30 %package devel
31 Summary:        %{name} header files
32 Summary(pl):    Pliki nag³ówkowe %{name}
33 Group:          Development/Libraries
34 Group(fr):      Development/Librairies
35 Group(pl):      Programowanie/Biblioteki
36 Requires:       %{name} = %{version}
37
38 %description devel
39 %{name} header files.
40
41 %description -l pl devel
42 Pliki nag³ówkowe %{name}.
43
44 %package static
45 Summary:        Static %{name} libraries
46 Summary(pl):    Biblioteki statyczne %{name}
47 Group:          Development/Libraries
48 Group(fr):      Development/Librairies
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 Static %{name} libraries.
54
55 %description -l pl static
56 Biblioteki statyczne %{name}.
57
58
59 %package -n blas
60 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux.
61 Group:          Development/Libraries
62 Group(fr):      Development/Librairies
63 Group(pl):      Programowanie/Biblioteki
64 Obsoletes:      lapack-blas
65
66 %description -n blas
67 BLAS (Basic Linear Algebra Subprograms) is a standard library for
68 numerical algebra. BLAS provides a number of basic algorithms for
69 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
70 77 and build with egcs. BLAS manual pages are available in the
71 blas-man package.
72
73 %package -n blas-devel
74 Summary:        %{name} header files
75 Summary(pl):    Pliki nag³ówkowe %{name}
76 Group:          Development/Libraries
77 Group(fr):      Development/Librairies
78 Group(pl):      Programowanie/Biblioteki
79 Requires:       blas = %{version}
80
81 %description -n blas-devel
82 %{name} header files.
83
84 %description -l pl -n blas-devel
85 Pliki nag³ówkowe %{name}.
86
87 %package -n blas-static
88 Summary:        Static %{name} libraries
89 Summary(pl):    Biblioteki statyczne %{name}
90 Group:          Development/Libraries
91 Group(fr):      Development/Librairies
92 Group(pl):      Programowanie/Biblioteki
93 Requires:       blas-devel = %{version}
94
95 %description -n blas-static
96 Static %{name} libraries.
97
98 %description -l pl -n blas-static
99 Biblioteki statyczne %{name}.
100
101
102 %package -n blas-man
103 Summary:        Man pages for BLAS (Basic Linear Algebra Subprograms) routines.
104 Group:          Documentation
105 Group(pl):      Dokumentacja
106 Obsoletes:      lapack-blas-man
107
108 %description -n blas-man
109 The blas-man package contains documentation for BLAS (Basic Linear
110 Algebra Subprograms) routines, in the form of man pages.
111
112 %package man
113 Summary:        Documentation for the LAPACK numerical linear algebra libraries.
114 Group:          Documentation
115 Group(pl):      Dokumentacja
116
117 %description man
118 Documentation, in the form of man pages, for the LAPACK numerical
119 linear algebra libraries.
120
121
122 %prep
123 %setup -q -n LAPACK
124 %setup -q -D -T -a 1 -n LAPACK
125 %patch0 -p1
126 # directory INSTALL conflicts with file INSTALL needed by automake
127 mv -f INSTALL install
128 >INSTALL
129 >AUTHORS
130 >ChangeLog
131 >NEWS
132 >COPYING
133 >config.h.in
134
135 %build
136 aclocal
137 autoheader
138 automake --add-missing
139 autoconf
140 %configure 
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 %{__make} install DESTDIR=$RPM_BUILD_ROOT
146
147 install -d $RPM_BUILD_ROOT%{_mandir}/manl
148 gzip -9nf blas/man/manl/*.l man/manl/*.l
149 install blas/man/manl/* man/manl/* $RPM_BUILD_ROOT%{_mandir}/manl
150
151 echo "%defattr(644, root, root, 755)" > blasmans.list
152 find blas/man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> blasmans.list
153 echo "%defattr(644, root, root, 755)" > mans.list
154 find man/manl -name "*.gz" -printf "%{_mandir}/manl/%%f\n" >> mans.list
155
156 gzip -9nf README
157
158 %post           -p /sbin/ldconfig
159 %postun         -p /sbin/ldconfig
160 %post   -n blas -p /sbin/ldconfig
161 %postun -n blas -p /sbin/ldconfig
162
163 %clean
164 rm -fr $RPM_BUILD_ROOT
165
166 %files
167 %defattr(644,root,root,755)
168 %doc README*
169 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_libdir}/liblapack.so
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/liblapack.a
178
179 %files -n blas 
180 %defattr(644,root,root,755)
181 %{_libdir}/libblas.so.*.*.*
182
183 %files -n blas-devel
184 %defattr(644,root,root,755)
185 %{_libdir}/libblas.so
186
187 %files -n blas-static
188 %defattr(644,root,root,755)
189 %{_libdir}/libblas.a
190
191
192 %files -n blas-man -f blasmans.list
193 %defattr(644,root,root,755)
194
195 %files man -f mans.list
196 %defattr(644,root,root,755)
This page took 0.076433 seconds and 3 git commands to generate.