]> git.pld-linux.org Git - packages/lapack.git/blob - lapack.spec
- strict internal deps, dropped libtool < 1.5 support
[packages/lapack.git] / lapack.spec
1 Summary:        The LAPACK libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne LAPACK do algebry liniowej
3 Name:           lapack
4 Version:        3.0
5 Release:        18
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://www.netlib.org/lapack/%{name}.tgz
9 # Source0-md5:  a24f59304f87b78cdc7da2ae59c98664
10 Source1:        http://www.netlib.org/lapack/manpages.tgz
11 # Source1-md5:  50efab6cd73a9429584f7f1537f1727f
12 Patch0:         %{name}-automake_support.patch
13 Patch1:         %{name}-20010525.patch
14 URL:            http://www.netlib.org/lapack/
15 BuildRequires:  gcc-g77
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 2:1.5
19 Requires:       blas = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LAPACK (Linear Algebra PACKage) is a standard library for numerical
24 linear algebra. LAPACK provides routines for solving systems of
25 simultaneous linear equations, least-squares solutions of linear
26 systems of equations, eigenvalue problems, and singular value
27 problems. Associated matrix factorizations (LU, Cholesky, QR, SVD,
28 Schur, and generalized Schur) and related computations (i.e.,
29 reordering of Schur factorizations and estimating condition numbers)
30 are also included. LAPACK can handle dense and banded matrices, but
31 not general sparse matrices. Similar functionality is provided for
32 real and complex matrices in both single and double precision. LAPACK
33 is coded in Fortran77.
34
35 %description -l pl
36 LAPACK (Linear Algebra PACKage) jest standardow± bibliotek± numeryczn±
37 do algebry liniowej. Dostarcza funkcje rozwi±zywania: uk³adów równañ
38 liniowych, uk³adów równañ metod± najmniejszych kwadratów, problemów
39 w³asnych. Zawiera algorytmy faktoryzacji macierzy (LU, Cholesky'ego,
40 QR, SVD, Schura, uogólnion± Schura) i zwi±zanych z tym obliczeñ (np.
41 przenumerowywanie w faktoryzacji Schura i estymacjê uwarunkowania).
42 LAPACK mo¿e obs³ugiwaæ macierze blokowe i pasmowe, ale nie rzadkie w
43 ogólnym przypadku. Zapewnia funkcjonalno¶æ dla macierzy rzeczywistych
44 i zespolonych, dla liczb pojedynczej i podwójnej precyzji. LAPACK jest
45 napisany w Fortranie 77.
46
47 %package devel
48 Summary:        LAPACK header files
49 Summary(pl):    Pliki nag³ówkowe LAPACK
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       blas-devel = %{version}-%{release}
53 Obsoletes:      lapack-man
54
55 %description devel
56 LAPACK header files.
57
58 %description devel -l pl
59 Pliki nag³ówkowe LAPACK.
60
61 %package static
62 Summary:        Static LAPACK libraries
63 Summary(pl):    Biblioteki statyczne LAPACK
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static LAPACK libraries.
69
70 %description static -l pl
71 Biblioteki statyczne LAPACK.
72
73 %package -n blas
74 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
75 Summary(pl):    Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
76 Group:          Development/Libraries
77 Obsoletes:      lapack-blas
78
79 %description -n blas
80 BLAS (Basic Linear Algebra Subprograms) is a standard library for
81 numerical algebra. BLAS provides a number of basic algorithms for
82 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
83 77.
84
85 Warning: this is a reference implementation from Netlib. If possible,
86 use version optimized for your architecture instead.
87
88 %description -n blas -l pl
89 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
90 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
91 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
92 w Fortranie 77.
93
94 Ostrze¿enie: to jest implementacja przyk³adowa z repozytorium Netlib.
95 Je¿eli to mo¿liwe, nale¿y u¿ywaæ zamiast niej wersji zoptymalizowanej
96 pod dan± architekturê.
97
98 %package -n blas-devel
99 Summary:        BLAS header files
100 Summary(pl):    Pliki nag³ówkowe BLAS
101 Group:          Development/Libraries
102 Requires:       blas = %{version}-%{release}
103 Obsoletes:      blas-man
104
105 %description -n blas-devel
106 BLAS header files.
107
108 %description -n blas-devel -l pl
109 Pliki nag³ówkowe BLAS.
110
111 %package -n blas-static
112 Summary:        Static BLAS libraries
113 Summary(pl):    Biblioteki statyczne BLAS
114 Group:          Development/Libraries
115 Requires:       blas-devel = %{version}-%{release}
116
117 %description -n blas-static
118 Static BLAS libraries.
119
120 %description -n blas-static -l pl
121 Biblioteki statyczne BLAS.
122
123 %prep
124 %setup -q -a1 -n LAPACK
125 %patch0 -p1
126 %patch1 -p1
127 # directory INSTALL conflicts with file INSTALL needed by automake
128 mv -f INSTALL install
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoheader}
134 %{__autoconf}
135 %{__automake}
136 %configure
137
138 %{__make} \
139         LTTAG="--tag=F77"
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 # present both in blas and lapack
148 rm -f man/manl/{lsame,xerbla}.l
149
150 install -d $RPM_BUILD_ROOT%{_mandir}/man3
151 for d in man/manl/*.l blas/man/manl/*.l ; do
152         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
153 done
154
155 echo "%defattr(644, root, root, 755)" > blasmans.list
156 find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
157 echo "%defattr(644, root, root, 755)" > mans.list
158 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
159
160 %clean
161 rm -fr $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %post   -n blas -p /sbin/ldconfig
167 %postun -n blas -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc README
172 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
173
174 %files devel -f mans.list
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/liblapack.so
177 %{_libdir}/liblapack.la
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/liblapack.a
182
183 %files -n blas
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
186
187 %files -n blas-devel -f blasmans.list
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libblas.so
190 %{_libdir}/libblas.la
191
192 %files -n blas-static
193 %defattr(644,root,root,755)
194 %{_libdir}/libblas.a
This page took 0.069725 seconds and 3 git commands to generate.