]> git.pld-linux.org Git - packages/kismet.git/blob - kismet.spec
- BR: pkgconfig
[packages/kismet.git] / kismet.spec
1 #
2 # TODO: Anybody knows, why it will not build,
3 #       when kernel-headers are installed?
4 #
5 Summary:        Wireless network sniffer
6 Summary(pl.UTF-8):      Sniffer sieci bezprzewodowych
7 Name:           kismet
8 Version:        2010_01_R1
9 %define _ver    2010-01-R1
10 Release:        1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://www.kismetwireless.net/code/%{name}-%{_ver}.tar.gz
14 # Source0-md5:  a6d6edcf65d5bb2cb5de6472bcc16f19
15 URL:            http://www.kismetwireless.net/
16 BuildRequires:  ImageMagick-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gmp-devel
20 BuildRequires:  libpcap-devel >= 2:0.9.4-1
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libwiretap-devel
23 BuildRequires:  ncurses-ext-devel
24 BuildRequires:  pkgconfig
25 # it uses internal structures - so strict deps
26 %requires_eq    libpcap
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Kismet is a 802.11b wireless network sniffer. It is capable of
31 sniffing using almost any wireless card supported in Linux, including
32 Prism2 based cards supported by the Wlan-NG project (Linksys, Dlink,
33 Rangelan, etc), cards which support standard packet capture via
34 libpcap (Cisco), and limited support for cards without RF Monitor
35 support.
36
37 %description -l pl.UTF-8
38 Kismet to sniffer bezprzewodowych sieci 802.11b. Jest zdolny do
39 sniffowania używając prawie dowolnych bezprzewodowych kart sieciowych
40 w Linuksie włączając w to karty Prism2 wspierane przez projekt Wlan-NG
41 (Linksys, Dlink, Rangelan, etc), kart które umożliwiają
42 przechwytywanie pakietów poprzez libpcap (Cisco), oraz ograniczone
43 wsparcie dla kart bez obsługi Monitora RF.
44
45 %prep
46 %setup -q -n %{name}-%{_ver}
47
48 sed -i -e 's#-o $(INSTUSR)##g' -e 's#-o $(INSTGRP)##g' Makefile.in
49
50 %build
51 cp -f /usr/share/automake/config.* .
52 %{__aclocal}
53 %{__autoconf}
54 CPPFLAGS="-I/usr/include/ncurses"
55 %configure \
56         --enable-syspcap \
57         --with-linuxheaders=no \
58         --with-ethereal=%{_includedir} \
59 %ifarch arm
60         --enable-zaurus
61 %endif
62
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_datadir}}
68
69 %{__make} install \
70         INSTGRP=$(id -g) \
71         MANGRP=$(id -g) \
72         prefix=$RPM_BUILD_ROOT%{_prefix} \
73         exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
74         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
75         BIN=$RPM_BUILD_ROOT%{_bindir} \
76         SHARE=$RPM_BUILD_ROOT%{_datadir}/%{name} \
77         MAN=$RPM_BUILD_ROOT%{_mandir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc docs/* CHANGELOG README
85 %attr(755,root,root) %{_bindir}/*
86 %{_datadir}/%{name}
87 %{_mandir}/man?/*
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}*
This page took 0.066316 seconds and 3 git commands to generate.