]> git.pld-linux.org Git - packages/kile.git/blob - kile.spec
- Initial spec for the beta version working with KDE5.
[packages/kile.git] / kile.spec
1 %define         _version        2.1b5
2 Summary:        KDE Integrated LaTeX Environment
3 Summary(pl.UTF-8):      Zintegrowane środowisko LaTeXowe dla KDE
4 Name:           kile
5 Version:        2.9.93
6 Release:        0.1
7 License:        GPL v2
8 Group:          X11/Applications/Publishing
9 Source0:        http://downloads.sourceforge.net/kile/%{name}-%{version}.tar.bz2
10 # Source0-md5:  3fd6bef325eaba51744cc36bfde22097
11 URL:            http://kile.sourceforge.net/
12 Patch0:         %{name}-cmake.patch
13 BuildRequires:  QtNetwork-devel
14 BuildRequires:  QtScript-devel
15 BuildRequires:  QtSvg-devel
16 BuildRequires:  automoc4
17 BuildRequires:  cmake
18 #BuildRequires: kde4-kdelibs-devel >= 4.4.0
19 BuildRequires:  qt4-build
20 BuildRequires:  qt4-qmake
21 BuildRequires:  rpmbuild(macros) >= 1.129
22 Requires:       ka5-kate
23 Requires:       tetex-format-latex
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 KDE Integrated LaTeX Environment. Features:
28
29  - an editor to write your LaTeX source files (syntax highlighting,
30    undo-redo, search-replace, spellcheck ...)
31  - the principal LaTeX tags can be inserted directly with the "LaTeX",
32    "Math" and "Greek" menus
33  - 370 mathematical symbols can be inserted in just one click
34  - wizards to generate code ('Quick document', 'Quick letter', tabular,
35    tabbing and array environments)
36  - LaTeX-related programs can be launched via the "Tools" menu
37  - contextual help in the "Messages / Log File" frame
38  - the standard Bibtex entry types can be inserted in the ".bib" file
39    with the "Bibliography" menu
40  - a "structure view" of the document for easier navigation of a
41    document (by clicking on an item in the "Structure" frame, you can
42    jump directly to the corresponding part of your document
43  - extensive LaTeX documentation
44  - in the "Messages / Log File" frame, you can see information about
45    processes and the logfile after a LaTeX compilation
46  - the "Next Latex Error" and "Previous Latex Error" commands let you
47    reach the LaTeX errors detected by Kile in the log file
48  - by clicking on the number of a line in the log file, the cursor
49    jumps to the corresponding line in the editor
50  - a Gnuplot front end (adaptation of the Xgfe program)
51  - support for "Inverse and Forward Search" with KDVI
52
53 The program's aim is to simplify the edition of LaTeX source code and
54 the use of the LaTeX-related programs for users who want to retain
55 control over their LaTeX documents.
56
57 %description -l pl.UTF-8
58 Zintegrowane środowisko LaTeXowe dla KDE. Możliwości:
59  - edytor do pisania plików źródłowych w LaTeXu (z podświetlaniem
60    składni, cofaniem i powtarzaniem, szukaniem i zastępowaniem, kontrolą
61    pisowni...)
62  - podstawowe znaczniki LaTeXa mogą być wstawiane bezpośrednio z menu
63    "LaTeX", "Math" lub "Greek"
64  - 370 symboli matematycznych może być wstawianych pojedynczym
65    kliknięciem
66  - automaty do generowania kodu ("Szybki dokument", "Szybki list",
67    środowiska tabular, tabbing i array)
68  - programy związane z LaTeXem mogą być uruchamiane z menu "Tools"
69  - kontekstowa pomoc w ramce "Messages / Log File"
70  - standardowe typy wpisów Bibtexa mogą być wstawiane do pliku .bib z
71    menu "Bibliography"
72  - "strukturalny widok" dokumentu dla łatwiejszej nawigacji po
73    dokumencie (poprzez kliknięcie elementu w ramce "Structure", można
74    skoczyć bezpośrednio do odpowiedniej części dokumentu)
75  - obszerna dokumentacja do LaTeXa
76  - w ramce "Messages / Log File" można zobaczyć informacje o
77    przetwarzaniu i plik loga po kompilacji LaTeXa
78  - polecenia "Next Latex Error" i "Previous Latex Error" pozwalają na
79    przechodzenie do miejsc wystąpienia błędów znalezionych przez Kile w
80    pliku loga
81  - po kliknięciu na numerze linii w pliku loga, kursor skacze do
82    odpowiedniej linii w edytorze
83  - interfejs do Gnuplota (adaptacja programu Xgfe)
84  - obsługa "Inverse and Forward Search" w KDVI.
85
86 Celem programu jest uproszczenie edycji kodu źródłowego w LaTeXu i
87 używania programów związanych z LaTeXem dla użytkowników, którzy chcą
88 zachować kontrolę nad dokumentami w LaTeXu.
89
90 %prep
91 %setup -q
92 #%patch0 -p1
93
94 %build
95 install -d build
96 cd build
97 %cmake \
98 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
99 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
100 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
101 -DKILE_VERSION=%{version} \
102 ../
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} -C build install \
109 DESTDIR=$RPM_BUILD_ROOT \
110 kde_htmldir=%{_kdedocdir}
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/*/44x44
113 %{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/*/150x150
114 %{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/*/310x310
115
116 #%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
117
118
119 %find_lang %{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README README.cwl kile-remote-control.txt README.MacOSX 
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/libkdeinit5_kile.so
129 %{_datadir}/kile
130 #%{_datadir}/mimelnk/text/x-kilepr.desktop
131 %{_datadir}/kconf_update/*
132 #%attr(755,root,root) %{_datadir}/kconf_update/kile*_upd.pl
133 %{_datadir}/config.kcfg/kile.kcfg
134 %{_desktopdir}/org.kde.kile.desktop
135 %{_iconsdir}/*/*/apps/*.png
136 %{_iconsdir}/*/*/apps/*.svg
137 %{_docdir}/*
138 %{_datadir}/dbus-1/interfaces/net.sourceforge.kile.main.xml
139 %{_datadir}/mime/packages/kile.xml
140 %{_datadir}/metainfo/org.kde.kile.appdata.xml
141 /etc/xdg/kile.categories
142
This page took 0.121997 seconds and 3 git commands to generate.