]> git.pld-linux.org Git - packages/kf5-threadweaver.git/blob - kf5-threadweaver.spec
- up to 5.4.0
[packages/kf5-threadweaver.git] / kf5-threadweaver.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 # /usr/lib/qt5/qml/org/kde not packaged
4 # /usr/lib/qt5/plugins/kf5
5 # /usr/share/kf5
6 %define         kdeframever     5.4
7 %define         qtver           5.3.2
8 %define         kfname          threadweaver
9
10 Summary:        Helper for multithreaded programming
11 Name:           kf5-%{kfname}
12 Version:        5.4.0
13 Release:        0.1
14 License:        LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
17 # Source0-md5:  605b4e81d3edf061e8562976d29d0c76
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel >= %{qtver}
20 BuildRequires:  Qt5Test-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 ThreadWeaver is a helper for multithreaded programming. It uses a
33 job-based interface to queue tasks and execute them in an efficient
34 way.
35
36 You simply divide the workload into jobs, state the dependencies
37 between the jobs and ThreadWeaver will work out the most efficient way
38 of dividing the work between threads within a set of resource limits.
39
40 See the information on [use cases](@ref usecases) and [why
41 multithreading can help](@ref multithreading), as well as the usage
42 section below, for more detailed information.
43
44 %package devel
45 Summary:        Header files for %{kfname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{kfname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{kfname}.
55
56 %prep
57 %setup -q -n %{kfname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build/ install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.md
82 %attr(755,root,root) %ghost %{_libdir}/libKF5ThreadWeaver.so.5
83 %attr(755,root,root) %{_libdir}/libKF5ThreadWeaver.so.5.4.0
84
85 %files devel
86 %defattr(644,root,root,755)
87 %{_includedir}/KF5/ThreadWeaver
88 %{_includedir}/KF5/threadweaver_version.h
89 %{_libdir}/cmake/KF5ThreadWeaver
90 %{_libdir}/libKF5ThreadWeaver.so
91 %{qt5dir}/mkspecs/modules/qt_ThreadWeaver.pri
This page took 0.178069 seconds and 4 git commands to generate.