]> git.pld-linux.org Git - packages/kf5-threadweaver.git/blob - kf5-threadweaver.spec
tar.xz deps
[packages/kf5-threadweaver.git] / kf5-threadweaver.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 # /usr/lib/qt5/qml/org/kde not packaged
4 # /usr/lib/qt5/plugins/kf5
5 # /usr/share/kf5
6
7 %define         _state          stable
8 %define         orgname         threadweaver
9
10 Summary:        Helper for multithreaded programming
11 Name:           kf5-%{orgname}
12 Version:        5.0.0
13 Release:        0.1
14 License:        LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  23426ad8caacb0e494d870c546a3783c
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel
20 BuildRequires:  Qt5Test-devel
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
23 BuildRequires:  rpmbuild(macros) >= 1.164
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         qt5dir          %{_libdir}/qt5
30
31 %description
32 ThreadWeaver is a helper for multithreaded programming. It uses a
33 job-based interface to queue tasks and execute them in an efficient
34 way.
35
36 You simply divide the workload into jobs, state the dependencies
37 between the jobs and ThreadWeaver will work out the most efficient way
38 of dividing the work between threads within a set of resource limits.
39
40 See the information on [use cases](@ref usecases) and [why
41 multithreading can help](@ref multithreading), as well as the usage
42 section below, for more detailed information.
43
44 %package devel
45 Summary:        Header files for %{orgname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{orgname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{orgname}.
55
56 %prep
57 %setup -q -n %{orgname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DBIN_INSTALL_DIR=%{_bindir} \
64         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
65         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
66         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
67         -DQML_INSTALL_DIR=%{qt5dir}/qml \
68         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
69         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
70         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
71         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
72         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
73         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
74         ../
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build/ install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md
92 %attr(755,root,root) %ghost %{_libdir}/libKF5ThreadWeaver.so.5
93 %attr(755,root,root) %{_libdir}/libKF5ThreadWeaver.so.5.0.0
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/KF5/ThreadWeaver
98 %{_includedir}/KF5/threadweaver_version.h
99 %{_libdir}/cmake/KF5ThreadWeaver
100 %{_libdir}/libKF5ThreadWeaver.so
101 %{qt5dir}/mkspecs/modules/qt_ThreadWeaver.pri
This page took 0.073467 seconds and 4 git commands to generate.