]> git.pld-linux.org Git - packages/kf5-syndication.git/blob - kf5-syndication.spec
- updated to 5.115.0
[packages/kf5-syndication.git] / kf5-syndication.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.115
5 %define         qtver           5.15.2
6 %define         kfname          syndication
7
8 Summary:        syndication
9 Name:           kf5-%{kfname}
10 Version:        5.115.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  0b47f08e5502871d9d7a483b75bb6ac4
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Network-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Xml-devel >= %{qtver}
21 BuildRequires:  cmake >= 3.16
22 BuildRequires:  kf5-extra-cmake-modules >= %{version}
23 BuildRequires:  kf5-kcodecs-devel >= %{version}
24 BuildRequires:  ninja
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       Qt5Core >= %{qtver}
29 Requires:       Qt5Xml >= %{qtver}
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 An RSS/Atom parser library.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 %cmake -B build \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
58
59 %ninja_build -C build
60
61 %if %{with tests}
62 %ninja_build -C build test
63 %endif
64
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.md
79 %{_datadir}/qlogging-categories5/syndication.categories
80 %ghost %{_libdir}/libKF5Syndication.so.5
81 %attr(755,root,root) %{_libdir}/libKF5Syndication.so.5.*.*
82 %{_datadir}/qlogging-categories5/syndication.renamecategories
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_includedir}/KF5/Syndication
87 %{_libdir}/cmake/KF5Syndication
88 %{_libdir}/libKF5Syndication.so
89 %{_libdir}/qt5/mkspecs/modules/qt_Syndication.pri
This page took 0.149815 seconds and 3 git commands to generate.