4e262bb2564ff0c109b676f3810aa6224263ce2b
[packages/kf5-kcmutils.git] / kf5-kcmutils.spec
1 %define         kdeframever     5.39
2 %define         qtver           5.3.2
3 %define         kfname          kcmutils
4
5 Summary:        Utilities for KDE System Settings modules
6 Name:           kf5-%{kfname}
7 Version:        5.39.0
8 Release:        2
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  fbd1d8df73a230632252d22c9309d1c7
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5DBus-devel >= %{qtver}
16 BuildRequires:  Qt5Gui-devel >= %{qtver}
17 BuildRequires:  Qt5Test-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  Qt5Xml-devel >= %{qtver}
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  kf5-attica-devel >= %{version}
23 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
24 BuildRequires:  kf5-kauth-devel >= %{version}
25 BuildRequires:  kf5-kcodecs-devel >= %{version}
26 BuildRequires:  kf5-kcompletion-devel >= %{version}
27 BuildRequires:  kf5-kconfig-devel >= %{version}
28 BuildRequires:  kf5-kconfigwidgets-devel >= %{version}
29 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
30 BuildRequires:  kf5-kdbusaddons-devel >= %{version}
31 BuildRequires:  kf5-kdeclarative-devel >= %{version}
32 BuildRequires:  kf5-kglobalaccel-devel >= %{version}
33 BuildRequires:  kf5-kguiaddons-devel >= %{version}
34 BuildRequires:  kf5-ki18n-devel >= %{version}
35 BuildRequires:  kf5-kiconthemes-devel >= %{version}
36 BuildRequires:  kf5-kitemviews-devel >= %{version}
37 BuildRequires:  kf5-kservice-devel >= %{version}
38 BuildRequires:  kf5-ktextwidgets-devel >= %{version}
39 BuildRequires:  kf5-kwidgetsaddons-devel >= %{version}
40 BuildRequires:  kf5-kwindowsystem-devel >= %{version}
41 BuildRequires:  kf5-kxmlgui-devel >= %{version}
42 BuildRequires:  kf5-sonnet-devel >= %{version}
43 BuildRequires:  rpmbuild(macros) >= 1.164
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires:       kf5-dirs
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         qt5dir          %{_libdir}/qt5
50
51 %description
52 KCMUtils provides various classes to work with KCModules. KCModules
53 can be created with the KConfigWidgets framework.
54
55 %package devel
56 Summary:        Header files for %{kfname} development
57 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
58 Group:          X11/Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       kf5-kconfigwidgets-devel >= %{version}
61
62 %description devel
63 Header files for %{kfname} development.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe dla programistów używających %{kfname}.
67
68 %prep
69 %setup -q -n %{kfname}-%{version}
70
71 %build
72 install -d build
73 cd build
74 %cmake \
75         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
76         ../
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build/ install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %find_lang %{kfname}5
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{kfname}5.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 %attr(755,root,root) %ghost %{_libdir}/libKF5KCMUtils.so.5
97 %attr(755,root,root) %{_libdir}/libKF5KCMUtils.so.*.*
98 %{_datadir}/kservicetypes5/kcmodule.desktop
99 %{_datadir}/kservicetypes5/kcmoduleinit.desktop
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/KF5/KCMUtils
104 %{_includedir}/KF5/kcmutils_version.h
105 %{_libdir}/cmake/KF5KCMUtils
106 %attr(755,root,root) %{_libdir}/libKF5KCMUtils.so
107 %{qt5dir}/mkspecs/modules/qt_KCMUtils.pri
This page took 0.099955 seconds and 2 git commands to generate.