]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 3.8.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 28 Feb 2013 14:18:09 +0000 (15:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 28 Feb 2013 14:18:09 +0000 (15:18 +0100)
kernel-small_fixes.patch
kernel.spec

index 0660f7e9c47418fa4f7a2c15bbce828915779c2f..ebdc93f473a065ec85d2d6100eb28933bc3c7828 100644 (file)
@@ -49,34 +49,3 @@ index 7a0c800..ec5ebbb 100644
 -- 
 1.7.7.3
 
-
-commit 6e601a53566d84e1ffd25e7b6fe0b6894ffd79c0
-Author: Mathias Krause <minipli@googlemail.com>
-Date:   Sat Feb 23 01:13:47 2013 +0000
-
-    sock_diag: Fix out-of-bounds access to sock_diag_handlers[]
-    
-    Userland can send a netlink message requesting SOCK_DIAG_BY_FAMILY
-    with a family greater or equal then AF_MAX -- the array size of
-    sock_diag_handlers[]. The current code does not test for this
-    condition therefore is vulnerable to an out-of-bound access opening
-    doors for a privilege escalation.
-    
-    Signed-off-by: Mathias Krause <minipli@googlemail.com>
-    Acked-by: Eric Dumazet <edumazet@google.com>
-    Signed-off-by: David S. Miller <davem@davemloft.net>
-
-diff --git a/net/core/sock_diag.c b/net/core/sock_diag.c
-index 602cd63..750f44f 100644
---- a/net/core/sock_diag.c
-+++ b/net/core/sock_diag.c
-@@ -121,6 +121,9 @@ static int __sock_diag_rcv_msg(struct sk_buff *skb, struct nlmsghdr *nlh)
-       if (nlmsg_len(nlh) < sizeof(*req))
-               return -EINVAL;
-+      if (req->sdiag_family >= AF_MAX)
-+              return -EINVAL;
-+
-       hndl = sock_diag_lock_handler(req->sdiag_family);
-       if (hndl == NULL)
-               err = -ENOENT;
index 11c6438653ff36b7de0eab8a20e02d3ad3d3600e..65dd9fa52e644829c5fad01ae61fe3b73b5528c0 100644 (file)
@@ -68,7 +68,7 @@
 
 %define                rel             0.1
 %define                basever         3.8
-%define                postver         .0
+%define                postver         .1
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -111,7 +111,7 @@ Source0:    http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
 # Source0-md5: 1c738edfc54e7c65faeb90c436104e2f
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.bz2
-# Patch0-md5:  8d176cf61afaafa3c621833a8f8d2c62
+# Patch0-md5:  5bee6b12baef607b0ed4be5cd7d34a48
 %endif
 
 Source3:       kernel-autoconf.h
This page took 3.505727 seconds and 4 git commands to generate.