]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- rel 3; v2 version of the patch auto/th/kernel-4.19-4.19.16-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 26 Jan 2019 13:25:50 +0000 (14:25 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 26 Jan 2019 13:25:50 +0000 (14:25 +0100)
kernel-small_fixes.patch
kernel.spec

index 196102743c4119649f651a8f1394ee3b49f7070e..c14499f52af3afbd1d3b6a0f1d3cae775a0589b3 100644 (file)
@@ -162,10 +162,11 @@ index 76c92e31afc0..abb5d382f64d 100644
 -- 
 cgit 1.2-0.3.lf.el7
 
-From 48744b6339cf649a69b55997e138c17df1ecc897 Mon Sep 17 00:00:00 2001\r
+
+From 9c9e935fc038342c48461aabca666f1b544e32b1 Mon Sep 17 00:00:00 2001\r
 From: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>\r
-Date: Sat, 26 Jan 2019 20:00:51 +0900\r
-Subject: [PATCH] oom, oom_reaper: do not enqueue same task twice\r
+Date: Sat, 26 Jan 2019 21:57:25 +0900\r
+Subject: [PATCH v2] oom, oom_reaper: do not enqueue same task twice\r
 \r
 Arkadiusz reported that enabling memcg's group oom killing causes\r
 strange memcg statistics where there is no task in a memcg despite\r
@@ -182,20 +183,19 @@ request.
 \r
 Fix this bug using an approach used by commit 855b018325737f76\r
 ("oom, oom_reaper: disable oom_reaper for oom_kill_allocating_task").\r
-Since task_will_free_mem(p) == false if p->mm == NULL, we can assume that\r
-p->mm != NULL when wake_oom_reaper() is called from task_will_free_mem()\r
-paths. As a side effect of this patch, this patch also avoids enqueuing\r
+As a side effect of this patch, this patch also avoids enqueuing\r
 multiple threads sharing memory via task_will_free_mem(current) path.\r
 \r
 Signed-off-by: Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>\r
-Reported-by: Arkadiusz Miśkiewicz <a.miskiewicz@gmail.com>\r
+Reported-by: Arkadiusz Miśkiewicz <arekm@maven.pl>\r
+Tested-by: Arkadiusz Miśkiewicz <arekm@maven.pl>\r
 Fixes: af8e15cc85a25315 ("oom, oom_reaper: do not enqueue task if it is on the oom_reaper_list head")\r
 ---\r
- mm/oom_kill.c | 28 +++++++++++++---------------\r
- 1 file changed, 13 insertions(+), 15 deletions(-)\r
+ mm/oom_kill.c | 17 +++++++----------\r
+ 1 file changed, 7 insertions(+), 10 deletions(-)\r
 \r
 diff --git a/mm/oom_kill.c b/mm/oom_kill.c\r
-index f0e8cd9..457f240 100644\r
+index f0e8cd9..057bfee 100644\r
 --- a/mm/oom_kill.c\r
 +++ b/mm/oom_kill.c\r
 @@ -505,14 +505,6 @@ bool __oom_reap_task_mm(struct mm_struct *mm)\r
@@ -213,12 +213,9 @@ index f0e8cd9..457f240 100644
        for (vma = mm->mmap ; vma; vma = vma->vm_next) {\r
                if (!can_madv_dontneed_vma(vma))\r
                        continue;\r
-@@ -645,10 +637,15 @@ static int oom_reaper(void *unused)\r
-       return 0;\r
- }\r
+@@ -647,8 +639,13 @@ static int oom_reaper(void *unused)\r
  \r
--static void wake_oom_reaper(struct task_struct *tsk)\r
-+static void wake_oom_reaper(struct task_struct *tsk, struct mm_struct *mm)\r
+ static void wake_oom_reaper(struct task_struct *tsk)\r
  {\r
 -      /* tsk is already queued? */\r
 -      if (tsk == oom_reaper_list || tsk->oom_reaper_list)\r
@@ -228,47 +225,10 @@ index f0e8cd9..457f240 100644
 +       * should imply barriers already and the reader would hit a page fault\r
 +       * if it stumbled over a reaped memory.\r
 +       */\r
-+      if (test_and_set_bit(MMF_UNSTABLE, &mm->flags))\r
++      if (test_and_set_bit(MMF_UNSTABLE, &tsk->signal->oom_mm->flags))\r
                return;\r
  \r
        get_task_struct(tsk);\r
-@@ -668,7 +665,8 @@ static int __init oom_init(void)\r
- }\r
- subsys_initcall(oom_init)\r
- #else\r
--static inline void wake_oom_reaper(struct task_struct *tsk)\r
-+static inline void wake_oom_reaper(struct task_struct *tsk,\r
-+                                 struct mm_struct *mm)\r
- {\r
- }\r
- #endif /* CONFIG_MMU */\r
-@@ -915,7 +913,7 @@ static void __oom_kill_process(struct task_struct *victim)\r
-       rcu_read_unlock();\r
\r
-       if (can_oom_reap)\r
--              wake_oom_reaper(victim);\r
-+              wake_oom_reaper(victim, mm);\r
\r
-       mmdrop(mm);\r
-       put_task_struct(victim);\r
-@@ -955,7 +953,7 @@ static void oom_kill_process(struct oom_control *oc, const char *message)\r
-       task_lock(p);\r
-       if (task_will_free_mem(p)) {\r
-               mark_oom_victim(p);\r
--              wake_oom_reaper(p);\r
-+              wake_oom_reaper(p, p->mm);\r
-               task_unlock(p);\r
-               put_task_struct(p);\r
-               return;\r
-@@ -1085,7 +1083,7 @@ bool out_of_memory(struct oom_control *oc)\r
-        */\r
-       if (task_will_free_mem(current)) {\r
-               mark_oom_victim(current);\r
--              wake_oom_reaper(current);\r
-+              wake_oom_reaper(current, current->mm);\r
-               return true;\r
-       }\r
\r
 -- \r
 1.8.3.1\r
 \r
index 551409d6bba0c7acb4e21fa7a2d0f195d5d764db..2bbf62a1f8d23876884d0c4ea5b2b8e393f071bf 100644 (file)
@@ -68,7 +68,7 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             2
+%define                rel             3
 %define                basever         4.19
 %define                postver         .16
 
This page took 0.596271 seconds and 4 git commands to generate.