]> git.pld-linux.org Git - packages/kernel.git/commitdiff
- up to 4.19.55; improved xfs writeback support (from xfs ml)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Jun 2019 05:54:04 +0000 (07:54 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 25 Jun 2019 05:54:04 +0000 (07:54 +0200)
kernel-small_fixes.patch
kernel.spec

index 30bd2ed5a58f1939377f7e25368bde525997683f..2674f5c5fb8db3fc4dc47f5652758fdc3e85f684 100644 (file)
-From: Shaohua Li <shli@fb.com>
-
-Basically this is a copy of commit 001e4a8775f6(ext4: implement cgroup
-writeback support). Tested with a fio test, verified writeback is
-throttled against cgroup io.max write bandwidth, also verified moving
-the fio test to another cgroup and the writeback is throttled against
-new cgroup setting.
-
-Cc: Tejun Heo <tj@kernel.org>
-Signed-off-by: Shaohua Li <shli@fb.com>
----
- fs/xfs/xfs_aops.c  | 2 ++
- fs/xfs/xfs_super.c | 1 +
- 2 files changed, 3 insertions(+)
-
---- linux-4.19/fs/xfs/xfs_aops.c.org   2018-11-21 10:31:12.348955352 +0100
-+++ linux-4.19/fs/xfs/xfs_aops.c       2018-11-21 10:34:35.241764742 +0100
-@@ -613,8 +613,10 @@ xfs_add_to_ioend(
-                       list_add(&wpc->ioend->io_list, iolist);
-               wpc->ioend = xfs_alloc_ioend(inode, wpc->io_type, offset,
-                               bdev, sector);
-+              wbc_init_bio(wbc, wpc->ioend->io_bio);
-       }
-+      wbc_account_io(wbc, page, len);
-       if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff)) {
-               if (iop)
-                       atomic_inc(&iop->write_count);
-diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c
-index 584cf2d..aea3bc2 100644
---- a/fs/xfs/xfs_super.c
-+++ b/fs/xfs/xfs_super.c
-@@ -1634,6 +1634,7 @@ xfs_fs_fill_super(
-       sb->s_max_links = XFS_MAXLINK;
-       sb->s_time_gran = 1;
-       set_posix_acl_flag(sb);
-+      sb->s_iflags |= SB_I_CGROUPWB;
-       /* version 5 superblocks support inode version counters. */
-       if (XFS_SB_VERSION_NUM(&mp->m_sb) == XFS_SB_VERSION_5)
-
-
+Move setting up operation and write hint to xfs_alloc_ioend, and\r
+then just copy over all needed information from the previous bio\r
+in xfs_chain_bio and stop passing various parameters to it.\r
+\r
+Signed-off-by: Christoph Hellwig <hch@lst.de>\r
+---\r
+ fs/xfs/xfs_aops.c | 35 +++++++++++++++++------------------\r
+ 1 file changed, 17 insertions(+), 18 deletions(-)\r
+\r
+diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c\r
+index a6f0f4761a37..9cceb90e77c5 100644\r
+--- a/fs/xfs/xfs_aops.c\r
++++ b/fs/xfs/xfs_aops.c\r
+@@ -665,7 +665,6 @@ xfs_submit_ioend(\r
\r
+       ioend->io_bio->bi_private = ioend;\r
+       ioend->io_bio->bi_end_io = xfs_end_bio;\r
+-      ioend->io_bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
\r
+       /*\r
+        * If we are failing the IO now, just mark the ioend with an\r
+@@ -679,7 +678,6 @@ xfs_submit_ioend(\r
+               return status;\r
+       }\r
\r
+-      ioend->io_bio->bi_write_hint = ioend->io_inode->i_write_hint;\r
+       submit_bio(ioend->io_bio);\r
+       return 0;\r
+ }\r
+@@ -691,7 +689,8 @@ xfs_alloc_ioend(\r
+       xfs_exntst_t            state,\r
+       xfs_off_t               offset,\r
+       struct block_device     *bdev,\r
+-      sector_t                sector)\r
++      sector_t                sector,\r
++      struct writeback_control *wbc)\r
+ {\r
+       struct xfs_ioend        *ioend;\r
+       struct bio              *bio;\r
+@@ -699,6 +698,8 @@ xfs_alloc_ioend(\r
+       bio = bio_alloc_bioset(GFP_NOFS, BIO_MAX_PAGES, &xfs_ioend_bioset);\r
+       bio_set_dev(bio, bdev);\r
+       bio->bi_iter.bi_sector = sector;\r
++      bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
++      bio->bi_write_hint = inode->i_write_hint;\r
\r
+       ioend = container_of(bio, struct xfs_ioend, io_inline_bio);\r
+       INIT_LIST_HEAD(&ioend->io_list);\r
+@@ -719,24 +720,22 @@ xfs_alloc_ioend(\r
+  * so that the bi_private linkage is set up in the right direction for the\r
+  * traversal in xfs_destroy_ioend().\r
+  */\r
+-static void\r
++static struct bio *\r
+ xfs_chain_bio(\r
+-      struct xfs_ioend        *ioend,\r
+-      struct writeback_control *wbc,\r
+-      struct block_device     *bdev,\r
+-      sector_t                sector)\r
++      struct bio              *prev)\r
+ {\r
+       struct bio *new;\r
\r
+       new = bio_alloc(GFP_NOFS, BIO_MAX_PAGES);\r
+-      bio_set_dev(new, bdev);\r
+-      new->bi_iter.bi_sector = sector;\r
+-      bio_chain(ioend->io_bio, new);\r
+-      bio_get(ioend->io_bio);         /* for xfs_destroy_ioend */\r
+-      ioend->io_bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
+-      ioend->io_bio->bi_write_hint = ioend->io_inode->i_write_hint;\r
+-      submit_bio(ioend->io_bio);\r
+-      ioend->io_bio = new;\r
++      bio_copy_dev(new, prev);\r
++      new->bi_iter.bi_sector = bio_end_sector(prev);\r
++      new->bi_opf = prev->bi_opf;\r
++      new->bi_write_hint = prev->bi_write_hint;\r
++\r
++      bio_chain(prev, new);\r
++      bio_get(prev);          /* for xfs_destroy_ioend */\r
++      submit_bio(prev);\r
++      return new;\r
+ }\r
\r
+ /*\r
+@@ -614,14 +614,14 @@ xfs_add_to_ioend(\r
+               if (wpc->ioend)\r
+                       list_add(&wpc->ioend->io_list, iolist);\r
+               wpc->ioend = xfs_alloc_ioend(inode, wpc->io_type, offset,\r
+-                              bdev, sector);\r
++                              bdev, sector, wbc);\r
+       }\r
\r
+       if (!__bio_try_merge_page(wpc->ioend->io_bio, page, len, poff)) {\r
+               if (iop)\r
+                       atomic_inc(&iop->write_count);\r
+               if (bio_full(wpc->ioend->io_bio))\r
+-                      xfs_chain_bio(wpc->ioend, wbc, bdev, sector);\r
++                      wpc->ioend->io_bio = xfs_chain_bio(wpc->ioend->io_bio);\r
+               __bio_add_page(wpc->ioend->io_bio, page, len, poff);\r
+       }\r
\r
+-- \r
+2.20.1\r
+\r
+\r
+Link every newly allocated writeback bio to cgroup pointed to by the\r
+writeback control structure, and charge every byte written back to it.\r
+\r
+Tested-by: Stefan Priebe - Profihost AG <s.priebe@profihost.ag>\r
+Signed-off-by: Christoph Hellwig <hch@lst.de>\r
+---\r
+ fs/xfs/xfs_aops.c  | 4 +++-\r
+ fs/xfs/xfs_super.c | 2 ++\r
+ 2 files changed, 5 insertions(+), 1 deletion(-)\r
+\r
+diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c\r
+index 9cceb90e77c5..73c291aeae17 100644\r
+--- a/fs/xfs/xfs_aops.c\r
++++ b/fs/xfs/xfs_aops.c\r
+@@ -700,6 +700,7 @@ xfs_alloc_ioend(\r
+       bio->bi_iter.bi_sector = sector;\r
+       bio->bi_opf = REQ_OP_WRITE | wbc_to_write_flags(wbc);\r
+       bio->bi_write_hint = inode->i_write_hint;\r
++      wbc_init_bio(wbc, bio);\r
\r
+       ioend = container_of(bio, struct xfs_ioend, io_inline_bio);\r
+       INIT_LIST_HEAD(&ioend->io_list);\r
+@@ -727,7 +728,7 @@ xfs_chain_bio(\r
+       struct bio *new;\r
\r
+       new = bio_alloc(GFP_NOFS, BIO_MAX_PAGES);\r
+-      bio_copy_dev(new, prev);\r
++      bio_copy_dev(new, prev);/* also copies over blkcg information */\r
+       new->bi_iter.bi_sector = bio_end_sector(prev);\r
+       new->bi_opf = prev->bi_opf;\r
+       new->bi_write_hint = prev->bi_write_hint;\r
+@@ -782,6 +783,7 @@ xfs_add_to_ioend(\r
+       }\r
\r
+       wpc->ioend->io_size += len;\r
++      wbc_account_io(wbc, page, len);\r
+ }\r
\r
+ STATIC void\r
+diff --git a/fs/xfs/xfs_super.c b/fs/xfs/xfs_super.c\r
+index 594c119824cc..ee0df8f611ff 100644\r
+--- a/fs/xfs/xfs_super.c\r
++++ b/fs/xfs/xfs_super.c\r
+@@ -1685,6 +1685,8 @@ xfs_fs_fill_super(\r
+       sb->s_maxbytes = xfs_max_file_offset(sb->s_blocksize_bits);\r
+       sb->s_max_links = XFS_MAXLINK;\r
+       sb->s_time_gran = 1;\r
++      sb->s_iflags |= SB_I_CGROUPWB;\r
++\r
+       set_posix_acl_flag(sb);\r
\r
+       /* version 5 superblocks support inode version counters. */\r
+-- \r
+2.20.1\r
+\r
index ced2efa25b712fa75fc99dcf2df88fa3d6b1c09f..19f716038e94ba2ab52f35f4436491f1e3770b05 100644 (file)
@@ -70,7 +70,7 @@
 
 %define                rel             1
 %define                basever         4.19
-%define                postver         .53
+%define                postver         .55
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       -%{basever}
@@ -124,7 +124,7 @@ Source0:    https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
 # Source0-md5: 740a90cf810c2105df8ee12e5d0bb900
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  1a8c9115a84cbd449e14e4800c80876b
+# Patch0-md5:  826042721d8935724c3494eef5d70660
 %endif
 Source1:       kernel.sysconfig
 
This page took 0.077502 seconds and 4 git commands to generate.